aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-11-01 03:23:26 +0800
committeralepulver <alepulver@FreeBSD.org>2006-11-01 03:23:26 +0800
commit768aab1349d79174974cc3c54d4b4a6c1389a9a3 (patch)
tree175e9bae6aec9ec74acccd1a727d7a4ab63dc8ef /games
parentddb7d9fce47dddef272833edc508a53ebfba64db (diff)
downloadfreebsd-ports-gnome-768aab1349d79174974cc3c54d4b4a6c1389a9a3.tar.gz
freebsd-ports-gnome-768aab1349d79174974cc3c54d4b4a6c1389a9a3.tar.zst
freebsd-ports-gnome-768aab1349d79174974cc3c54d4b4a6c1389a9a3.zip
Slump is a random map generator for FreeDoom that is based on David M. Chess'
SLIGE map generator. Basically Slump is a fork of SLIGE that is optimized for making FreeDoom maps. In particular, Slump only places monsters that the FreeDoom artists have drawn in to maps; this way one can play FreeDoom without feeling that the game is incomplete. WWW: http://www.samiam.org/slump.html
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/slump/Makefile31
-rw-r--r--games/slump/distinfo3
-rw-r--r--games/slump/files/patch-dump.c15
-rw-r--r--games/slump/pkg-descr9
5 files changed, 59 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 2e1fbc896ab0..6762e8ef13d5 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -641,6 +641,7 @@
SUBDIR += sl
SUBDIR += slashem-tty
SUBDIR += slige
+ SUBDIR += slump
SUBDIR += slune
SUBDIR += smiley
SUBDIR += sokoban
diff --git a/games/slump/Makefile b/games/slump/Makefile
new file mode 100644
index 000000000000..bcfed32d48d3
--- /dev/null
+++ b/games/slump/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: slump
+# Date created: 2006-10-09
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= slump
+PORTVERSION= 0.003.01
+CATEGORIES= games
+MASTER_SITES= http://www.samiam.org/software/
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Fork of SLIGE that is optimized for making FreeDoom maps
+
+USE_BZIP2= yes
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^FLAGS =|& $${CFLAGS}|' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/slump/distinfo b/games/slump/distinfo
new file mode 100644
index 000000000000..18010af989ea
--- /dev/null
+++ b/games/slump/distinfo
@@ -0,0 +1,3 @@
+MD5 (slump-0.003.01.tar.bz2) = ef3944131efeba004dae7b8fac0073ff
+SHA256 (slump-0.003.01.tar.bz2) = 196d358565e380e0ed5590167a63e06802ad46bf11fb45c0f2814a4905bd42d5
+SIZE (slump-0.003.01.tar.bz2) = 115443
diff --git a/games/slump/files/patch-dump.c b/games/slump/files/patch-dump.c
new file mode 100644
index 000000000000..44bf886aaa69
--- /dev/null
+++ b/games/slump/files/patch-dump.c
@@ -0,0 +1,15 @@
+--- ./dump.c.orig Sun May 29 23:48:57 2005
++++ ./dump.c Mon Oct 9 23:53:07 2006
+@@ -36,6 +36,12 @@
+ #include <assert.h>
+ #include "slump.h"
+
++#include <machine/endian.h>
++
++#if BYTE_ORDER == BIG_ENDIAN
++#define ENDIAN_BIG
++#endif
++
+ /* Global variables */
+
+ extern int current_level_number;
diff --git a/games/slump/pkg-descr b/games/slump/pkg-descr
new file mode 100644
index 000000000000..8d8b0384ece3
--- /dev/null
+++ b/games/slump/pkg-descr
@@ -0,0 +1,9 @@
+Slump is a random map generator for FreeDoom that is based on David M. Chess'
+SLIGE map generator.
+
+Basically Slump is a fork of SLIGE that is optimized for making FreeDoom maps.
+In particular, Slump only places monsters that the FreeDoom artists have drawn
+in to maps; this way one can play FreeDoom without feeling that the game is
+incomplete.
+
+WWW: http://www.samiam.org/slump.html