aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-10 06:29:38 +0800
committerkrion <krion@FreeBSD.org>2004-01-10 06:29:38 +0800
commit782fcc6f9b4e10ab67fa9b927747081ec5dc2136 (patch)
tree8962b287e38d729683c75d3e07d9910dd667a402 /games
parentc413e682e1e10d5b83c83eea6f34f0a4674cf3ba (diff)
downloadfreebsd-ports-gnome-782fcc6f9b4e10ab67fa9b927747081ec5dc2136.tar.gz
freebsd-ports-gnome-782fcc6f9b4e10ab67fa9b927747081ec5dc2136.tar.zst
freebsd-ports-gnome-782fcc6f9b4e10ab67fa9b927747081ec5dc2136.zip
- Update to version 0.1722b
- Port is not FORBIDDEN anymore PR: 61146 Submitted by: maintainer
Diffstat (limited to 'games')
-rw-r--r--games/mvdsv/Makefile16
-rw-r--r--games/mvdsv/distinfo2
-rw-r--r--games/mvdsv/files/Makefile2
-rw-r--r--games/mvdsv/files/patch-sv_demo.c2
-rw-r--r--games/mvdsv/files/patch-sv_login.c47
-rw-r--r--games/mvdsv/files/patch-sv_sv_main.c54
-rw-r--r--games/mvdsv/files/patch-sv_sys_unix.c27
7 files changed, 10 insertions, 140 deletions
diff --git a/games/mvdsv/Makefile b/games/mvdsv/Makefile
index 7de18a08bfce..81edde142d4d 100644
--- a/games/mvdsv/Makefile
+++ b/games/mvdsv/Makefile
@@ -6,21 +6,22 @@
#
PORTNAME= mvdsv
-PORTVERSION= 0.165b
+PORTVERSION= 0.1722
CATEGORIES= games
-MASTER_SITES= http://www.wsb.poznan.pl/~pawel/q/q/ktpro/develop/ \
+MASTER_SITES= http://www.wsb.poznan.pl/~pawel/q/q/ktpro/ \
http://freebsd.nsu.ru/distfiles/
-DISTNAME= qwex_src-${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= danfe@regency.nsu.ru
COMMENT= Enhanced QuakeWorld server with multi-view demos capability
-FORBIDDEN= Remote buffer overflow exists
-
MAKEFILE= ${FILESDIR}/Makefile
-WRKSRC= ${WRKDIR}/mvdsrc/source
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/vvd/${PORTNAME}${PORTVERSION}b/source
pre-everything::
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "Define WITH_OPTIMIZED_CFLAGS to enable extra optimization options"
+.endif
.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
@${ECHO_MSG} "Define WITHOUT_X86_ASM to disable x86 assembly code"
.endif
@@ -28,7 +29,4 @@ pre-everything::
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-post-install:
- @${SED} -e 's#$${PREFIX}#${PREFIX}#g' ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/games/mvdsv/distinfo b/games/mvdsv/distinfo
index f2219dd1a81f..98d5670be6b3 100644
--- a/games/mvdsv/distinfo
+++ b/games/mvdsv/distinfo
@@ -1 +1 @@
-MD5 (qwex_src-0.165b.tar.gz) = 69329a418fedafb43277acae8d5aca10
+MD5 (mvdsv-0.1722.tar.gz) = 141760e87b64508fc0a66fc2dc9776c7
diff --git a/games/mvdsv/files/Makefile b/games/mvdsv/files/Makefile
index 962d9ab418ff..36457164905c 100644
--- a/games/mvdsv/files/Makefile
+++ b/games/mvdsv/files/Makefile
@@ -11,7 +11,7 @@
# Created on Wednesday, May 21 2003 by Alexey Dokuchaev <danfe@regency.nsu.ru>
#
-DO_CFLAGS = ${CFLAGS} -funsigned-char -I${LOCALBASE}/include -DSERVERONLY
+DO_CFLAGS = ${CFLAGS} -funsigned-char -I${LOCALBASE}/include -DSERVERONLY -Dstricmp=strcasecmp
.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
DO_CFLAGS += -Did386
diff --git a/games/mvdsv/files/patch-sv_demo.c b/games/mvdsv/files/patch-sv_demo.c
index c2a5f7fef26b..8456271e3281 100644
--- a/games/mvdsv/files/patch-sv_demo.c
+++ b/games/mvdsv/files/patch-sv_demo.c
@@ -1,6 +1,6 @@
--- sv_demo.c.orig Tue Jun 3 17:50:02 2003
+++ sv_demo.c Tue Jun 3 17:53:09 2003
-@@ -607,12 +607,12 @@
+@@ -610,12 +610,12 @@
{
if (!USACACHE)
{
diff --git a/games/mvdsv/files/patch-sv_login.c b/games/mvdsv/files/patch-sv_login.c
deleted file mode 100644
index cc7e5106b940..000000000000
--- a/games/mvdsv/files/patch-sv_login.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- sv_login.c.orig Tue Jun 3 17:47:04 2003
-+++ sv_login.c Tue Jun 3 17:48:21 2003
-@@ -244,7 +244,7 @@
- continue;
- }
-
-- if (!stricmp(accounts[i].login, Cmd_Argv(1)) || (use == use_ip && !stricmp(accounts[i].login, Cmd_Argv(2))))
-+ if (!strcasecmp(accounts[i].login, Cmd_Argv(1)) || (use == use_ip && !strcasecmp(accounts[i].login, Cmd_Argv(2))))
- break;
-
- c++;
-@@ -298,7 +298,7 @@
- if (accounts[i].state == a_free)
- continue;
-
-- if (!stricmp(accounts[i].login, Cmd_Argv(1)))
-+ if (!strcasecmp(accounts[i].login, Cmd_Argv(1)))
- {
- if (accounts[i].inuse)
- SV_Logout(&svs.clients[accounts[i].inuse -1]);
-@@ -365,7 +365,7 @@
- if (accounts[i].state == a_free)
- continue;
-
-- if (!stricmp(accounts[i].login, Cmd_Argv(1)))
-+ if (!strcasecmp(accounts[i].login, Cmd_Argv(1)))
- {
- if (block)
- {
-@@ -434,7 +434,7 @@
- continue;
-
- if (use == accounts[i].use &&
-- /*use == use_log && accounts[i].use == use_log && */!stricmp(log, accounts[i].login))
-+ /*use == use_log && accounts[i].use == use_log && */!strcasecmp(log, accounts[i].login))
- {
- if (accounts[i].inuse && accounts[i].use == use_log)
- return -1;
-@@ -442,7 +442,7 @@
- if (accounts[i].state == a_blocked)
- return -2;
-
-- if (use == use_ip || !stricmp(pass, accounts[i].pass)) {
-+ if (use == use_ip || !strcasecmp(pass, accounts[i].pass)) {
- accounts[i].failures = 0;
- accounts[i].inuse++;
- return i+1;
diff --git a/games/mvdsv/files/patch-sv_sv_main.c b/games/mvdsv/files/patch-sv_sv_main.c
deleted file mode 100644
index 4ced211b2cce..000000000000
--- a/games/mvdsv/files/patch-sv_sv_main.c
+++ /dev/null
@@ -1,54 +0,0 @@
---- sv_main.c.orig Tue Jun 3 17:53:39 2003
-+++ sv_main.c Tue Jun 3 17:56:11 2003
-@@ -646,7 +646,7 @@
- vip = SV_VIPbyIP(net_from);
-
- if (spectator_password.string[0] &&
-- stricmp(spectator_password.string, "none") &&
-+ strcasecmp(spectator_password.string, "none") &&
- strcmp(spectator_password.string, s) )
- { // failed
- spass = false;
-@@ -671,7 +671,7 @@
- vip = SV_VIPbyIP(net_from);
-
- if (!vip && password.string[0] &&
-- stricmp(password.string, "none") &&
-+ strcasecmp(password.string, "none") &&
- strcmp(password.string, s) )
- {
- Con_Printf ("%s:password failed\n", NET_AdrToString (net_from));
-@@ -1403,13 +1403,13 @@
- {
- int i;
-
-- if (!vip_password.string[0] || !stricmp(vip_password.string, "none"))
-+ if (!vip_password.string[0] || !strcasecmp(vip_password.string, "none"))
- return 0;
-
- Cmd_TokenizeString(vip_password.string);
-
- for (i = 0; i < Cmd_Argc(); i++)
-- if (!strcmp(Cmd_Argv(i), pass) && stricmp(Cmd_Argv(i), "none"))
-+ if (!strcmp(Cmd_Argv(i), pass) && strcasecmp(Cmd_Argv(i), "none"))
- return i+1;
-
- return 0;
-@@ -2205,7 +2205,7 @@
- val = Info_ValueForKey (cl->userinfo, "name");
- }
-
-- if (!val[0] || !stricmp(val, "console")) {
-+ if (!val[0] || !strcasecmp(val, "console")) {
- Info_SetValueForKey (cl->userinfo, "name", "unnamed", MAX_INFO_STRING);
- val = Info_ValueForKey (cl->userinfo, "name");
- }
-@@ -2215,7 +2215,7 @@
- for (i=0, client = svs.clients ; i<MAX_CLIENTS ; i++, client++) {
- if (client->state != cs_spawned || client == cl)
- continue;
-- if (!stricmp(client->name, val))
-+ if (!strcasecmp(client->name, val))
- break;
- }
- if (i != MAX_CLIENTS) { // dup name
diff --git a/games/mvdsv/files/patch-sv_sys_unix.c b/games/mvdsv/files/patch-sv_sys_unix.c
deleted file mode 100644
index 06de97204c5a..000000000000
--- a/games/mvdsv/files/patch-sv_sys_unix.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- sv_sys_unix.c.orig Tue Jun 3 17:53:55 2003
-+++ sv_sys_unix.c Tue Jun 3 17:59:41 2003
-@@ -24,7 +24,7 @@
- #include <libc.h>
- #endif
-
--#if defined(__linux__) || defined(sun) || defined(__GNUC__)
-+#if defined(__linux__) || defined(__FreeBSD__) || defined(sun) || defined(__GNUC__)
- #include <sys/stat.h>
- #include <unistd.h>
- #include <sys/time.h>
-@@ -364,7 +364,7 @@
- =============
- */
-
--void main (int argc, char *argv[])
-+int main (int argc, char *argv[])
- {
- double time, oldtime, newtime;
- quakeparms_t parms;
-@@ -444,5 +444,6 @@
- usleep (sys_extrasleep.value);
- }
- #endif
-+ return (1); /* should never reach here */
- }
-