aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-29 01:01:31 +0800
committerpav <pav@FreeBSD.org>2004-03-29 01:01:31 +0800
commit7f8603c957151f4b672250e14d766980d68246ed (patch)
tree233e12abd141698cbb4ecfc8f52e91cf256fbfe4 /games
parent130eed025b466de84844cf791c7ab7f2b7b16508 (diff)
downloadfreebsd-ports-gnome-7f8603c957151f4b672250e14d766980d68246ed.tar.gz
freebsd-ports-gnome-7f8603c957151f4b672250e14d766980d68246ed.tar.zst
freebsd-ports-gnome-7f8603c957151f4b672250e14d766980d68246ed.zip
- Update to 141
PR: ports/62895 (based on) Submitted by: No Name <arundel@gmx.net> Approved by: maintainer timeout (6 weeks)
Diffstat (limited to 'games')
-rw-r--r--games/doomlegacy/Makefile63
-rw-r--r--games/doomlegacy/distinfo6
-rw-r--r--games/doomlegacy/files/patch-doomlegacy::linux_x::i_sound.c11
-rw-r--r--games/doomlegacy/files/patch-doomlegacy::linux_x::linux.c11
-rw-r--r--games/doomlegacy/files/patch-doomlegacy::t_prepro.h17
-rw-r--r--games/doomlegacy/files/patch-makefile39
-rw-r--r--games/doomlegacy/files/wrapper.sh6
-rw-r--r--games/doomlegacy/pkg-descr2
-rw-r--r--games/doomlegacy/pkg-message8
-rw-r--r--games/doomlegacy/pkg-plist41
10 files changed, 93 insertions, 111 deletions
diff --git a/games/doomlegacy/Makefile b/games/doomlegacy/Makefile
index 465b14ef4186..60936c4f4b1a 100644
--- a/games/doomlegacy/Makefile
+++ b/games/doomlegacy/Makefile
@@ -5,33 +5,30 @@
# $FreeBSD$
PORTNAME= doomlegacy
-PORTVERSION= 1.32b4
-PORTREVISION= 1
+PORTVERSION= 141
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR?= ${PORTNAME}
-DISTNAME= legacy_${FILEVERSION}_src
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= legacy_${PORTVERSION}_src
DISTFILES= ${DIST} ${WADFILE}
+DIST= ${DISTNAME}${EXTRACT_SUFX}
+WADFILE= legacy_dat.zip
EXTRACT_ONLY= ${DIST}
MAINTAINER= bock@bock.nnov.ru
COMMENT= DooM Legacy: popular DooM clone!
-BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip \
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
nasm:${PORTSDIR}/devel/nasm
-WADVER= 132b4
-WADFILE= doom3_wad_${WADVER}.zip
-FILEVERSION= 132beta4
-DIST= ${DISTNAME}${EXTRACT_SUFX}
-
USE_XLIB= yes
USE_GMAKE= yes
-USE_MESA= yes
+USE_GL= yes
+USE_SDL= mixer
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/legacy_${PORTVERSION}_src
MAKEFILE= makefile
-MAKE_ENV+= FREEBSD=1 PTHREAD_LIBS="${PTHREAD_LIBS}" \
+MAKE_ENV+= FREEBSD=1 FBSD_SDL=1 PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
# I have no ideas about build status on other platforms
@@ -39,25 +36,41 @@ ONLY_FOR_ARCHS= i386
TARGET_DIR= ${PREFIX}/${PORTNAME}
-DATA_FILES= ${WRKDIR}/bin/doom3.wad
+DATA_FILES= ${WRKDIR}/bin/legacy.dat
PROG_FILES= ${WRKDIR}/bin/llsndserv ${WRKDIR}/bin/r_opengl.so
-SGID_FILES= ${WRKDIR}/bin/llxdoom
+SGID_FILES= ${WRKDIR}/bin/lsdldoom
SGID_ARGS= -c -s -o root -g kmem -m 2555
+DOC_FILES= *.html *.txt *.cfg README_SDL copying
post-extract:
- @cd ${WRKDIR} && ${MKDIR} bin && \
- unzip -q ${_DISTDIR}/${WADFILE} -d ${WRKDIR}/bin
+ @${MKDIR} ${WRKDIR}/bin
+ ${UNZIP_CMD} -q ${DISTDIR}/${WADFILE} -d ${WRKDIR}/bin
+
+post-patch:
+ @${SED} -e "s|%%INSTALLDIR%%|${PREFIX}/${PORTNAME}|" ${FILESDIR}/wrapper.sh > \
+ ${WRKDIR}/bin/wrapper.sh
+
+pre-build:
+ cd ${WRKSRC}/linux_x/sndserv && ${GMAKE} clean
+
+post-build:
+ @${LN} -s ${WRKSRC}/linux_x/sndserv/linux/llsndserv ${WRKDIR}/bin
do-install:
- ${LN} -sf ${WRKSRC}/linux_x/sndserv/linux/llsndserv ${WRKDIR}/bin
- ${INSTALL} -d ${TARGET_DIR} && \
- ${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR} && \
- ${INSTALL} ${SGID_ARGS} ${SGID_FILES} ${TARGET_DIR} && \
- ${INSTALL_DATA} ${DATA_FILES} ${TARGET_DIR} && \
- ${INSTALL} -d ${DOCSDIR} && \
- ${INSTALL_DATA} ${WRKSRC}/_doc/* ${DOCSDIR}
+ ${INSTALL} -d ${TARGET_DIR}
+ ${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR}
+ ${INSTALL} ${SGID_ARGS} ${SGID_FILES} ${TARGET_DIR}
+ ${INSTALL_DATA} ${DATA_FILES} ${TARGET_DIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/bin/wrapper.sh ${TARGET_DIR}/legacy.sh
+ @${LN} -s ${TARGET_DIR}/legacy.sh ${PREFIX}/bin/legacy
post-install:
- @${CAT} ${PKGMESSAGE}
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ ${INSTALL_MAN} ${WRKSRC}/_doc/${file} ${DOCSDIR}
+.endfor
+.endif
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/games/doomlegacy/distinfo b/games/doomlegacy/distinfo
index 802af577cc4c..60b35f155be0 100644
--- a/games/doomlegacy/distinfo
+++ b/games/doomlegacy/distinfo
@@ -1,2 +1,4 @@
-MD5 (legacy_132beta4_src.tar.gz) = 27b1564bf05faf962501a658b4167758
-MD5 (doom3_wad_132b4.zip) = 1bcc230b9ef9520cf81bc41f0aff48ce
+MD5 (legacy_141_src.tar.gz) = 4e64cb19e0e57055e664bdf09bce14d2
+SIZE (legacy_141_src.tar.gz) = 1600679
+MD5 (legacy_dat.zip) = 8182e1aebac3696ddc7f9e0663740d9a
+SIZE (legacy_dat.zip) = 340934
diff --git a/games/doomlegacy/files/patch-doomlegacy::linux_x::i_sound.c b/games/doomlegacy/files/patch-doomlegacy::linux_x::i_sound.c
deleted file mode 100644
index edb4043f80cd..000000000000
--- a/games/doomlegacy/files/patch-doomlegacy::linux_x::i_sound.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- linux_x/i_sound.c.orig Sat Jan 18 18:24:12 2003
-+++ linux_x/i_sound.c Sat Jan 18 18:23:42 2003
-@@ -93,7 +93,7 @@
- // Linux voxware output.
- #ifdef LINUX
- #ifdef FREEBSD
--#include <machine/soundcard.h>
-+#include <sys/soundcard.h>
- #else
- #include <linux/soundcard.h>
- #endif
diff --git a/games/doomlegacy/files/patch-doomlegacy::linux_x::linux.c b/games/doomlegacy/files/patch-doomlegacy::linux_x::linux.c
deleted file mode 100644
index 878733b2051f..000000000000
--- a/games/doomlegacy/files/patch-doomlegacy::linux_x::linux.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- linux_x/sndserv/linux.c.orig Sat Jan 18 18:29:07 2003
-+++ linux_x/sndserv/linux.c Sat Jan 18 18:29:12 2003
-@@ -45,7 +45,7 @@
-
- #ifdef LINUX
- #ifdef FREEBSD
--#include <machine/soundcard.h>
-+#include <sys/soundcard.h>
- #else
- #include <linux/soundcard.h>
- #endif
diff --git a/games/doomlegacy/files/patch-doomlegacy::t_prepro.h b/games/doomlegacy/files/patch-doomlegacy::t_prepro.h
deleted file mode 100644
index 638135773148..000000000000
--- a/games/doomlegacy/files/patch-doomlegacy::t_prepro.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- t_prepro.h.orig Wed May 16 15:33:34 2001
-+++ t_prepro.h Sat Jan 18 18:19:25 2003
-@@ -34,12 +34,12 @@
- #define __PREPRO_H__
-
- #ifdef FREEBSD
--#include <machine/types.h>
-+//#include <machine/types.h>
- #endif
- typedef struct section_s section_t;
--#ifndef FREEBSD
-+#if __FreeBSD__ > 4
- typedef struct label_s label_t;
- #endif
- #define SECTIONSLOTS 17
- #define LABELSLOTS 17
-
diff --git a/games/doomlegacy/files/patch-makefile b/games/doomlegacy/files/patch-makefile
index 446fc48901ff..70ed1fa62696 100644
--- a/games/doomlegacy/files/patch-makefile
+++ b/games/doomlegacy/files/patch-makefile
@@ -1,6 +1,6 @@
---- makefile.orig Thu Jan 3 11:20:06 2002
-+++ makefile Thu Oct 2 15:40:05 2003
-@@ -224,7 +224,7 @@
+--- makefile.orig Fri Oct 3 15:11:05 2003
++++ makefile Sun Mar 28 17:15:39 2004
+@@ -260,7 +260,7 @@
# gcc or g++
#CC=@gcc
@@ -9,9 +9,9 @@
#if use PGCC or EGCS
PGCC=1
-@@ -351,7 +351,8 @@
+@@ -407,7 +407,8 @@
- OPTS := $(OPTS) -DVID_X11 -DPOLL_POINTER -I. -I/usr/X11R6/include
+ OPTS := $(OPTS) -DVID_X11 $(POLL_POINTER) -I. -I/usr/X11R6/include
LDFLAGS=-L/usr/X11R6/lib
- LIBS=-lXext -lX11 -lm -lXxf86vm -lipx -lkvm -pthread
+ LIBS=-lXext -lX11 -lm -lXxf86vm -lipx -lkvm ${PTHREAD_LIBS}
@@ -19,7 +19,7 @@
# name of the exefile
EXENAME=llxdoom
SFLAGS=-g $(OPTS)
-@@ -372,7 +373,8 @@
+@@ -428,7 +429,8 @@
DEBUGLIBS=$(LIBS)
LDFLAGS=-L/usr/X11R6/lib -L/usr/local/lib
@@ -29,46 +29,37 @@
DEBUGLIBS=$(LIBS)
# name of the exefile
-@@ -460,13 +462,13 @@
+@@ -555,13 +557,13 @@
# build a normal optimised version
ifdef PGCC
-- CFLAGS = $(OPTS) -mpentium -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
+- CFLAGS = $(OPTS) $(M5) -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
+ CFLAGS += $(OPTS) -fwritable-strings
# -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \
# -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps \
# -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \
# -fcaller-saves -finline-functions -mieee-fp -mfp-ret-in-387 -m80387 -mhard-float -finline
else
-- CFLAGS = -m486 -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
+- CFLAGS = $(M4) -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
+ CFLAGS += -fwritable-strings $(OPTS)
endif
endif
-@@ -623,7 +625,7 @@
+@@ -735,7 +737,7 @@
#dll
dll : $(O)/r_opengl.o $(O)/ogl_x11.o
-- $(CC) -mpentium -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lGL -lX11 -lXext -lGLU -lm
-+ $(CC) ${CFLAGS} -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lGL -lX11 -lXext -lGLU -lm
+- $(CC) $(M5) -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
++ $(CC) ${CFLAGS} -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
musserv:
@mkdir -p $(MUSSERV)/linux
-@@ -651,7 +653,7 @@
+@@ -763,7 +765,7 @@
$(CC) $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
else #FBSD_SDL
$(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
-- $(CC) -mpentium -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
-+ $(CC) $(CFLAGS) -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+- $(CC) $(M5) -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++ $(CC) ${CFLAGS} -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
endif #FBSD_SDL
endif #FREEBSD
-@@ -660,7 +662,7 @@
- $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
- else
- $(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
-- $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
-+ $(CC) $(CFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
- endif
-
-
diff --git a/games/doomlegacy/files/wrapper.sh b/games/doomlegacy/files/wrapper.sh
new file mode 100644
index 000000000000..df444e29468d
--- /dev/null
+++ b/games/doomlegacy/files/wrapper.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+# Needed to make symlinks/shortcuts work.
+# Wrap lsdldoom binary
+cd %%INSTALLDIR%%
+./lsdldoom -nocheckwadversion $*
+exit $?
diff --git a/games/doomlegacy/pkg-descr b/games/doomlegacy/pkg-descr
index c908ce3f3395..23295c788153 100644
--- a/games/doomlegacy/pkg-descr
+++ b/games/doomlegacy/pkg-descr
@@ -1,4 +1,4 @@
-Legacy Doom is DooM port. Some of supported features:
+DooM Legacy is a DooM port. Some of the supported features are:
* VIDEO OPTIONS MENU
* TRANSLUCENCY ON SPRITES AND WALLS
* SETUP CONTROLS MENU
diff --git a/games/doomlegacy/pkg-message b/games/doomlegacy/pkg-message
index 1041791b527d..4ed076ed641f 100644
--- a/games/doomlegacy/pkg-message
+++ b/games/doomlegacy/pkg-message
@@ -1,12 +1,14 @@
+
************************************************************
Please read docs in
- $(PREFIX)/share/doc/doomlegacy
+ %%PREFIX%%/share/doc/doomlegacy
before you run the application.
************************************************************
-Copy doom2.wad or other Id iwad into
+Copy DOOM.WAD or other id iwads into
- $(PREFIX)/doomlegacy
+ %%PREFIX%%/doomlegacy
************************************************************
+
diff --git a/games/doomlegacy/pkg-plist b/games/doomlegacy/pkg-plist
index 3ca6948cedcb..45e23bc2ed78 100644
--- a/games/doomlegacy/pkg-plist
+++ b/games/doomlegacy/pkg-plist
@@ -1,21 +1,28 @@
-doomlegacy/doom3.wad
+bin/legacy
+doomlegacy/legacy.dat
+doomlegacy/legacy.sh
doomlegacy/llsndserv
-doomlegacy/llxdoom
+doomlegacy/lsdldoom
doomlegacy/r_opengl.so
-share/doc/doomlegacy/Console.txt
-share/doc/doomlegacy/Doublescan.txt
-share/doc/doomlegacy/Legacy.txt
-share/doc/doomlegacy/README_SDL
-share/doc/doomlegacy/Readme.OS2
-share/doc/doomlegacy/Whatsnew.txt
-share/doc/doomlegacy/copying
-share/doc/doomlegacy/doomatic.txt
-share/doc/doomlegacy/doomlic.txt
-share/doc/doomlegacy/editing.txt
-share/doc/doomlegacy/faq.txt
-share/doc/doomlegacy/rules.txt
-share/doc/doomlegacy/skinspec.txt
-share/doc/doomlegacy/sound.cfg
-share/doc/doomlegacy/source.txt
+%%PORTDOCS%%%%DOCSDIR%%/3dfloors.html
+%%PORTDOCS%%%%DOCSDIR%%/Doublescan.txt
+%%PORTDOCS%%%%DOCSDIR%%/README_SDL
+%%PORTDOCS%%%%DOCSDIR%%/boomref.html
+%%PORTDOCS%%%%DOCSDIR%%/console.html
+%%PORTDOCS%%%%DOCSDIR%%/copying
+%%PORTDOCS%%%%DOCSDIR%%/doomatic.txt
+%%PORTDOCS%%%%DOCSDIR%%/doomlic.txt
+%%PORTDOCS%%%%DOCSDIR%%/editing.html
+%%PORTDOCS%%%%DOCSDIR%%/editspecs.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/fsbasic.html
+%%PORTDOCS%%%%DOCSDIR%%/fsfuncs.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/legacy.html
+%%PORTDOCS%%%%DOCSDIR%%/rules.txt
+%%PORTDOCS%%%%DOCSDIR%%/skinspec.html
+%%PORTDOCS%%%%DOCSDIR%%/sound.cfg
+%%PORTDOCS%%%%DOCSDIR%%/source.html
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew.html
@dirrm share/doc/doomlegacy
@dirrm doomlegacy