aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2014-01-13 13:01:34 +0800
committernivit <nivit@FreeBSD.org>2014-01-13 13:01:34 +0800
commit8025680e617594a4f27f3041e06bc305d96cbd66 (patch)
treefe42dd7bde42349efb421e1cc9ed5b3fc8a96042 /games
parent571822c22a15d0a908f591d7db2fa02b2f28e4a1 (diff)
downloadfreebsd-ports-gnome-8025680e617594a4f27f3041e06bc305d96cbd66.tar.gz
freebsd-ports-gnome-8025680e617594a4f27f3041e06bc305d96cbd66.tar.zst
freebsd-ports-gnome-8025680e617594a4f27f3041e06bc305d96cbd66.zip
PolyGlot is a "UCI adapter". It connects a UCI chess engine to an
xboard interface. PolyGlot tries to solve known problems with other adapters. For instance, it detects and reports draws by fifty-move rule, repetition, etc... WWW: http://wbec-ridderkerk.nl/html/details1/PolyGlot.html
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/polyglot/Makefile21
-rw-r--r--games/polyglot/distinfo2
-rw-r--r--games/polyglot/files/patch-main.c11
-rw-r--r--games/polyglot/files/patch-pgheader.c18
-rw-r--r--games/polyglot/files/patch-pipex_posix.c16
-rw-r--r--games/polyglot/files/patch-util.h10
-rw-r--r--games/polyglot/pkg-descr8
-rw-r--r--games/polyglot/pkg-plist9
9 files changed, 96 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 8e3c46aa2668..6b95cf48327d 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -732,6 +732,7 @@
SUBDIR += poker-engine
SUBDIR += poker-eval
SUBDIR += pokerth
+ SUBDIR += polyglot
SUBDIR += polypuzzle
SUBDIR += pongix
SUBDIR += popstar
diff --git a/games/polyglot/Makefile b/games/polyglot/Makefile
new file mode 100644
index 000000000000..7e2ed7b5be61
--- /dev/null
+++ b/games/polyglot/Makefile
@@ -0,0 +1,21 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= polyglot
+DISTVERSION= 1.4.70b
+#PORTVERSION=
+#PORTREVISION= 0
+CATEGORIES= games
+MASTER_SITES= http://hardy.uhasselt.be/Toga/polyglot-release/ \
+ http://nivit.altervista.org/FreeBSD/ports/distfiles/
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Winboard protocol to UCI protocol adapter
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.mk>
diff --git a/games/polyglot/distinfo b/games/polyglot/distinfo
new file mode 100644
index 000000000000..840046c21711
--- /dev/null
+++ b/games/polyglot/distinfo
@@ -0,0 +1,2 @@
+SHA256 (polyglot-1.4.70b.tar.gz) = cc10554390cb67c73395470505805f673a639fd3283acd02471f7a67dc9bedef
+SIZE (polyglot-1.4.70b.tar.gz) = 269938
diff --git a/games/polyglot/files/patch-main.c b/games/polyglot/files/patch-main.c
new file mode 100644
index 000000000000..06162eb320bd
--- /dev/null
+++ b/games/polyglot/files/patch-main.c
@@ -0,0 +1,11 @@
+--- ./main.c.orig 2012-09-20 19:56:38.000000000 +0200
++++ ./main.c 2014-01-11 04:44:10.000000000 +0100
+@@ -242,7 +242,7 @@
+ }
+ }
+
+-int wb_select(){
++void wb_select(){
+ option_t *opt;
+ option_start_iter(Option);
+ while((opt=option_next(Option))){
diff --git a/games/polyglot/files/patch-pgheader.c b/games/polyglot/files/patch-pgheader.c
new file mode 100644
index 000000000000..12833d4fcee2
--- /dev/null
+++ b/games/polyglot/files/patch-pgheader.c
@@ -0,0 +1,18 @@
+--- ./pgheader.c.orig 2012-09-20 13:50:00.000000000 +0200
++++ ./pgheader.c 2014-01-11 04:44:10.000000000 +0100
+@@ -47,13 +47,13 @@
+ #ifndef WIN32
+ #define O_BINARY 0x0
+ #endif
+-
++/*
+ #ifdef _MSC_VER
+ typedef unsigned __int64 uint64_t;
+ #else
+ typedef unsigned long long int uint64_t;
+ #endif
+-
++*/
+ static int int_from_file(FILE *f, int l, uint64_t *r){
+ int i,c;
+ for(i=0;i<l;i++){
diff --git a/games/polyglot/files/patch-pipex_posix.c b/games/polyglot/files/patch-pipex_posix.c
new file mode 100644
index 000000000000..8351b34b624c
--- /dev/null
+++ b/games/polyglot/files/patch-pipex_posix.c
@@ -0,0 +1,16 @@
+--- ./pipex_posix.c.orig 2014-01-11 04:44:58.000000000 +0100
++++ ./pipex_posix.c 2014-01-11 04:45:23.000000000 +0100
+@@ -2,11 +2,12 @@
+
+ // includes
+
++#include <sys/wait.h>
+ #include <string.h>
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <wordexp.h>
+-#include <sys/wait.h>
++#include <signal.h>
+ #include "pipex.h"
+
+ // prototypes
diff --git a/games/polyglot/files/patch-util.h b/games/polyglot/files/patch-util.h
new file mode 100644
index 000000000000..d2a374ad79f4
--- /dev/null
+++ b/games/polyglot/files/patch-util.h
@@ -0,0 +1,10 @@
+--- ./util.h.orig 2010-12-06 18:35:50.000000000 +0100
++++ ./util.h 2014-01-11 04:44:10.000000000 +0100
+@@ -8,7 +8,6 @@
+
+ #include <stdio.h>
+ #include <sys/types.h>
+-#include <sys/timeb.h>
+ #include <sys/stat.h>
+
+ // defines
diff --git a/games/polyglot/pkg-descr b/games/polyglot/pkg-descr
new file mode 100644
index 000000000000..432ae2350514
--- /dev/null
+++ b/games/polyglot/pkg-descr
@@ -0,0 +1,8 @@
+PolyGlot is a "UCI adapter". It connects a UCI chess engine to an
+xboard interface.
+
+PolyGlot tries to solve known problems with other adapters. For
+instance, it detects and reports draws by fifty-move rule, repetition,
+etc...
+
+WWW: http://wbec-ridderkerk.nl/html/details1/PolyGlot.html
diff --git a/games/polyglot/pkg-plist b/games/polyglot/pkg-plist
new file mode 100644
index 000000000000..179ae2fa2d43
--- /dev/null
+++ b/games/polyglot/pkg-plist
@@ -0,0 +1,9 @@
+bin/polyglot
+man/man6/polyglot.6.gz
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README1.3
+%%PORTDOCS%%%%DOCSDIR%%/README1.4
+%%PORTDOCS%%%%DOCSDIR%%/README1.4w
+%%PORTDOCS%%%%DOCSDIR%%/README1.4w10UCI
+%%PORTDOCS%%%%DOCSDIR%%/book_format.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%