aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-27 21:21:13 +0800
committerbapt <bapt@FreeBSD.org>2014-05-27 21:21:13 +0800
commit80d651eb05f02de1d8657811bacb46c1b44ddd3a (patch)
tree3e56d7963d822cd6ea35792bd6e6cfdc3a8e4662 /games
parent743488ec182bb912e9c7f06603edb97e6012df17 (diff)
downloadfreebsd-ports-gnome-80d651eb05f02de1d8657811bacb46c1b44ddd3a.tar.gz
freebsd-ports-gnome-80d651eb05f02de1d8657811bacb46c1b44ddd3a.tar.zst
freebsd-ports-gnome-80d651eb05f02de1d8657811bacb46c1b44ddd3a.zip
Convert to USES=scons
Stagify
Diffstat (limited to 'games')
-rw-r--r--games/pingus/Makefile16
-rw-r--r--games/pink-pony/Makefile4
2 files changed, 7 insertions, 13 deletions
diff --git a/games/pingus/Makefile b/games/pingus/Makefile
index ddc2b0007c5b..bc8878a83c8d 100644
--- a/games/pingus/Makefile
+++ b/games/pingus/Makefile
@@ -14,10 +14,8 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libboost_regex.so:${PORTSDIR}/devel/boost-libs \
libphysfs.so:${PORTSDIR}/devel/physfs
-USE_BZIP2= yes
-USES= iconv
-USE_SCONS= yes
-SCONS_ARGS= with_linuxusbmouse=0 \
+USES= iconv scons tar:bzip2
+MAKE_ARGS= with_linuxusbmouse=0 \
with_linuxevdev=0
USE_SDL= sdl image mixer
@@ -27,7 +25,6 @@ DESKTOP_ENTRIES="Pingus" "${COMMENT}" \
PLIST= ${WRKDIR}/pkg-plist
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|add_path("data")|add_path("${DATADIR}")|g' \
${WRKSRC}/src/pingus_main.cpp
@@ -42,11 +39,10 @@ pre-install:
@${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
do-install:
- @${MKDIR} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
@cd ${WRKSRC}/data && \
- ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/src/win32/icon1.ico ${PREFIX}/share/pixmaps/${PORTNAME}.ico
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/src/win32/icon1.ico ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.ico
.include <bsd.port.mk>
diff --git a/games/pink-pony/Makefile b/games/pink-pony/Makefile
index 131349f76854..69ae6638a07b 100644
--- a/games/pink-pony/Makefile
+++ b/games/pink-pony/Makefile
@@ -20,9 +20,7 @@ LIB_DEPENDS= libIL.so:${PORTSDIR}/graphics/devil \
libftgl.so:${PORTSDIR}/graphics/ftgl \
libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20
-USES= dos2unix pkgconfig tar:bzip2
-USE_BZIP2= yes
-USE_SCONS= yes
+USES= dos2unix pkgconfig scons tar:bzip2
USE_GL= gl glu
USE_SDL= mixer
SUB_FILES= pink-pony.sh