aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-06-02 09:42:36 +0800
committeradamw <adamw@FreeBSD.org>2003-06-02 09:42:36 +0800
commit8371c036440af348a4589d57a29ee20573469bae (patch)
tree964a3043cd89f615f037e1495db63e2bbfccee65 /games
parentc0faa62c9115068d160ffe961af39687455e10cd (diff)
downloadfreebsd-ports-gnome-8371c036440af348a4589d57a29ee20573469bae.tar.gz
freebsd-ports-gnome-8371c036440af348a4589d57a29ee20573469bae.tar.zst
freebsd-ports-gnome-8371c036440af348a4589d57a29ee20573469bae.zip
Add scummvm-tools.
This is a collection of various tools that may be useful to use in conjunction with ScummVM. It includes tools that will allow you to decompile and extract SCUMM scripts from various games, as well as graphics and sound. Of special note is the extract utility, which uses libmp3lame to compress a monster.sou file to about 25% its original size.
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/scummvm-tools/Makefile37
-rw-r--r--games/scummvm-tools/distinfo1
-rw-r--r--games/scummvm-tools/files/patch-simon1descr.c19
-rw-r--r--games/scummvm-tools/pkg-descr10
-rw-r--r--games/scummvm-tools/pkg-plist8
6 files changed, 76 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 34e99de3131d..96d38c096145 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -298,6 +298,7 @@
SUBDIR += scid
SUBDIR += scorched3d-devel
SUBDIR += scummvm
+ SUBDIR += scummvm-tools
SUBDIR += sdlroids
SUBDIR += seabattle
SUBDIR += seahaven
diff --git a/games/scummvm-tools/Makefile b/games/scummvm-tools/Makefile
new file mode 100644
index 000000000000..e07ef459e5bc
--- /dev/null
+++ b/games/scummvm-tools/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: scummvm-tools
+# Date created: 28 May 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scummvm-tools
+PORTVERSION= 0.4.1
+CATEGORIES= games emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= scummvm
+
+MAINTAINER= flynn@energyhq.es.eu.org
+COMMENT= Tools for use with the SCUMMVM game emulator
+
+RUN_DEPENDS= scummvm:${PORTSDIR}/games/scummvm
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' \
+ ${WRKSRC}/Makefile
+
+do-install:
+.for i in extract rescumm descumm descumm6 simon1decr simon2mp3
+ @${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
+.endfor
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/scummvm-tools/distinfo b/games/scummvm-tools/distinfo
new file mode 100644
index 000000000000..eeaf9b1bec7e
--- /dev/null
+++ b/games/scummvm-tools/distinfo
@@ -0,0 +1 @@
+MD5 (scummvm-tools-0.4.1.tar.bz2) = d7415eb6e55a78061964930563f78308
diff --git a/games/scummvm-tools/files/patch-simon1descr.c b/games/scummvm-tools/files/patch-simon1descr.c
new file mode 100644
index 000000000000..80dc425759a1
--- /dev/null
+++ b/games/scummvm-tools/files/patch-simon1descr.c
@@ -0,0 +1,19 @@
+--- simon1decr.c.orig Tue May 27 16:34:14 2003
++++ simon1decr.c Tue May 27 16:34:34 2003
+@@ -26,14 +26,9 @@
+
+ #define EndGetM32(a) ((((a)[0])<<24)|(((a)[1])<<16)|(((a)[2])<<8)|((a)[3]))
+
+-#define SD_GETBIT(var) do { \
+- if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } \
+- (var) = bb & 1; bb >>= 1; \
+-} while (0)
++#define SD_GETBIT(var) do { if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } (var) = bb & 1; bb >>= 1; } while (0)
+
+-#define SD_GETBITS(var, nbits) do { \
+- bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } \
+-} while (0)
++#define SD_GETBITS(var, nbits) do { bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } } while (0)
+
+ #define SD_TYPE_LITERAL (0)
+ #define SD_TYPE_MATCH (1)
diff --git a/games/scummvm-tools/pkg-descr b/games/scummvm-tools/pkg-descr
new file mode 100644
index 000000000000..1384552382ac
--- /dev/null
+++ b/games/scummvm-tools/pkg-descr
@@ -0,0 +1,10 @@
+This is a collection of various tools that may be useful to use in
+conjunction with ScummVM. It includes tools that will allow you to
+decompile and extract SCUMM scripts from various games, as well as
+graphics and sound. Of special note is the extract utility, which
+uses libmp3lame to compress a monster.sou file to about 25% its
+original size.
+
+WWW: http://scummvm.sourceforge.net/
+
+-Miguel Mendez <flynn@energyhq.es.eu.org>
diff --git a/games/scummvm-tools/pkg-plist b/games/scummvm-tools/pkg-plist
new file mode 100644
index 000000000000..fead579084fe
--- /dev/null
+++ b/games/scummvm-tools/pkg-plist
@@ -0,0 +1,8 @@
+bin/extract
+bin/rescumm
+bin/descumm
+bin/descumm6
+bin/simon1decr
+bin/simon2mp3
+%%PORTDOCS%%share/doc/scummvm-tools/README
+%%PORTDOCS%%@dirrm share/doc/scummvm-tools