aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-07-31 00:49:12 +0800
committerglewis <glewis@FreeBSD.org>2004-07-31 00:49:12 +0800
commit8fa8e3c02bad997c32eb4e50249646224415d99b (patch)
tree230373c48cc333866bc8ee657da203b46b9ed144 /games
parent7c6e720f15a3c7452d8918debcc3fa33a2e362bf (diff)
downloadfreebsd-ports-gnome-8fa8e3c02bad997c32eb4e50249646224415d99b.tar.gz
freebsd-ports-gnome-8fa8e3c02bad997c32eb4e50249646224415d99b.tar.zst
freebsd-ports-gnome-8fa8e3c02bad997c32eb4e50249646224415d99b.zip
. Update to 2.3.3.22, a version written this century. It could do with
some more work to make it easier to run out of the box (in terms of configuration files) if anyone is interested.
Diffstat (limited to 'games')
-rw-r--r--games/tinymux/Makefile80
-rw-r--r--games/tinymux/distinfo4
-rw-r--r--games/tinymux/files/patch-aa19
-rw-r--r--games/tinymux/files/patch-ab31
-rw-r--r--games/tinymux/files/patch-src-db.h20
-rw-r--r--games/tinymux/files/patch-src-htab.c9
-rw-r--r--games/tinymux/files/patch-src-udb_misc.c14
-rw-r--r--games/tinymux/files/patch-src-udb_ocache.c47
-rw-r--r--games/tinymux/files/patch-src-udb_ochunk.c63
-rw-r--r--games/tinymux/pkg-descr14
-rw-r--r--games/tinymux/pkg-plist77
11 files changed, 94 insertions, 284 deletions
diff --git a/games/tinymux/Makefile b/games/tinymux/Makefile
index db9abfe4f713..1fa9e9cb9350 100644
--- a/games/tinymux/Makefile
+++ b/games/tinymux/Makefile
@@ -6,54 +6,68 @@
#
PORTNAME= tinymux
-PORTVERSION= 1.6p0
-PORTREVISION= 2
-CATEGORIES= games
-MASTER_SITES= http://www.moosh.net/pub/mush/servers/tinymux/TinyMUX-1.x/
+PORTVERSION= 2.3.3.${PATCHLEVEL}
+CATEGORIES= games net
+MASTER_SITES= ftp://ftp.tinymux.org/TinyMUX/tinymux-2.3/${PATCHLEVEL}/ \
+ http://www.tinymux.org/ \
+ http://www.moosh.net/pub/mush/servers/tinymux/TinyMUX-2.x/tinymux-2.3/${PATCHLEVEL}/
+DISTNAME= mux-${PORTVERSION}.unix
MAINTAINER= ports@FreeBSD.org
COMMENT= A Multi-Player FreeForm adventure Program
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
-
-WRKSRC= ${WRKDIR}/src
-
-USE_AUTOCONF_VER= 213
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-extract:
- @${RM} -f ${WRKSRC}/gdbm.h
+PATCHLEVEL= 22
+WRKSRC= ${WRKDIR}/mux2.3/src
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
-#
-# Distribution does not include an install target. So here it is.
do-install:
- ${MKDIR} ${PREFIX}/games/tinymux
- ${INSTALL_SCRIPT} ${WRKDIR}/game/Startmux ${PREFIX}/games/tinymux
-.for file in alias.conf compat.conf mtrace.awk mux.config netmux.conf
- ${INSTALL_DATA} ${WRKDIR}/game/${file} ${PREFIX}/games/tinymux
+# Binaries
+.for file in netmux slave
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/sbin
.endfor
- ${MKDIR} ${PREFIX}/games/tinymux/data
+ ${INSTALL_PROGRAM} ${WRKSRC}/../game/bin/dbconvert ${PREFIX}/bin
+# Configuration
+ ${MKDIR} ${PREFIX}/etc/${PORTNAME}
+.for file in alias.conf compat.conf mux.config netmux.conf
+ ${INSTALL_DATA} ${WRKSRC}/../game/${file} \
+ ${PREFIX}/etc/${PORTNAME}/${file}.sample
+.endfor
+# Data
+ ${MKDIR} ${DATADIR}/game/netmux
+.for file in Backup Startmux _backupflat.sh
+ ${INSTALL_SCRIPT} ${WRKSRC}/../game/${file} ${DATADIR}/game/netmux/
+.endfor
+ ${MKDIR} ${DATADIR}/game/netmux/data
.for file in db_check db_load db_unload
- ${INSTALL_SCRIPT} ${WRKDIR}/game/data/${file} \
- ${PREFIX}/games/tinymux/data
+ ${INSTALL_SCRIPT} ${WRKSRC}/../game/data/${file} \
+ ${DATADIR}/game/netmux/data
.endfor
- ${MKDIR} ${PREFIX}/games/tinymux/text
+ ${INSTALL_DATA} ${WRKSRC}/../game/data/netmux.db \
+ ${DATADIR}/game/netmux/data
+ ${MKDIR} ${DATADIR}/game/netmux/text
.for file in badsite connect create_reg down full guest help motd \
- news newuser plushelp quit register wizhelp wizmotd wiznews
- ${INSTALL_DATA} ${WRKDIR}/game/text/${file}.txt \
- ${PREFIX}/games/tinymux/text
-.endfor
- ${MKDIR} ${PREFIX}/games/tinymux/bin
-# ${INSTALL_PROGRAM} ${WRKSRC}/conc ${PREFIX}/games/tinymux/bin
-.for file in dbconvert mkindx netmux slave
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/games/tinymux/bin
+ news newuser plushelp quit register staffhelp wizhelp wizmotd wiznews
+ ${INSTALL_DATA} ${WRKSRC}/../game/text/${file}.txt \
+ ${DATADIR}/game/netmux/text
.endfor
+# Docs
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/tinymux
-.for file in README README.COMPRESSION README.GUESTS README.MEMORY \
- README.TOOLS
- ${INSTALL_DATA} ${WRKDIR}/${file} ${PREFIX}/share/doc/tinymux
+ ${MKDIR} ${DOCSDIR}
+.for file in ATTACK CHANGES INSTALL NOTES README SGP
+ ${INSTALL_DATA} ${WRKSRC}/../${file} ${DOCSDIR}
+.endfor
+.for file in BACKUPS CONFIGURATION CONVERSION CREDITS DISTRIBUTIONS GUESTS \
+ LIMITS MEMORY PATCHES REALMS muxman.pdf
+ ${INSTALL_DATA} ${WRKSRC}/../docs/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/games/tinymux/distinfo b/games/tinymux/distinfo
index e91346f0057e..ea432da6113b 100644
--- a/games/tinymux/distinfo
+++ b/games/tinymux/distinfo
@@ -1,2 +1,2 @@
-MD5 (tinymux-1.6p0.tar.gz) = 317f5a4611caee9f28d0e0fea63a3539
-SIZE (tinymux-1.6p0.tar.gz) = 640346
+MD5 (mux-2.3.3.22.unix.tar.bz2) = 3a1bbe505789e14499e6662155572c1a
+SIZE (mux-2.3.3.22.unix.tar.bz2) = 831091
diff --git a/games/tinymux/files/patch-aa b/games/tinymux/files/patch-aa
deleted file mode 100644
index b4fbf87ecc68..000000000000
--- a/games/tinymux/files/patch-aa
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.in.orig Fri Nov 6 06:36:22 1998
-+++ configure.in Mon Jan 22 23:40:31 2001
-@@ -17,7 +17,7 @@
- else
- AC_EGREP_HEADER(sys_errlist,errno.h, ,AC_EGREP_HEADER(sys_errlist,stdio.h,,AC_DEFINE(NEED_SYS_ERRLIST_DCL)))
- fi
--LIBS="-L./gdbm-1.7.3 -lgdbm"
-+AC_CHECK_LIB(gdbm, gdbm_open)
- AC_CHECK_LIB(crypt, main)
- AC_FUNC_STRFTIME
- AC_FUNC_VFORK
-@@ -126,7 +126,6 @@
- AC_CHECK_LIB(resolv, main)
- AC_CHECK_LIB(sun, getpwnam)
- AC_CHECK_LIB(seq, main)
--AC_CHECK_LIB(intl, main)
- AC_CHECK_LIB(nsl, main)
- if test $ac_cv_func_gethostbyaddr = no; then
- AC_CHECK_LIB(inet, main)
diff --git a/games/tinymux/files/patch-ab b/games/tinymux/files/patch-ab
deleted file mode 100644
index 646b42d457d9..000000000000
--- a/games/tinymux/files/patch-ab
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile.in.orig Fri Nov 6 11:06:00 1998
-+++ Makefile.in Mon Jan 22 23:27:55 2001
-@@ -8,8 +8,10 @@
- VPATH = @srcdir@
- BIN = ../game/bin
- CC = @CC@
-+CFLAGS= @CFLAGS@
- # CPP = @CPP@ # This is broken in autoconf. Sigh.
- CPP = $(CC) -E
-+CPPFLAGS = @CPPFLAGS@
- LIBS = @LIBS@
- LIBOBJS = @LIBOBJS@
-
-@@ -18,7 +20,7 @@
- # gmon.out)
- #OPTIM = -O
- #OPTIM = -g -pg -O
--OPTIM = -g -O
-+#OPTIM = -g -O
-
- # The first set of definitions is for disk-based caching. If you wish to be
- # memory based, comment the first set and uncomment the second set. Being
-@@ -170,7 +172,7 @@
- LIB_SRC =
- LIB_INC =
- DEBUG = $(OPTIM)
--ALLCFLAGS = $(CFLAGS) $(DEBUG) $(DEFS) $(COMPRESS_DEFS) $(BASED) $(MALLOC_DEFS) $(CONC_DEFS) $(MOREDEFS) $(RLIM_F)
-+ALLCFLAGS = $(CFLAGS) $(CPPFLAGS) $(DEBUG) $(DEFS) $(COMPRESS_DEFS) $(BASED) $(MALLOC_DEFS) $(CONC_DEFS) $(MOREDEFS) $(RLIM_F)
-
- #Auxiliary files
- A_INST = README NOTES HIGHLIGHTS CREDITS CHANGES
diff --git a/games/tinymux/files/patch-src-db.h b/games/tinymux/files/patch-src-db.h
deleted file mode 100644
index 5692a9f8792f..000000000000
--- a/games/tinymux/files/patch-src-db.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- db.h.orig Tue Oct 28 00:58:23 2003
-+++ db.h Tue Oct 28 00:58:46 2003
-@@ -16,7 +16,7 @@
- #define STORE(key, attr, len) cache_put(key, attr, len)
- #else
- #define STORE(key, attr) cache_put(key, attr)
--#endif RADIX_COMPRESSION
-+#endif /* RADIX_COMPRESSION */
- #define DELETE(key) cache_del(key)
- #define FETCH(key) cache_get(key)
- #define SYNC cache_sync()
-@@ -27,7 +27,7 @@
- #define FETCH(key)
- #define SYNC
- #define CLOSE
--#endif MEMORY_BASED
-+#endif /* MEMORY_BASED */
-
- #include "udb.h"
-
diff --git a/games/tinymux/files/patch-src-htab.c b/games/tinymux/files/patch-src-htab.c
deleted file mode 100644
index 69a18f029ca1..000000000000
--- a/games/tinymux/files/patch-src-htab.c
+++ /dev/null
@@ -1,9 +0,0 @@
---- htab.c.orig Tue Oct 28 01:03:30 2003
-+++ htab.c Tue Oct 28 01:03:38 2003
-@@ -805,4 +805,4 @@
- return -1;
- }
-
--#endif STANDALONE
-\ No newline at end of file
-+#endif /* STANDALONE */
diff --git a/games/tinymux/files/patch-src-udb_misc.c b/games/tinymux/files/patch-src-udb_misc.c
deleted file mode 100644
index c3332b4b54a0..000000000000
--- a/games/tinymux/files/patch-src-udb_misc.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- udb_misc.c.orig Tue Oct 28 01:01:25 2003
-+++ udb_misc.c Tue Oct 28 01:01:47 2003
-@@ -40,9 +40,9 @@
- * VARARGS
- */
- #ifdef STDC_HEADERS
--void logf(char *p,...)
-+void Logf(char *p,...)
- #else
--void logf(va_alist)
-+void Logf(va_alist)
- va_dcl
-
- #endif
diff --git a/games/tinymux/files/patch-src-udb_ocache.c b/games/tinymux/files/patch-src-udb_ocache.c
deleted file mode 100644
index 0f5baf664b1e..000000000000
--- a/games/tinymux/files/patch-src-udb_ocache.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- udb_ocache.c.orig Tue Oct 28 01:02:12 2003
-+++ udb_ocache.c Tue Oct 28 01:02:25 2003
-@@ -32,7 +32,7 @@
- #endif
-
- extern struct Obj *dddb_get();
--extern void logf();
-+extern void Logf();
-
- /*
- * This is by far the most complex and kinky code in UnterMUD. You should
-@@ -220,7 +220,7 @@
-
- sp = sys_c = (CacheLst *) malloc((unsigned)cwidth * sizeof(CacheLst));
- if (sys_c == (CacheLst *) 0) {
-- logf(ncmsg, (char *)-1, "\n", (char *)0);
-+ Logf(ncmsg, (char *)-1, "\n", (char *)0);
- return (-1);
- }
- /*
-@@ -228,7 +228,7 @@
- */
- cp = (Cache *) malloc(cwidth * cdepth * sizeof(Cache));
- if (cp == (Cache *) 0) {
-- logf(ncmsg, (char *)-1, "\n", (char *)0);
-+ Logf(ncmsg, (char *)-1, "\n", (char *)0);
- return (-1);
- }
- for (x = 0; x < cwidth; x++, sp++) {
-@@ -358,7 +358,7 @@
- */
- if (nam == (Aname *) 0 || !cache_initted) {
- #ifdef CACHE_VERBOSE
-- logf("cache_get: NULL object name - programmer error\n", (char *)0);
-+ Logf("cache_get: NULL object name - programmer error\n", (char *)0);
- #endif
- return ((Attr *) 0);
- }
-@@ -548,7 +548,7 @@
- */
- if (obj == (Attr *) 0 || nam == (Aname *) 0 || !cache_initted) {
- #ifdef CACHE_VERBOSE
-- logf("cache_put: NULL object/name - programmer error\n", (char *)0);
-+ Logf("cache_put: NULL object/name - programmer error\n", (char *)0);
- #endif
- return (1);
- }
diff --git a/games/tinymux/files/patch-src-udb_ochunk.c b/games/tinymux/files/patch-src-udb_ochunk.c
deleted file mode 100644
index 9f2a2e750c6a..000000000000
--- a/games/tinymux/files/patch-src-udb_ochunk.c
+++ /dev/null
@@ -1,63 +0,0 @@
---- udb_ochunk.c.orig Sun Oct 25 23:58:06 1998
-+++ udb_ochunk.c Tue Oct 28 01:01:14 2003
-@@ -11,7 +11,7 @@
- #include "mudconf.h"
-
- #ifdef VMS
--#include <malloc.h>
-+#include <stdlib.h>
- #include <types.h>
- #include <file.h>
- #include <unixio.h>
-@@ -19,7 +19,7 @@
- #else
- #ifndef NEXT
- #ifndef MALLOC_IN_STDLIB_H
--#include <malloc.h>
-+#include <stdlib.h>
- #endif
- #endif /* NEXT */
- #include <sys/param.h>
-@@ -75,7 +75,7 @@
-
- if ((dbp = gdbm_open(dbfile, block_size, GDBM_WRCREAT, 0600, gdbm_panic)) == (GDBM_FILE) 0) {
- gdbm_error = (char *)gdbm_strerror(gdbm_errno);
-- logf(copen, dbfile, " ", (char *)-1, "\n", gdbm_error, "\n", (char *)0);
-+ Logf(copen, dbfile, " ", (char *)-1, "\n", gdbm_error, "\n", (char *)0);
- return (1);
- }
-
-@@ -130,7 +130,7 @@
-
- /* if the file is badly formatted, ret == Obj * 0 */
- if ((ret = objfromFILE(dat.dptr)) == (Obj *) 0) {
-- logf("db_get: cannot decode ", nam, "\n", (char *)0);
-+ Logf("db_get: cannot decode ", nam, "\n", (char *)0);
- free(dat.dptr);
- return NULL;
- }
-@@ -170,13 +170,13 @@
- dat.dsize = nsiz;
-
- if (objtoFILE(obj, dat.dptr) != 0) {
-- logf("db_put: can't save ", nam, " ", (char *)-1, "\n", (char *)0);
-+ Logf("db_put: can't save ", nam, " ", (char *)-1, "\n", (char *)0);
- free(dat.dptr);
- return (1);
- }
-
- if (gdbm_store(dbp, key, dat, GDBM_REPLACE)) {
-- logf("db_put: can't gdbm_store ", nam, " ", (char *)-1, "\n", (char *)0);
-+ Logf("db_put: can't gdbm_store ", nam, " ", (char *)-1, "\n", (char *)0);
- free(dat.dptr);
- return (1);
- }
-@@ -204,7 +204,7 @@
-
- /* drop key from db */
- if (gdbm_delete(dbp, key)) {
-- logf("db_del: can't delete key ", nam, "\n", (char *)0);
-+ Logf("db_del: can't delete key ", nam, "\n", (char *)0);
- return (1);
- }
- return (0);
diff --git a/games/tinymux/pkg-descr b/games/tinymux/pkg-descr
index 08b2446e481d..cb7eb85e740d 100644
--- a/games/tinymux/pkg-descr
+++ b/games/tinymux/pkg-descr
@@ -1,7 +1,9 @@
-TinyMUX is a Multi-Player FreeForm adventure server.
+TinyMUX is a text-based game server in the MUSH family (which also
+includes PennMUSH, TinyMUSH, and RhostMUSH). It is a platform which
+allows potentially several thousand players to connect to a single
+text-driven environment, interact with each other and with the
+environment (which is maintain in a database). The rich programming
+environment can be used to build almost anything, limited only by
+your own imagination.
-Based on the popular TinyMUSH code (and PernMUSH) code,
-TinyMUX allows a group of players to build their own adventure
-style game. As distributed, there is no pre-built database so
-you might want to explore some of the many MUSHs that already
-exists.
+WWW: http://www.tinymux.org/
diff --git a/games/tinymux/pkg-plist b/games/tinymux/pkg-plist
index bf5e5abdfdb0..1788a9d92cde 100644
--- a/games/tinymux/pkg-plist
+++ b/games/tinymux/pkg-plist
@@ -1,40 +1,37 @@
-games/tinymux/Startmux
-games/tinymux/alias.conf
-games/tinymux/bin/dbconvert
-games/tinymux/bin/mkindx
-games/tinymux/bin/netmux
-games/tinymux/bin/slave
-games/tinymux/compat.conf
-games/tinymux/data/db_check
-games/tinymux/data/db_load
-games/tinymux/data/db_unload
-games/tinymux/mtrace.awk
-games/tinymux/mux.config
-games/tinymux/netmux.conf
-games/tinymux/text/badsite.txt
-games/tinymux/text/connect.txt
-games/tinymux/text/create_reg.txt
-games/tinymux/text/down.txt
-games/tinymux/text/full.txt
-games/tinymux/text/guest.txt
-games/tinymux/text/help.txt
-games/tinymux/text/motd.txt
-games/tinymux/text/news.txt
-games/tinymux/text/newuser.txt
-games/tinymux/text/plushelp.txt
-games/tinymux/text/quit.txt
-games/tinymux/text/register.txt
-games/tinymux/text/wizhelp.txt
-games/tinymux/text/wizmotd.txt
-games/tinymux/text/wiznews.txt
-%%PORTDOCS%%share/doc/tinymux/README
-%%PORTDOCS%%share/doc/tinymux/README.COMPRESSION
-%%PORTDOCS%%share/doc/tinymux/README.GUESTS
-%%PORTDOCS%%share/doc/tinymux/README.MEMORY
-%%PORTDOCS%%share/doc/tinymux/README.TOOLS
-%%PORTDOCS%%@dirrm share/doc/tinymux
-@dirrm games/tinymux/text
-@dirrm games/tinymux/data
-@dirrm games/tinymux/bin
-@dirrm games/tinymux
-@unexec rmdir %D/games 2>/dev/null || true
+bin/dbconvert
+etc/tinymux/alias.conf.sample
+etc/tinymux/compat.conf.sample
+etc/tinymux/mux.config.sample
+etc/tinymux/netmux.conf.sample
+sbin/netmux
+sbin/slave
+%%DATADIR%%/game/netmux/Backup
+%%DATADIR%%/game/netmux/Startmux
+%%DATADIR%%/game/netmux/_backupflat.sh
+%%DATADIR%%/game/netmux/data/db_check
+%%DATADIR%%/game/netmux/data/db_load
+%%DATADIR%%/game/netmux/data/db_unload
+%%DATADIR%%/game/netmux/data/netmux.db
+%%DATADIR%%/game/netmux/text/badsite.txt
+%%DATADIR%%/game/netmux/text/connect.txt
+%%DATADIR%%/game/netmux/text/create_reg.txt
+%%DATADIR%%/game/netmux/text/down.txt
+%%DATADIR%%/game/netmux/text/full.txt
+%%DATADIR%%/game/netmux/text/guest.txt
+%%DATADIR%%/game/netmux/text/help.txt
+%%DATADIR%%/game/netmux/text/motd.txt
+%%DATADIR%%/game/netmux/text/news.txt
+%%DATADIR%%/game/netmux/text/newuser.txt
+%%DATADIR%%/game/netmux/text/plushelp.txt
+%%DATADIR%%/game/netmux/text/quit.txt
+%%DATADIR%%/game/netmux/text/register.txt
+%%DATADIR%%/game/netmux/text/staffhelp.txt
+%%DATADIR%%/game/netmux/text/wizhelp.txt
+%%DATADIR%%/game/netmux/text/wizmotd.txt
+%%DATADIR%%/game/netmux/text/wiznews.txt
+@dirrm %%DATADIR%%/game/netmux/text
+@dirrm %%DATADIR%%/game/netmux/data
+@dirrm %%DATADIR%%/game/netmux
+@dirrm %%DATADIR%%/game
+@dirrm %%DATADIR%%
+@dirrm etc/tinymux