aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2000-02-23 08:55:11 +0800
committerjedgar <jedgar@FreeBSD.org>2000-02-23 08:55:11 +0800
commit90f211993193241362af21f8f002ba97b5debe47 (patch)
tree83c34b23dab9ce137a4b308e49e33f28a1ea1006 /games
parent595cfef754896878c098621148ded89024c58759 (diff)
downloadfreebsd-ports-gnome-90f211993193241362af21f8f002ba97b5debe47.tar.gz
freebsd-ports-gnome-90f211993193241362af21f8f002ba97b5debe47.tar.zst
freebsd-ports-gnome-90f211993193241362af21f8f002ba97b5debe47.zip
Nice KDE reimplementation of the /usr/games/rogue classic
PR: 15803 Submitted by: Will Andrews <andrews@technologist.com>
Diffstat (limited to 'games')
-rw-r--r--games/krogue/Makefile30
-rw-r--r--games/krogue/distinfo1
-rw-r--r--games/krogue/files/patch-ab11
-rw-r--r--games/krogue/files/patch-ac10
-rw-r--r--games/krogue/files/patch-ad33
-rw-r--r--games/krogue/files/patch-ae11
-rw-r--r--games/krogue/files/patch-af11
-rw-r--r--games/krogue/files/patch-ag18
-rw-r--r--games/krogue/files/patch-ah33
-rw-r--r--games/krogue/files/patch-ai20
-rw-r--r--games/krogue/files/patch-aj64
-rw-r--r--games/krogue/files/patch-an11
-rw-r--r--games/krogue/files/patch-ao11
-rw-r--r--games/krogue/pkg-comment1
-rw-r--r--games/krogue/pkg-descr9
-rw-r--r--games/krogue/pkg-plist100
16 files changed, 374 insertions, 0 deletions
diff --git a/games/krogue/Makefile b/games/krogue/Makefile
new file mode 100644
index 000000000000..e237a1567d4a
--- /dev/null
+++ b/games/krogue/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: krogue
+# Version required: 0.9.6
+# Date created: 19 Nov 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= krogue-0.9.6
+CATEGORIES= games
+MASTER_SITES= http://ksi.ii.uj.edu.pl/krogue/dl/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= andrews@technologist.com
+
+LIB_DEPENDS= kdecore.2:${PORTSDIR}/x11/kdelibs11
+BUILD_DEPENDS= xgettext:${PORTSDIR}/devel/gettext
+
+USE_QT= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKE_ENV= SHELL=${SH} PREFIX=${PREFIX} MAKE=${GMAKE} PCFLAGS="${CFLAGS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400004
+BROKEN= "obsolete compiler"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/krogue/distinfo b/games/krogue/distinfo
new file mode 100644
index 000000000000..10132f5e92b9
--- /dev/null
+++ b/games/krogue/distinfo
@@ -0,0 +1 @@
+MD5 (krogue-0.9.6.tgz) = d268e030260493c15650548367629c7b
diff --git a/games/krogue/files/patch-ab b/games/krogue/files/patch-ab
new file mode 100644
index 000000000000..2e29e0d49396
--- /dev/null
+++ b/games/krogue/files/patch-ab
@@ -0,0 +1,11 @@
+--- krogue/rogue/Makefile.in Sun Jan 9 16:42:12 2000
++++ krogue/rogue/Makefile.in.new Tue Feb 22 00:33:12 2000
+@@ -180,7 +180,7 @@
+ # in curses.c for more info.
+
+ #CFLAGS = -g -c -DUNIX -DUNIX_SYS5
+-CFLAGS = -c -O2 -DUNIX -DUNIX_SYS5
++CFLAGS = $(PCFLAGS) -c -DUNIX -DUNIX_SYS5
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/games/krogue/files/patch-ac b/games/krogue/files/patch-ac
new file mode 100644
index 000000000000..2b5ccec05d90
--- /dev/null
+++ b/games/krogue/files/patch-ac
@@ -0,0 +1,10 @@
+--- krogue/kdun.cpp Tue Dec 21 15:31:48 1999
++++ krogue/kdun.cpp.new Tue Feb 22 00:41:48 2000
+@@ -6,6 +6,7 @@
+ #include <kmsgbox.h>
+ #include <kconfig.h>
+ #include <ctype.h>
++#include <unistd.h>
+ #include "krestoredlg.h"
+ #include "rogue/dun.h"
+ #include "kcharfile.h"
diff --git a/games/krogue/files/patch-ad b/games/krogue/files/patch-ad
new file mode 100644
index 000000000000..69f78a2e2be5
--- /dev/null
+++ b/games/krogue/files/patch-ad
@@ -0,0 +1,33 @@
+--- krogue/rogue/move.c Sun Oct 24 13:30:32 1999
++++ krogue/rogue/move.c.new Sun Nov 21 23:03:50 1999
+@@ -15,7 +15,7 @@
+
+ short m_moves = 0;
+ boolean jump = 1;
+-char *you_can_move_again = _T("you can move again");
++char *you_can_move_again = msgQuote("you can move again");
+
+ extern short cur_room, halluc, blind, levitate;
+ extern short cur_level, max_level;
+@@ -324,18 +324,18 @@
+ boolean fainted = 0;
+
+ if (rogue.moves_left == HUNGRY) {
+- (void) strcpy(hunger_str, _T("hungry"));
++ (void) strcpy(hunger_str, msgQuote("hungry"));
+ message(transl(hunger_str), 0);
+ print_stats(STAT_HUNGER);
+ }
+ if (rogue.moves_left == WEAK) {
+- (void) strcpy(hunger_str, _T("weak"));
++ (void) strcpy(hunger_str, msgQuote("weak"));
+ message(transl(hunger_str), 1);
+ print_stats(STAT_HUNGER);
+ }
+ if (rogue.moves_left <= FAINT) {
+ if (rogue.moves_left == FAINT) {
+- (void) strcpy(hunger_str, _T("faint"));
++ (void) strcpy(hunger_str, msgQuote("faint"));
+ message(transl(hunger_str), 1);
+ print_stats(STAT_HUNGER);
+ }
diff --git a/games/krogue/files/patch-ae b/games/krogue/files/patch-ae
new file mode 100644
index 000000000000..a5f06d666ca2
--- /dev/null
+++ b/games/krogue/files/patch-ae
@@ -0,0 +1,11 @@
+--- krogue/rogue/pack.c Wed Sep 1 15:44:36 1999
++++ krogue/rogue/pack.c.new Sun Nov 21 23:04:02 1999
+@@ -13,7 +13,7 @@
+ #include "rogue.h"
+ #include "dun.h"
+
+-char *curse_message = _T("you can't, it appears to be cursed");
++char *curse_message = msgQuote("you can't, it appears to be cursed");
+ extern short levitate;
+
+ object *
diff --git a/games/krogue/files/patch-af b/games/krogue/files/patch-af
new file mode 100644
index 000000000000..3611a131ebac
--- /dev/null
+++ b/games/krogue/files/patch-af
@@ -0,0 +1,11 @@
+--- krogue/rogue/ring.c Sat Aug 28 14:23:08 1999
++++ krogue/rogue/ring.c.new Sun Nov 21 23:04:16 1999
+@@ -13,7 +13,7 @@
+ #include "rogue.h"
+ #include "dun.h"
+
+-char *no_ring = _T("there's no ring on that hand");
++char *no_ring = msgQuote("there's no ring on that hand");
+ short stealthy, r_rings, add_strength, e_rings, regeneration, ring_exp;
+ short auto_search;
+ boolean r_teleport, r_see_invisible, sustain_strength, maintain_armor;
diff --git a/games/krogue/files/patch-ag b/games/krogue/files/patch-ag
new file mode 100644
index 000000000000..1ba88784d850
--- /dev/null
+++ b/games/krogue/files/patch-ag
@@ -0,0 +1,18 @@
+--- krogue/rogue/rogue.h Tue Aug 31 12:38:17 1999
++++ krogue/rogue/rogue.h.new Sun Nov 21 22:08:57 1999
+@@ -26,7 +26,7 @@
+ extern const char *cmd_q;
+ extern struct obj *item_o;
+
+-#define _T(x) (x)
++#define msgQuote(x) (x)
+ #define transl(x) _i18n(x)
+
+ #define NOTHING ((unsigned short) 0)
+@@ -449,4 +449,4 @@
+ #ifdef __cplusplus
+ }
+ #endif
+-#endif
++#endif
+
diff --git a/games/krogue/files/patch-ah b/games/krogue/files/patch-ah
new file mode 100644
index 000000000000..cbaeb3ffcb0b
--- /dev/null
+++ b/games/krogue/files/patch-ah
@@ -0,0 +1,33 @@
+--- krogue/rogue/trap.c Fri May 14 07:08:43 1999
++++ krogue/rogue/trap.c.new Sun Nov 21 23:06:08 1999
+@@ -18,18 +18,18 @@
+ short bear_trap = 0;
+
+ char *trap_strings[TRAPS * 2] = {
+- _T("trap door"),
+- _T("you fell down a trap"),
+- _T("bear trap"),
+- _T("you are caught in a bear trap"),
+- _T("teleport trap"),
+- _T("teleport"),
+- _T("poison dart trap"),
+- _T("a small dart just hit you in the shoulder"),
+- _T("sleeping gas trap"),
+- _T("a strange white mist envelops you and you fall asleep"),
+- _T("rust trap"),
+- _T("a gush of water hits you on the head")
++ msgQuote("trap door"),
++ msgQuote("you fell down a trap"),
++ msgQuote("bear trap"),
++ msgQuote("you are caught in a bear trap"),
++ msgQuote("teleport trap"),
++ msgQuote("teleport"),
++ msgQuote("poison dart trap"),
++ msgQuote("a small dart just hit you in the shoulder"),
++ msgQuote("sleeping gas trap"),
++ msgQuote("a strange white mist envelops you and you fall asleep"),
++ msgQuote("rust trap"),
++ msgQuote("a gush of water hits you on the head")
+ };
+
+ extern short cur_level, party_room;
diff --git a/games/krogue/files/patch-ai b/games/krogue/files/patch-ai
new file mode 100644
index 000000000000..37f119a7f068
--- /dev/null
+++ b/games/krogue/files/patch-ai
@@ -0,0 +1,20 @@
+--- krogue/rogue/use.c Sat Aug 28 17:49:55 1999
++++ krogue/rogue/use.c.new Sun Nov 21 23:06:33 1999
+@@ -21,7 +21,7 @@
+ boolean see_invisible = 0;
+ short extra_hp = 0;
+ boolean detect_monster = 0;
+-char *strange_feeling = _T("you have a strange feeling for a moment, then it passes");
++char *strange_feeling = msgQuote("you have a strange feeling for a moment, then it passes");
+
+ extern short bear_trap;
+ extern char hunger_str[];
+@@ -196,7 +196,7 @@
+ ccmd=CMD_IDENTIFY;
+ cmd_ask=2+256;
+ cmd_mask=ALL_OBJECTS;
+- cmd_q=_T("what would you like to identify");
++ cmd_q=msgQuote("what would you like to identify");
+ break;
+ case TELEPORT:
+ tele();
diff --git a/games/krogue/files/patch-aj b/games/krogue/files/patch-aj
new file mode 100644
index 000000000000..f3b982e32c1b
--- /dev/null
+++ b/games/krogue/files/patch-aj
@@ -0,0 +1,64 @@
+--- krogue/kcmdr.cpp.orig Sun Oct 10 09:33:41 1999
++++ krogue/kcmdr.cpp Wed Dec 15 15:28:50 1999
+@@ -36,26 +36,26 @@
+ {'m', ASK_DIR, 0, NULL},
+ {'s', 0, 0, NULL},
+ {'f', ASK_DIR, 0, NULL},
+- {'e', ASK_ITEM, FOOD, _T("eat what")},
+- {'r', ASK_ITEM, SCROLL, _T("read what")},
+- {'P', ASK_ITEM|ASK_EMPTY_HAND, RING, _T("put on what")},
++ {'e', ASK_ITEM, FOOD, msgQuote("eat what")},
++ {'r', ASK_ITEM, SCROLL, msgQuote("read what")},
++ {'P', ASK_ITEM|ASK_EMPTY_HAND, RING, msgQuote("put on what")},
+ {'^', ASK_DIR, 0, NULL},
+ {'T', 0, 0, NULL},
+- {'w', ASK_ITEM, ALL_OBJECTS&(~(ARMOR|RING)), _T("wield what")},
+- {'z', ASK_DIR|ASK_ITEM, WAND, _T("zap what")},
++ {'w', ASK_ITEM, ALL_OBJECTS&(~(ARMOR|RING)), msgQuote("wield what")},
++ {'z', ASK_DIR|ASK_ITEM, WAND, msgQuote("zap what")},
+ {'v', 0, 0, NULL},
+ {'\x01', 0, 0, NULL},
+ {'F', ASK_DIR, 0, NULL},
+- {'q', ASK_ITEM, POTION, _T("quaff what")},
+- {'d', ASK_ITEM, ALL_OBJECTS, _T("drop what")},
++ {'q', ASK_ITEM, POTION, msgQuote("quaff what")},
++ {'d', ASK_ITEM, ALL_OBJECTS, msgQuote("drop what")},
+ {'R', ASK_HAND, 0, NULL},
+- {'I', ASK_ITEM, ALL_OBJECTS, _T("inventory what")},
+- {'W', ASK_ITEM, ARMOR, _T("wear what")},
+- {'t', ASK_DIR|ASK_ITEM, ALL_OBJECTS, _T("throw what")},
++ {'I', ASK_ITEM, ALL_OBJECTS, msgQuote("inventory what")},
++ {'W', ASK_ITEM, ARMOR, msgQuote("wear what")},
++ {'t', ASK_DIR|ASK_ITEM, ALL_OBJECTS, msgQuote("throw what")},
+ {')', 0, 0, NULL},
+ {']', 0, 0, NULL},
+ {'=', 0, 0, NULL},
+- {CMD_CALL, ASK_ITEM, SCROLL|POTION|WAND|RING, _T("call what")},
++ {CMD_CALL, ASK_ITEM, SCROLL|POTION|WAND|RING, msgQuote("call what")},
+ {CMD_WIZ, 0, 0, NULL},
+ {CMD_QUIT, 0, 0, NULL},
+ {CMD_INV, 0, 0, NULL},
+@@ -213,9 +213,9 @@
+ {
+ for (i=0; i<NCMD; i++)
+ {
+- if (r_cmdtable[i].cmd==k->ascii())
++ if (r_cmdtable[i].thecmd==k->ascii())
+ {
+- ccmd=r_cmdtable[i].cmd;
++ ccmd=r_cmdtable[i].thecmd;
+ cmd_ask=r_cmdtable[i].ask;
+ cmd_q=r_cmdtable[i].q;
+ cmd_mask=r_cmdtable[i].mask;
+@@ -226,9 +226,9 @@
+ {
+ if (::wizard)
+ for (i=0; i<NWIZCMD; i++)
+- if (wiz_cmdtable[i].cmd==k->ascii())
++ if (wiz_cmdtable[i].thecmd==k->ascii())
+ {
+- ccmd=wiz_cmdtable[i].cmd;
++ ccmd=wiz_cmdtable[i].thecmd;
+ cmd_ask=wiz_cmdtable[i].ask;
+ cmd_q=wiz_cmdtable[i].q;
+ cmd_mask=wiz_cmdtable[i].mask;
diff --git a/games/krogue/files/patch-an b/games/krogue/files/patch-an
new file mode 100644
index 000000000000..4e0dddb6b49f
--- /dev/null
+++ b/games/krogue/files/patch-an
@@ -0,0 +1,11 @@
+--- krogue/kcmdr.h.orig Sun Oct 10 09:15:43 1999
++++ krogue/kcmdr.h Wed Dec 15 15:26:29 1999
+@@ -26,7 +26,7 @@
+
+ struct cmd
+ {
+- int cmd, ask;
++ int thecmd, ask;
+ int mask;
+ char *q;
+ };
diff --git a/games/krogue/files/patch-ao b/games/krogue/files/patch-ao
new file mode 100644
index 000000000000..d2941831b28c
--- /dev/null
+++ b/games/krogue/files/patch-ao
@@ -0,0 +1,11 @@
+--- krogue/kinvwnd.cpp Mon Dec 27 17:11:42 1999
++++ krogue/kinvwnd.cpp.new Tue Feb 22 00:48:16 2000
+@@ -315,7 +315,7 @@
+ {"food", NULL, false, 0, FOOD},
+ {"potion", id_potions, true, POTIONS, POTION},
+ {"scroll", id_scrolls, true, SCROLLS, SCROLL},
+- {_T("weapon"), id_weapons, false, WEAPONS, WEAPON},
++ {msgQuote("weapon"), id_weapons, false, WEAPONS, WEAPON},
+ {"armor", id_armors, false, ARMORS, ARMOR},
+ {"wand", id_wands, true, WANDS, WAND},
+ {"ring", id_rings, true, RINGS, RING},
diff --git a/games/krogue/pkg-comment b/games/krogue/pkg-comment
new file mode 100644
index 000000000000..079c4f7d7b44
--- /dev/null
+++ b/games/krogue/pkg-comment
@@ -0,0 +1 @@
+KDE-ified version of classical rogue.
diff --git a/games/krogue/pkg-descr b/games/krogue/pkg-descr
new file mode 100644
index 000000000000..c99f5dfc22ad
--- /dev/null
+++ b/games/krogue/pkg-descr
@@ -0,0 +1,9 @@
+Nice KDE reimplementation of the /usr/games/rogue classic.
+I like it mostly because it allows me to use the arrow
+keys instead of 'h', 'j', 'k', 'l'. The program looks
+fairly well-developed.
+
+WWW: http://ksi.ii.uj.edu.pl/krogue/
+Author: Mikolaj Zalewski <M.Zalewski@pegaz.if.uj.edu.pl>
+
+--Will <andrews@technologist.com>
diff --git a/games/krogue/pkg-plist b/games/krogue/pkg-plist
new file mode 100644
index 000000000000..e9cda1e9d6b4
--- /dev/null
+++ b/games/krogue/pkg-plist
@@ -0,0 +1,100 @@
+bin/krogue
+share/mimelnk/application/x-krogue.kdelnk
+share/applnk/Games/krogue.kdelnk
+share/icons/kroguesg.xpm
+share/icons/krogue.xpm
+share/icons/mini/krogue.xpm
+share/icons/mini/kroguesg.xpm
+share/apps/krogue/pics/rogue.xpm
+share/apps/krogue/pics/rip.xpm
+share/apps/krogue/pics/about.xpm
+share/apps/krogue/templates/killedby.html
+share/apps/krogue/templates/top10.html
+share/apps/krogue/templates/quit.html
+share/apps/krogue/templates/intro.html
+share/apps/krogue/templates/win.html
+share/apps/krogue/toolbar/eat.xpm
+share/apps/krogue/toolbar/drop.xpm
+share/apps/krogue/toolbar/zap.xpm
+share/apps/krogue/toolbar/quaff.xpm
+share/apps/krogue/toolbar/lputr.xpm
+share/apps/krogue/toolbar/lremr.xpm
+share/apps/krogue/toolbar/rputr.xpm
+share/apps/krogue/toolbar/rremr.xpm
+share/apps/krogue/toolbar/read.xpm
+share/apps/krogue/toolbar/takeoff.xpm
+share/apps/krogue/toolbar/throw.xpm
+share/apps/krogue/toolbar/wear.xpm
+share/apps/krogue/toolbar/wield.xpm
+share/apps/krogue/toolbar/downstair.xpm
+share/apps/krogue/toolbar/upstair.xpm
+share/apps/krogue/toolbar/rest.xpm
+share/apps/krogue/toolbar/search.xpm
+share/apps/krogue/toolbar/invent.xpm
+share/locale/pl/LC_MESSAGES/krogue.mo
+share/doc/HTML/en/krogue/index.html
+share/doc/HTML/en/krogue/general.html
+share/doc/HTML/en/krogue/moving.html
+share/doc/HTML/en/krogue/monster.html
+share/doc/HTML/en/krogue/hp.html
+share/doc/HTML/en/krogue/hidden.html
+share/doc/HTML/en/krogue/exp.html
+share/doc/HTML/en/krogue/food.html
+share/doc/HTML/en/krogue/scroll.html
+share/doc/HTML/en/krogue/potion.html
+share/doc/HTML/en/krogue/str.html
+share/doc/HTML/en/krogue/weapon.html
+share/doc/HTML/en/krogue/ring.html
+share/doc/HTML/en/krogue/wand.html
+share/doc/HTML/en/krogue/armor.html
+share/doc/HTML/en/krogue/key.html
+share/doc/HTML/en/krogue/arm.gif
+share/doc/HTML/en/krogue/exp.gif
+share/doc/HTML/en/krogue/hp.gif
+share/doc/HTML/en/krogue/str.gif
+share/doc/HTML/en/krogue/downstair.gif
+share/doc/HTML/en/krogue/eat.gif
+share/doc/HTML/en/krogue/flee.gif
+share/doc/HTML/en/krogue/food.gif
+share/doc/HTML/en/krogue/potion.gif
+share/doc/HTML/en/krogue/puton.gif
+share/doc/HTML/en/krogue/zap.gif
+share/doc/HTML/en/krogue/wield.gif
+share/doc/HTML/en/krogue/weapon.gif
+share/doc/HTML/en/krogue/wear.gif
+share/doc/HTML/en/krogue/wand.gif
+share/doc/HTML/en/krogue/throw.gif
+share/doc/HTML/en/krogue/takeoff.gif
+share/doc/HTML/en/krogue/stair.gif
+share/doc/HTML/en/krogue/search.gif
+share/doc/HTML/en/krogue/scroll.gif
+share/doc/HTML/en/krogue/ring.gif
+share/doc/HTML/en/krogue/remove.gif
+share/doc/HTML/en/krogue/read.gif
+share/doc/HTML/en/krogue/quaff.gif
+share/doc/HTML/pl/krogue/index.html
+share/doc/HTML/pl/krogue/general.html
+share/doc/HTML/pl/krogue/moving.html
+share/doc/HTML/pl/krogue/exp.html
+share/doc/HTML/pl/krogue/hidden.html
+share/doc/HTML/pl/krogue/hp.html
+share/doc/HTML/pl/krogue/monster.html
+share/doc/HTML/pl/krogue/str.gif
+share/doc/HTML/pl/krogue/hp.gif
+share/doc/HTML/pl/krogue/exp.gif
+share/doc/HTML/pl/krogue/arm.gif
+share/doc/HTML/pl/krogue/key.html
+share/doc/HTML/pl/krogue/ring.html
+share/doc/HTML/pl/krogue/wand.html
+share/doc/HTML/pl/krogue/armor.html
+share/doc/HTML/pl/krogue/weapon.html
+share/doc/HTML/pl/krogue/str.html
+share/doc/HTML/pl/krogue/potion.html
+share/doc/HTML/pl/krogue/scroll.html
+share/doc/HTML/pl/krogue/food.html
+share/apps/krogue/krogue.scores
+@dirrm share/apps/krogue/pics
+@dirrm share/apps/krogue/templates
+@dirrm share/apps/krogue/toolbar
+@dirrm share/doc/HTML/en/krogue
+@dirrm share/doc/HTML/pl/krogue