aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorphilip <philip@FreeBSD.org>2009-09-15 21:43:35 +0800
committerphilip <philip@FreeBSD.org>2009-09-15 21:43:35 +0800
commit9425093d0e7472599bc0d3730ab0664798eb81be (patch)
tree993efab2b6f576adb4c89aacddd713fe18304201 /games
parent6ed629e5ec80bf55e626569942b0e2340a12fd4d (diff)
downloadfreebsd-ports-gnome-9425093d0e7472599bc0d3730ab0664798eb81be.tar.gz
freebsd-ports-gnome-9425093d0e7472599bc0d3730ab0664798eb81be.tar.zst
freebsd-ports-gnome-9425093d0e7472599bc0d3730ab0664798eb81be.zip
Update to 1.6.5.
http://svn.gna.org/viewcvs/wesnoth/tags/1.6.5/changelog?rev=38453&view=download PR: ports/138711 Submitted by: Anonymous <swell.k@gmail.com> Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/wesnoth/Makefile40
-rw-r--r--games/wesnoth/distinfo6
-rw-r--r--games/wesnoth/pkg-plist16
3 files changed, 40 insertions, 22 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 568d7de68469..de4b0ab97ebd 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -6,23 +6,20 @@
#
PORTNAME= wesnoth
-PORTVERSION= 1.6.4
-PORTREVISION= 1
+PORTVERSION= 1.6.5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-1.6/${PORTNAME}-${PORTVERSION} \
http://www.wesnoth.org/files/
-
MAINTAINER= philip@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs
-CONFLICTS= wesnoth-1.5* wesnoth-1.7*
+CONFLICTS= wesnoth-devel-[0-9]*
USE_SDL= image mixer net ttf
-USE_GNOME= gnometarget pango
+USE_GNOME= desktopfileutils gnometarget pango
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
@@ -31,17 +28,16 @@ USE_AUTOTOOLS= aclocal:110 autoheader:262 automake:110 autoconf:262
ACLOCAL_ARGS= -Im4
AUTOMAKE_ARGS= --add-missing --copy
CONFIGURE_ARGS= --localstatedir=/var \
+ --with-icondir=${PREFIX}/share/pixmaps \
--with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \
--with-localedir=${PREFIX}/share/locale
-MANLANG= "" cs de en_GB es fi fr hu it lt pl sr sr@latin sv tr \
+MANLANG_GAME= gl sk
+MANLANG= "" cs de en_GB es et fi fr hu it lt pl sr sr@latin sv tr \
zh_CN zh_TW
MAN6= wesnoth.6
-MAN6_GL= wesnoth.6
-MAN6_RU= wesnoth.6
-MAN6_SK= wesnoth.6
OPTIONS= CAMPAIGN "Enable campaign server" On \
EDITOR "Enable map editor" On \
@@ -52,6 +48,17 @@ OPTIONS= CAMPAIGN "Enable campaign server" On \
.include <bsd.port.pre.mk>
+# workaround: compress and add to plist disobedient man pages
+.for manlang in ${MANLANG_GAME}
+MAN6_${manlang:U}= wesnoth.6
+
+.if defined(NOMANCOMPRESS)
+PLIST_FILES+= man/${manlang}/man6/wesnoth.6
+.else
+PLIST_FILES+= man/${manlang}/man6/wesnoth.6.gz
+.endif
+.endfor
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -103,8 +110,13 @@ PLIST_SUB+= TOOLS=""
BROKEN= you need NLS support for `campaignd' or `wesnothd' or tools to link against gettext
.endif
-post-configure:
- @${REINPLACE_CMD} -e 's|[$$][{]datarootdir[}]/icons|${LOCALBASE}/share/pixmaps|' \
- ${WRKSRC}/icons/Makefile
+post-install: .SILENT
+ -update-desktop-database
+
+.if !defined(NOMANCOMPRESS)
+. for manlang in ${MANLANG_GAME}
+ ${GZIP_CMD} ${PREFIX}/man/${manlang}/man6/wesnoth.6
+. endfor
+.endif
.include <bsd.port.post.mk>
diff --git a/games/wesnoth/distinfo b/games/wesnoth/distinfo
index 27933ebe0eea..444ac6c42480 100644
--- a/games/wesnoth/distinfo
+++ b/games/wesnoth/distinfo
@@ -1,3 +1,3 @@
-MD5 (wesnoth-1.6.4.tar.bz2) = c8bc4c5b2be28e29563dfe3f89eafd51
-SHA256 (wesnoth-1.6.4.tar.bz2) = 496a1a9b2b9f05e400a60466ae0644cd376902439436b0ab1ef3e9a67105a1b3
-SIZE (wesnoth-1.6.4.tar.bz2) = 229852077
+MD5 (wesnoth-1.6.5.tar.bz2) = 493826bbd9ba355930765a7e8fe3749a
+SHA256 (wesnoth-1.6.5.tar.bz2) = 7ef047ae364278a5bf9bdc69228f77d825f793f1c4d9adae8b47f0882e7f30d7
+SIZE (wesnoth-1.6.5.tar.bz2) = 230239169
diff --git a/games/wesnoth/pkg-plist b/games/wesnoth/pkg-plist
index 76710d844950..6052f7268ca1 100644
--- a/games/wesnoth/pkg-plist
+++ b/games/wesnoth/pkg-plist
@@ -10,7 +10,7 @@ bin/wesnoth
share/applications/wesnoth.desktop
%%EDITOR%%share/applications/wesnoth_editor.desktop
share/pixmaps/wesnoth-icon.png
-share/pixmaps/wesnoth_editor-icon.png
+%%EDITOR%%share/pixmaps/wesnoth_editor-icon.png
%%DOCSDIR%%/manual/CMakeLists.txt
%%DOCSDIR%%/manual/images/de/game-screen-1.5.7.jpg
%%DOCSDIR%%/manual/images/de/main-menu-1.5.11.jpg
@@ -3938,19 +3938,21 @@ share/pixmaps/wesnoth_editor-icon.png
%%DATADIR%%/data/core/images/terrain/lava-convex-r.png
%%DATADIR%%/data/core/images/terrain/lava-convex-tl.png
%%DATADIR%%/data/core/images/terrain/lava-convex-tr.png
-%%DATADIR%%/data/core/images/terrain/lava-n-ne-nw-s.png
-%%DATADIR%%/data/core/images/terrain/lava-n-ne-nw.png
+%%DATADIR%%/data/core/images/terrain/lava-n-ne-se-s.png
+%%DATADIR%%/data/core/images/terrain/lava-n-ne-se.png
%%DATADIR%%/data/core/images/terrain/lava-n-ne.png
%%DATADIR%%/data/core/images/terrain/lava-n.png
-%%DATADIR%%/data/core/images/terrain/lava-ne-nw-s.png
+%%DATADIR%%/data/core/images/terrain/lava-ne-se-s.png
%%DATADIR%%/data/core/images/terrain/lava-ne-se.png
%%DATADIR%%/data/core/images/terrain/lava-ne.png
+%%DATADIR%%/data/core/images/terrain/lava-nw-n-ne.png
%%DATADIR%%/data/core/images/terrain/lava-nw-n.png
%%DATADIR%%/data/core/images/terrain/lava-nw.png
-%%DATADIR%%/data/core/images/terrain/lava-s-nw-ne-n.png
+%%DATADIR%%/data/core/images/terrain/lava-s-sw-nw-n.png
%%DATADIR%%/data/core/images/terrain/lava-s-sw-nw.png
%%DATADIR%%/data/core/images/terrain/lava-s-sw.png
%%DATADIR%%/data/core/images/terrain/lava-s.png
+%%DATADIR%%/data/core/images/terrain/lava-se-s-sw.png
%%DATADIR%%/data/core/images/terrain/lava-se-s.png
%%DATADIR%%/data/core/images/terrain/lava-se.png
%%DATADIR%%/data/core/images/terrain/lava-sw-nw-n.png
@@ -9711,6 +9713,8 @@ share/pixmaps/wesnoth_editor-icon.png
@dirrmtry man/en_GB
@dirrmtry man/es/man6
@dirrmtry man/es
+@dirrmtry man/et/man6
+@dirrmtry man/et
@dirrmtry man/fi/man6
@dirrmtry man/fi
@dirrmtry man/fr/man6
@@ -9763,3 +9767,5 @@ share/pixmaps/wesnoth_editor-icon.png
%%NLS%%@dirrmtry share/locale/tl/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/tl
%%SERVER%%@unexec rmdir /var/run/wesnothd 2>/dev/null || echo "If you are permanently removing this port, you should do a 'rm -rf /var/run/wesnothd' to remove it." | fmt
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true