aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-09-25 06:49:33 +0800
committernemysis <nemysis@FreeBSD.org>2013-09-25 06:49:33 +0800
commit94de8383fd025a4c47e3592ac980a9e768159ada (patch)
treefec559076fa6bcd6576de4d2d1e84fd5dc36988b /games
parent4ac5dc3b3dbda5ea6eeb1b532f057d7d03bb3284 (diff)
downloadfreebsd-ports-gnome-94de8383fd025a4c47e3592ac980a9e768159ada.tar.gz
freebsd-ports-gnome-94de8383fd025a4c47e3592ac980a9e768159ada.tar.zst
freebsd-ports-gnome-94de8383fd025a4c47e3592ac980a9e768159ada.zip
- Change Makefile header
- Bump portrevision - Change maintainer email gmx.ch --> FreeBSD.org - USES gmake - Use pkg-plist instead of PLIST_FILES and PLIST_DIRS - Change REINPLACE_CMD, fix build with Clang - Use REINPLACE_CMD instead of simple patches - Mute dir install - Update WWW Approved by: wg/pawel (mentors)
Diffstat (limited to 'games')
-rw-r--r--games/smashbattle/Makefile37
-rw-r--r--games/smashbattle/files/patch-Makefile11
-rw-r--r--games/smashbattle/pkg-descr2
-rw-r--r--games/smashbattle/pkg-plist99
4 files changed, 117 insertions, 32 deletions
diff --git a/games/smashbattle/Makefile b/games/smashbattle/Makefile
index 6c3af7d3ab5c..f0edb88b6e37 100644
--- a/games/smashbattle/Makefile
+++ b/games/smashbattle/Makefile
@@ -1,53 +1,50 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= smashbattle
PORTVERSION= 110224
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/beta-${PORTVERSION}
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= 8-bit style platform battle game
WRKSRC= ${WRKDIR}/${DISTNAME}/battle/Battle
USE_ZIP= yes
EXTRACT_AFTER_ARGS= -d ${WRKDIR}/${DISTNAME}
-USE_GMAKE= yes
+USES= gmake
+USE_SDL= sdl image mixer
USE_DOS2UNIX= *.cpp *.h *.ini Makefile
ALL_TARGET= battle
-USE_SDL= sdl image mixer
NO_STAGE= yes
pre-extract:
@${MKDIR} ${WRKDIR}/${DISTNAME}
-PLIST_FILES= bin/${PORTNAME} \
- share/applications/${PORTNAME}.desktop \
- share/applications/${PORTNAME}fs.desktop \
- share/pixmaps/${PORTNAME}.png
-PLIST_DIRSTRY= share/applications
-
-PORTDATA= *
-
SUB_FILES= ${PORTNAME}
.include <bsd.port.options.mk>
post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|CC=|CC?=|' \
+ -e 's|CFLAGS=-c -Wall|CFLAGS += $$(shell sdl-config --cflags) -c -Wall|' \
+ -e 's|LDFLAGS=-lSDL -lSDL_mixer -lz -lstdc++|LDFLAGS += $$(shell $${SDL_CONFIG} --libs) -lSDL -lSDL_mixer -lz -lstdc++ -lm|' \
+ ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/usr/share/games/smashbattle/gfx/SB.png|${PORTNAME}|' \
-e 's|/usr/local/bin/smashbattle|${PORTNAME}|' \
- ${WRKSRC}/linux/${PORTNAME}.desktop ${WRKSRC}/linux/${PORTNAME}fs.desktop
+ ${WRKSRC}/linux/*.desktop
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/battle ${DATADIR}/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "gfx music sfx stage" ${DATADIR})
- ${INSTALL_DATA} ${WRKSRC}/gfx/SB.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
- ${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/linux/${PORTNAME}.desktop ${PREFIX}/share/applications/
- ${INSTALL_DATA} ${WRKSRC}/linux/${PORTNAME}fs.desktop ${PREFIX}/share/applications/
+ ${INSTALL_PROGRAM} ${WRKSRC}/battle ${DATADIR}/${PORTNAME}
+ ${LN} -sf ${DATADIR}/gfx/SB.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+ @${MKDIR} ${PREFIX}/share/applications/
+# ${INSTALL_DATA} ${WRKSRC}/linux/*.desktop ${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/linux/*.desktop ${DESKTOPDIR}
.include <bsd.port.mk>
diff --git a/games/smashbattle/files/patch-Makefile b/games/smashbattle/files/patch-Makefile
deleted file mode 100644
index ffed56f3c7a6..000000000000
--- a/games/smashbattle/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2012-05-11 15:51:06.000000000 +0200
-+++ Makefile 2012-05-11 16:34:16.000000000 +0200
-@@ -1,6 +1,6 @@
- CC=g++
--CFLAGS=-c -Wall
--LDFLAGS=-lSDL -lSDL_mixer -lz -lstdc++
-+CFLAGS += $(shell sdl-config --cflags) -c -Wall
-+LDFLAGS += $(shell sdl-config --libs) -lSDL -lSDL_mixer -lz -lstdc++ -lm
- SRCS=Airstrike.cpp\
- AirstrikePowerUp.cpp\
- AmmoPowerUp.cpp\
diff --git a/games/smashbattle/pkg-descr b/games/smashbattle/pkg-descr
index 858225b7df59..a365d9a68f29 100644
--- a/games/smashbattle/pkg-descr
+++ b/games/smashbattle/pkg-descr
@@ -3,4 +3,4 @@ three or four player face off against each other.
The game was inspired by the mario battle minigame from mario 3
when we started developing, but changed a lot over time.
-WWW: http://smashbattle.condor.tv/
+WWW: http://smashbattle.demontpx.com/
diff --git a/games/smashbattle/pkg-plist b/games/smashbattle/pkg-plist
new file mode 100644
index 000000000000..060fd6330400
--- /dev/null
+++ b/games/smashbattle/pkg-plist
@@ -0,0 +1,99 @@
+bin/smashbattle
+share/applications/smashbattle.desktop
+share/applications/smashbattlefs.desktop
+share/pixmaps/smashbattle.png
+%%DATADIR%%/gfx/SB.bmp
+%%DATADIR%%/gfx/SB.ico
+%%DATADIR%%/gfx/SB.png
+%%DATADIR%%/gfx/anton.bmp
+%%DATADIR%%/gfx/arjan.bmp
+%%DATADIR%%/gfx/berry.bmp
+%%DATADIR%%/gfx/bert.bmp
+%%DATADIR%%/gfx/bg_black.bmp
+%%DATADIR%%/gfx/bg_blue.bmp
+%%DATADIR%%/gfx/bg_grey.bmp
+%%DATADIR%%/gfx/bg_orange.bmp
+%%DATADIR%%/gfx/bg_white.bmp
+%%DATADIR%%/gfx/bomb.bmp
+%%DATADIR%%/gfx/cannon.bmp
+%%DATADIR%%/gfx/chick.bmp
+%%DATADIR%%/gfx/common.bmp
+%%DATADIR%%/gfx/cups.bmp
+%%DATADIR%%/gfx/donja.bmp
+%%DATADIR%%/gfx/eva.bmp
+%%DATADIR%%/gfx/font_l.bmp
+%%DATADIR%%/gfx/font_m.bmp
+%%DATADIR%%/gfx/font_s.bmp
+%%DATADIR%%/gfx/gatling.bmp
+%%DATADIR%%/gfx/gijs.bmp
+%%DATADIR%%/gfx/jay.bmp
+%%DATADIR%%/gfx/jeremy.bmp
+%%DATADIR%%/gfx/jeroen.bmp
+%%DATADIR%%/gfx/kim.bmp
+%%DATADIR%%/gfx/marcel.bmp
+%%DATADIR%%/gfx/okke.bmp
+%%DATADIR%%/gfx/peter.bmp
+%%DATADIR%%/gfx/player1hp.bmp
+%%DATADIR%%/gfx/player2hp.bmp
+%%DATADIR%%/gfx/pmarkers.bmp
+%%DATADIR%%/gfx/powerups.bmp
+%%DATADIR%%/gfx/props.bmp
+%%DATADIR%%/gfx/rob.bmp
+%%DATADIR%%/gfx/rutger.bmp
+%%DATADIR%%/gfx/ruud.bmp
+%%DATADIR%%/gfx/shield.bmp
+%%DATADIR%%/gfx/steven.bmp
+%%DATADIR%%/gfx/tedje.bmp
+%%DATADIR%%/gfx/tiles.bmp
+%%DATADIR%%/gfx/tobias.bmp
+%%DATADIR%%/gfx/ton.bmp
+%%DATADIR%%/gfx/weapons.bmp
+%%DATADIR%%/music/a_hero_rises.ogg
+%%DATADIR%%/music/graveyard.ogg
+%%DATADIR%%/music/hydro_dreams.ogg
+%%DATADIR%%/music/space_farer.ogg
+%%DATADIR%%/music/victory.ogg
+%%DATADIR%%/sfx/airstrike.wav
+%%DATADIR%%/sfx/bounce.wav
+%%DATADIR%%/sfx/countdown.wav
+%%DATADIR%%/sfx/explode.wav
+%%DATADIR%%/sfx/go.wav
+%%DATADIR%%/sfx/hit.wav
+%%DATADIR%%/sfx/item.wav
+%%DATADIR%%/sfx/jump.wav
+%%DATADIR%%/sfx/laser.wav
+%%DATADIR%%/sfx/pause.wav
+%%DATADIR%%/sfx/select.wav
+%%DATADIR%%/sfx/select_character.wav
+%%DATADIR%%/sfx/shield.wav
+%%DATADIR%%/sfx/shoot.wav
+%%DATADIR%%/sfx/youlose.wav
+%%DATADIR%%/smashbattle
+%%DATADIR%%/stage/blastbowl.lvl
+%%DATADIR%%/stage/boulderdash.lvl
+%%DATADIR%%/stage/chick_invasion.lvl
+%%DATADIR%%/stage/chick_invasion_ii.lvl
+%%DATADIR%%/stage/chicken_run.lvl
+%%DATADIR%%/stage/commongrounds.lvl
+%%DATADIR%%/stage/ducknhunt.lvl
+%%DATADIR%%/stage/easy_does_it.lvl
+%%DATADIR%%/stage/lamoustache.lvl
+%%DATADIR%%/stage/piepit.lvl
+%%DATADIR%%/stage/pitfall.lvl
+%%DATADIR%%/stage/pitofdeath.lvl
+%%DATADIR%%/stage/platformalley.lvl
+%%DATADIR%%/stage/pogostick.lvl
+%%DATADIR%%/stage/rabbithole.lvl
+%%DATADIR%%/stage/slipnslide.lvl
+%%DATADIR%%/stage/snowfight.lvl
+%%DATADIR%%/stage/stayhigh.lvl
+%%DATADIR%%/stage/thefunnel.lvl
+%%DATADIR%%/stage/titlescreen.lvl
+%%DATADIR%%/stage/trainingdojo.lvl
+%%DATADIR%%/stage/tryout.lvl
+@dirrm %%DATADIR%%/stage
+@dirrm %%DATADIR%%/sfx
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%
+@dirrmtry share/applications