aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-03-04 20:16:29 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-03-04 20:16:29 +0800
commit9a50ff5c461dfba26eaa7ea7fe445fa15e76b877 (patch)
tree14ca507496af2d8347c391407650aed2e266a2c4 /games
parent6e902fadd4bba71ba188fcef4668a121eb6c06f8 (diff)
downloadfreebsd-ports-gnome-9a50ff5c461dfba26eaa7ea7fe445fa15e76b877.tar.gz
freebsd-ports-gnome-9a50ff5c461dfba26eaa7ea7fe445fa15e76b877.tar.zst
freebsd-ports-gnome-9a50ff5c461dfba26eaa7ea7fe445fa15e76b877.zip
D2X-XL is a community modified version of Icculus's D2X port,
the original Unix port of Descent by Parallax software. It contains many bug fixes and improvements since Icculus stopped working on D2X. You need to own the orignal game or download demo data files. WWW: http://www.descent2.de/ PR: 132086 Submitted by: Aragon Gouveia <aragon at phat dot za dot net>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/d2x-xl/Makefile62
-rw-r--r--games/d2x-xl/distinfo3
-rw-r--r--games/d2x-xl/files/patch-include-ogl_defs.h11
-rw-r--r--games/d2x-xl/files/pkg-message.in8
-rw-r--r--games/d2x-xl/pkg-descr9
6 files changed, 94 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 98a57d886d80..53748d9b7ce8 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -157,6 +157,7 @@
SUBDIR += cultivation
SUBDIR += cursive
SUBDIR += d2x
+ SUBDIR += d2x-xl
SUBDIR += daimonin-client
SUBDIR += dangen
SUBDIR += dangerdeep
diff --git a/games/d2x-xl/Makefile b/games/d2x-xl/Makefile
new file mode 100644
index 000000000000..cb34c5331621
--- /dev/null
+++ b/games/d2x-xl/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: d2x-xl
+# Date created: 25 Feb 2009
+# Whom: Aragon Gouveia
+#
+# $FreeBSD$
+#
+
+PORTNAME= d2x-xl
+PORTVERSION= 1.13.127
+CATEGORIES= games
+MASTER_SITES= http://www.descent2.de/downloads/
+DISTFILES= ${PORTNAME}-src-${PORTVERSION}.rar
+
+MAINTAINER= aragon@phat.za.net
+COMMENT= Community Unix port of Descent 2 Game
+
+EXTRACT_DEPENDS=unrar:${PORTSDIR}/archivers/unrar
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-debug --enable-release=yes --with-sharepath=${PREFIX}/share/d2x-xl
+USE_SDL= sdl mixer
+USE_GMAKE= yes
+USE_AUTOTOOLS= aclocal:110 \
+ autoheader:262 \
+ automake:110 \
+ autoconf:262
+AUTOMAKE_ARGS= --add-missing --copy
+
+USE_DOS2UNIX= missing depcomp
+
+SUB_FILES= pkg-message
+PLIST_FILES= bin/d2x-xl
+
+OPTIONS= OPENGL "Use OpenGL for 3D graphics" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_OPENGL)
+USE_GL= gl glu glut
+CONFIGURE_ARGS+=--with-opengl
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && \
+ unrar x ${DISTDIR}/${DISTFILES} >/dev/null && \
+ unrar x ${PORTNAME}-makefiles.rar >/dev/null && \
+ ${CHMOD} +x configure
+
+post-patch:
+ @${REINPLACE_CMD} -e '/FLAGS/ s|-O3||; /FLAGS/ s|-g||' \
+ ${WRKSRC}/configure.ac
+ @cd ${WRKSRC} && \
+ ${FIND} . -name "*.cpp" -o -name "*.h" | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|'
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/d2x-xl ${PREFIX}/bin/d2x-xl
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/games/d2x-xl/distinfo b/games/d2x-xl/distinfo
new file mode 100644
index 000000000000..662b3f68ddab
--- /dev/null
+++ b/games/d2x-xl/distinfo
@@ -0,0 +1,3 @@
+MD5 (d2x-xl-src-1.13.127.rar) = 050a60816b90e5f6e1e6b2c729d3ea22
+SHA256 (d2x-xl-src-1.13.127.rar) = a9d856c08b3617412393c80fcdf4a80dd565b2ed8dd375d5f6cedf692288d599
+SIZE (d2x-xl-src-1.13.127.rar) = 1406776
diff --git a/games/d2x-xl/files/patch-include-ogl_defs.h b/games/d2x-xl/files/patch-include-ogl_defs.h
new file mode 100644
index 000000000000..8c688356467b
--- /dev/null
+++ b/games/d2x-xl/files/patch-include-ogl_defs.h
@@ -0,0 +1,11 @@
+--- include/ogl_defs.h.orig 2008-10-09 09:34:21.000000000 +0400
++++ include/ogl_defs.h 2009-02-26 23:25:34.000000000 +0300
+@@ -220,7 +220,7 @@
+
+ #else //GL_VERSION_20
+
+-# ifdef __macosx__
++# if defined(__macosx__) || defined(__FreeBSD__)
+ # define glCreateShaderObject glCreateShaderObjectARB
+ # define glShaderSource glShaderSourceARB
+ # define glCompileShader glCompileShaderARB
diff --git a/games/d2x-xl/files/pkg-message.in b/games/d2x-xl/files/pkg-message.in
new file mode 100644
index 000000000000..29b6a33f4587
--- /dev/null
+++ b/games/d2x-xl/files/pkg-message.in
@@ -0,0 +1,8 @@
+************************************************************
+You need to get data files from an original Descent 2 or 1
+CD or from the free demo and place them in:
+
+ /usr/local/share/d2x-xl/data
+
+See http://www.descent2.de/ for more information and addons.
+************************************************************
diff --git a/games/d2x-xl/pkg-descr b/games/d2x-xl/pkg-descr
new file mode 100644
index 000000000000..24efcc367398
--- /dev/null
+++ b/games/d2x-xl/pkg-descr
@@ -0,0 +1,9 @@
+D2X-XL is a community modified version of Icculus's D2X port,
+the original Unix port of Descent by Parallax software. It
+contains many bug fixes and improvements since Icculus stopped
+working on D2X.
+
+You need to own the orignal game or download demo data
+files.
+
+WWW: http://www.descent2.de/