aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-05-23 02:30:55 +0800
committernemysis <nemysis@FreeBSD.org>2014-05-23 02:30:55 +0800
commit9fb409ce0e0dc4d8d297977b25e776cd2e7d80eb (patch)
tree67455095e4d4a1a67b46ffae498808067e269e08 /games
parentd7eaab8515b4d49c8fab04e868620e3fe707772e (diff)
downloadfreebsd-ports-gnome-9fb409ce0e0dc4d8d297977b25e776cd2e7d80eb.tar.gz
freebsd-ports-gnome-9fb409ce0e0dc4d8d297977b25e776cd2e7d80eb.tar.zst
freebsd-ports-gnome-9fb409ce0e0dc4d8d297977b25e776cd2e7d80eb.zip
- Update to 2.12, Announce message:
Add desktop file and a minor cleanup patch. - Remove Desktop entry file, use supplied desktop files - Remove obsolete patch
Diffstat (limited to 'games')
-rw-r--r--games/bluemoon/Makefile8
-rw-r--r--games/bluemoon/distinfo4
-rw-r--r--games/bluemoon/files/bluemoon.desktop10
-rw-r--r--games/bluemoon/files/patch-bluemoon.c11
4 files changed, 5 insertions, 28 deletions
diff --git a/games/bluemoon/Makefile b/games/bluemoon/Makefile
index dbb2d4e20be8..1a350af3fef1 100644
--- a/games/bluemoon/Makefile
+++ b/games/bluemoon/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= bluemoon
-PORTVERSION= 2.11
-PORTREVISION= 1
+PORTVERSION= 2.12
CATEGORIES= games
MASTER_SITES= http://www.catb.org/~esr/bluemoon/
@@ -21,7 +20,6 @@ PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
PORTDOCS= NEWS README
-
OPTIONS_DEFINE= DOCS
post-patch:
@@ -30,9 +28,9 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps
+ ${STAGEDIR}${PREFIX}/share/pixmaps
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/bluemoon/distinfo b/games/bluemoon/distinfo
index 0f09d1690093..3bf5a98a79df 100644
--- a/games/bluemoon/distinfo
+++ b/games/bluemoon/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bluemoon-2.11.tar.gz) = 19ce5b5f0220bd9906b6da0a25b8a61b7e2037283a0ed9804b45ed700fa55a14
-SIZE (bluemoon-2.11.tar.gz) = 12308
+SHA256 (bluemoon-2.12.tar.gz) = 52aec7ba74d0e811f46de44c30252877b612d780bc531e872357375b54083006
+SIZE (bluemoon-2.12.tar.gz) = 12586
diff --git a/games/bluemoon/files/bluemoon.desktop b/games/bluemoon/files/bluemoon.desktop
deleted file mode 100644
index 3255a767ec6b..000000000000
--- a/games/bluemoon/files/bluemoon.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Version=1.0
-Name=Blue Moon
-GenericName=Blue Moon game
-Comment=Blue Moon card solitaire
-Icon=bluemoon
-Exec=bluemoon
-Categories=Game;CardGame;
-Terminal=true
diff --git a/games/bluemoon/files/patch-bluemoon.c b/games/bluemoon/files/patch-bluemoon.c
deleted file mode 100644
index c83bd9a58e2f..000000000000
--- a/games/bluemoon/files/patch-bluemoon.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./bluemoon.c.orig 2010-10-19 07:59:18.000000000 +0200
-+++ ./bluemoon.c 2013-12-21 14:10:23.000000000 +0100
-@@ -376,7 +376,7 @@
- refresh();
- }
-
--main(int argc, char *argv[])
-+int main(int argc, char *argv[])
- {
- (void) signal(SIGINT, die);
- initscr();