aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-10-08 07:40:23 +0800
committermarino <marino@FreeBSD.org>2013-10-08 07:40:23 +0800
commita2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5 (patch)
treee61a78f0169c5b6d3db742a3a79532ae3afa9fab /games
parent75f2f17686803372411d7a488c3afc47442146cf (diff)
downloadfreebsd-ports-gnome-a2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5.tar.gz
freebsd-ports-gnome-a2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5.tar.zst
freebsd-ports-gnome-a2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5.zip
Explicitly link libraries on 10 unmaintained ports
The following ports will not build with a binutils 2.22+ linker built with standard options. This has been obvious with DPorts, but difficult to see on FreeBSD. However, setting the ports compiler as a recent gcc (e.g lang/gcc48) is an excellent way to detect the unspecified but needed libraries as these recent GCC compilers use the latest binutils linkers. These patches were tested on FreeBSD 8.4 and DragonFly 3.5
Diffstat (limited to 'games')
-rw-r--r--games/stepmania-devel/Makefile2
-rw-r--r--games/xteddy/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index d0a78bb029fd..1eecb806b29d 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -38,7 +38,7 @@ SHEBANG_FILES= Utils/*.pl \
extern/zlib/zlib2ansi
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lX11 -lpthread
NO_STAGE= yes
.include <bsd.port.options.mk>
diff --git a/games/xteddy/Makefile b/games/xteddy/Makefile
index 5f29af21e9ee..0b311676c606 100644
--- a/games/xteddy/Makefile
+++ b/games/xteddy/Makefile
@@ -16,7 +16,7 @@ USE_EFL= imlib2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib lXext
MAN6= xteddy.6
PLIST_FILES= bin/xteddy bin/xteddy_test bin/xtoys \