aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-12-05 06:42:38 +0800
committerpawel <pawel@FreeBSD.org>2012-12-05 06:42:38 +0800
commitad6d631ffed59712161300a4f0a85161e8b43492 (patch)
treec68032df08459ab635488adbdc886444a68f4699 /games
parent5e814e3c45872926a6c2a12debefada1d9f18cff (diff)
downloadfreebsd-ports-gnome-ad6d631ffed59712161300a4f0a85161e8b43492.tar.gz
freebsd-ports-gnome-ad6d631ffed59712161300a4f0a85161e8b43492.tar.zst
freebsd-ports-gnome-ad6d631ffed59712161300a4f0a85161e8b43492.zip
Tetris meets Pong, with more twists than a contortionist club's
secret handshake. Sometimes, the total is greater than the sum of the parts. Tetris and Pong are classics, addictive and unshakable from their places in gaming history. TONG is the result of mixing the two, capitalizing on the essential qualities of each classic and adding new twists of its own to make an explosive chemical reaction out of it all. WWW: http://www.nongnu.org/tong/ PR: ports/173878 Submitted by: nemysis@gmx.ch Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/tong/Makefile44
-rw-r--r--games/tong/distinfo2
-rw-r--r--games/tong/files/patch-tong.cpp24
-rw-r--r--games/tong/pkg-descr8
-rw-r--r--games/tong/pkg-plist93
6 files changed, 172 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 4270a7f0bd5c..b557659fc13f 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -905,6 +905,7 @@
SUBDIR += tksol
SUBDIR += tmw
SUBDIR += tomatoes
+ SUBDIR += tong
SUBDIR += toppler
SUBDIR += torcs
SUBDIR += tornado
diff --git a/games/tong/Makefile b/games/tong/Makefile
new file mode 100644
index 000000000000..333bfcdd2c37
--- /dev/null
+++ b/games/tong/Makefile
@@ -0,0 +1,44 @@
+# Created by: nemysis@gmx.ch
+# $FreeBSD$
+
+PORTNAME= tong
+PORTVERSION= 1.2
+CATEGORIES= games
+MASTER_SITES= http://www.nongnu.org/tong/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Tetris and Pong in the same place at the same time
+
+LICENSE= GPLv3
+
+USE_SDL= image mixer sdl
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= CHANGELOG README making-of.txt notes.txt
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+DESKTOP_ENTRIES="TONG!" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|GAME_DATA_DIR := .|GAME_DATA_DIR := ${DATADIR}|' \
+ -e 's|CC = g++ -O3 |CC = ${CXX} ${CXXFLAGS} |' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "*.png" ${DATADIR}
+ ${MKDIR} ${DATADIR}/media
+ @cd ${WRKSRC}/media && ${COPYTREE_SHARE} "*.png *.xcf *.ogg *.ico" ${DATADIR}/media
+ ${LN} -sf ${DATADIR}/media/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/tong/distinfo b/games/tong/distinfo
new file mode 100644
index 000000000000..3bbe43d0c25d
--- /dev/null
+++ b/games/tong/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tong-1.2.tar.gz) = 7514bf0c1c1a9a8d6985d0fbe83486b83f665d9a202beed2ae91e3f45e90942b
+SIZE (tong-1.2.tar.gz) = 88028070
diff --git a/games/tong/files/patch-tong.cpp b/games/tong/files/patch-tong.cpp
new file mode 100644
index 000000000000..004e92d6d7ba
--- /dev/null
+++ b/games/tong/files/patch-tong.cpp
@@ -0,0 +1,24 @@
+--- tong.cpp.orig 2012-10-31 18:18:19.000000000 +0100
++++ tong.cpp 2012-11-15 13:27:09.000000000 +0100
+@@ -63,6 +63,7 @@
+ #define SCREEN_CREDITS 8
+
+ #define DEMO_TIME 8000
++#define MIN_TIME 45
+
+ #define GP2X_BUTTON_UP 0
+ #define GP2X_BUTTON_UPLEFT 1
+@@ -1854,6 +1855,13 @@
+ SDL_Flip(screen);
+ lastlastupdate=lastupdate;
+ lastupdate=SDL_GetTicks();
++
++ // limit to 1000/MIN_TIME fps
++ if (lastupdate-lastlastupdate < MIN_TIME) {
++ SDL_Delay(MIN_TIME - (lastupdate - lastlastupdate));
++ }
++ lastupdate = SDL_GetTicks();
++
+ } //main game loop
+
+ Mix_FreeMusic(music);
diff --git a/games/tong/pkg-descr b/games/tong/pkg-descr
new file mode 100644
index 000000000000..0310bfd8e89c
--- /dev/null
+++ b/games/tong/pkg-descr
@@ -0,0 +1,8 @@
+Tetris meets Pong, with more twists than a contortionist club's
+secret handshake. Sometimes, the total is greater than the sum of the parts.
+Tetris and Pong are classics, addictive and unshakable from their places in
+gaming history. TONG is the result of mixing the two, capitalizing on the
+essential qualities of each classic and adding new twists of its own to make
+an explosive chemical reaction out of it all.
+
+WWW: http://www.nongnu.org/tong/
diff --git a/games/tong/pkg-plist b/games/tong/pkg-plist
new file mode 100644
index 000000000000..18c1df882b76
--- /dev/null
+++ b/games/tong/pkg-plist
@@ -0,0 +1,93 @@
+bin/tong
+share/pixmaps/tong.png
+%%DATADIR%%/background.png
+%%DATADIR%%/darkblot.png
+%%DATADIR%%/media/background-8bit.png
+%%DATADIR%%/media/background-clean.png
+%%DATADIR%%/media/background-new.png
+%%DATADIR%%/media/background-new.xcf
+%%DATADIR%%/media/background-old.png
+%%DATADIR%%/media/background-shiny.png
+%%DATADIR%%/media/background-space.png
+%%DATADIR%%/media/background-test.xcf
+%%DATADIR%%/media/background-xmas.png
+%%DATADIR%%/media/background.png
+%%DATADIR%%/media/ball-bounce.png
+%%DATADIR%%/media/ball-die.png
+%%DATADIR%%/media/ball-ignore.png
+%%DATADIR%%/media/ball-join.png
+%%DATADIR%%/media/behind.png
+%%DATADIR%%/media/beyond2000.ogg
+%%DATADIR%%/media/black.png
+%%DATADIR%%/media/bounce1.ogg
+%%DATADIR%%/media/bounce2.ogg
+%%DATADIR%%/media/controls.png
+%%DATADIR%%/media/donkeyrhubarb.ogg
+%%DATADIR%%/media/fanfare.ogg
+%%DATADIR%%/media/flock.ogg
+%%DATADIR%%/media/gameover.png
+%%DATADIR%%/media/gittegitte.ogg
+%%DATADIR%%/media/i12bpvd.ogg
+%%DATADIR%%/media/icon.png
+%%DATADIR%%/media/newrule.ogg
+%%DATADIR%%/media/next.png
+%%DATADIR%%/media/one-liner.ogg
+%%DATADIR%%/media/oneliner.ogg
+%%DATADIR%%/media/penduincode.png
+%%DATADIR%%/media/penduincode.xcf
+%%DATADIR%%/media/pieces-8bit.png
+%%DATADIR%%/media/pieces-clean.png
+%%DATADIR%%/media/pieces-default.png
+%%DATADIR%%/media/pieces-shiny.png
+%%DATADIR%%/media/pieces-space.png
+%%DATADIR%%/media/pieces-xmas.png
+%%DATADIR%%/media/pieces.png
+%%DATADIR%%/media/playzone-8bit.png
+%%DATADIR%%/media/playzone-clean.png
+%%DATADIR%%/media/playzone-shiny.png
+%%DATADIR%%/media/playzone-space.png
+%%DATADIR%%/media/playzone-xmas.png
+%%DATADIR%%/media/playzone.png
+%%DATADIR%%/media/plop1.ogg
+%%DATADIR%%/media/reach_reach.ogg
+%%DATADIR%%/media/reachreach.ogg
+%%DATADIR%%/media/ruleblot.png
+%%DATADIR%%/media/rulespark.png
+%%DATADIR%%/media/score.png
+%%DATADIR%%/media/squeekers.ogg
+%%DATADIR%%/media/squib.ogg
+%%DATADIR%%/media/stack-break.png
+%%DATADIR%%/media/stack-die.png
+%%DATADIR%%/media/stack-ignore.png
+%%DATADIR%%/media/stack-join.png
+%%DATADIR%%/media/stack-linebreak.png
+%%DATADIR%%/media/stuck-in-a-mailbox.ogg
+%%DATADIR%%/media/swish1.ogg
+%%DATADIR%%/media/swish2.ogg
+%%DATADIR%%/media/tetrad-break.png
+%%DATADIR%%/media/tetrad-die.png
+%%DATADIR%%/media/tetrad-drop.png
+%%DATADIR%%/media/tetrad-ignore.png
+%%DATADIR%%/media/tetrad-join.png
+%%DATADIR%%/media/tetrad-move.png
+%%DATADIR%%/media/tetrad-rotate.png
+%%DATADIR%%/media/text.png
+%%DATADIR%%/media/textbox.png
+%%DATADIR%%/media/the-diplomat.ogg
+%%DATADIR%%/media/tick.ogg
+%%DATADIR%%/media/time.png
+%%DATADIR%%/media/timeup.png
+%%DATADIR%%/media/toing.ogg
+%%DATADIR%%/media/tong.ico
+%%DATADIR%%/media/tong.ogg
+%%DATADIR%%/media/tong.png
+%%DATADIR%%/media/twobits.ogg
+%%DATADIR%%/media/wee1.ogg
+%%DATADIR%%/media/wtfgames.png
+%%DATADIR%%/media/youlose.png
+%%DATADIR%%/pieces.png
+%%DATADIR%%/play.png
+%%DATADIR%%/pongbits.png
+%%DATADIR%%/tetrisbits.png
+@dirrm %%DATADIR%%/media
+@dirrm %%DATADIR%%