aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-03-16 20:58:16 +0800
committerjbeich <jbeich@FreeBSD.org>2016-03-16 20:58:16 +0800
commitb36023e07460f760eb9afa1b4c73d043374a7968 (patch)
treecd771deb19a99a0daf138afa2b966f56b7d36b63 /games
parent58122f740c9d77b55ddf1a61f7e62eb310013e80 (diff)
downloadfreebsd-ports-gnome-b36023e07460f760eb9afa1b4c73d043374a7968.tar.gz
freebsd-ports-gnome-b36023e07460f760eb9afa1b4c73d043374a7968.tar.zst
freebsd-ports-gnome-b36023e07460f760eb9afa1b4c73d043374a7968.zip
Drop default directory from _DEPENDS in my ports
https://lists.freebsd.org/pipermail/freebsd-ports/2015-October/100794.html
Diffstat (limited to 'games')
-rw-r--r--games/aquaria/Makefile10
-rw-r--r--games/katawa-shoujo/Makefile2
-rw-r--r--games/narcissu2/Makefile2
-rw-r--r--games/openbor/Makefile12
-rw-r--r--games/openra/Makefile10
5 files changed, 18 insertions, 18 deletions
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index d55679b1c064..5daaed23972a 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -11,11 +11,11 @@ COMMENT= Underwater 2D fantasy action-adventure (game engine)
LICENSE= GPLv2+
-BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
-LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
- libftgl.so:${PORTSDIR}/graphics/ftgl \
- libpng.so:${PORTSDIR}/graphics/png \
- libtinyxml2.so:${PORTSDIR}/textproc/tinyxml2
+BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm
+LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
+ libftgl.so:graphics/ftgl \
+ libpng.so:graphics/png \
+ libtinyxml2.so:textproc/tinyxml2
USE_GITHUB= yes
GH_ACCOUNT= AquariaOSE
diff --git a/games/katawa-shoujo/Makefile b/games/katawa-shoujo/Makefile
index 265b9cbb28fc..7f0d24664bda 100644
--- a/games/katawa-shoujo/Makefile
+++ b/games/katawa-shoujo/Makefile
@@ -22,7 +22,7 @@ LICENSE_NAME= Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported
LICENSE_TEXT= See https://creativecommons.org/licenses/by-nc-nd/3.0/
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-RUN_DEPENDS= renpy:${PORTSDIR}/devel/renpy
+RUN_DEPENDS= renpy:devel/renpy
USES= tar:bz2
NO_ARCH= yes
diff --git a/games/narcissu2/Makefile b/games/narcissu2/Makefile
index e79e96a21f90..8e018ebf2d0a 100644
--- a/games/narcissu2/Makefile
+++ b/games/narcissu2/Makefile
@@ -22,7 +22,7 @@ LICENSE_TEXT= Permission has been granted to anyone to redistribute \
game data are not modified.
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-RUN_DEPENDS= ponscr:${PORTSDIR}/devel/ponscripter-sekai
+RUN_DEPENDS= ponscr:devel/ponscripter-sekai
NO_ARCH= yes
NO_BUILD= yes
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 39eb29300b23..ad25f2e31226 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -11,8 +11,8 @@ COMMENT= Moddable fighting game engine (aka Beats of Rage)
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
- libvpx.so:${PORTSDIR}/multimedia/libvpx
+LIB_DEPENDS= libpng.so:graphics/png \
+ libvpx.so:multimedia/libvpx
USES= dos2unix gmake pkgconfig tar:xz
USE_SDL= gfx2
@@ -39,12 +39,12 @@ OPTIONS_DEFAULT= ${MACHINE_CPU:tu:MSOFTFP:S/SOFTFP/TREMOR/}
OPTIONS_DEFINE_i386= MMX
OPTIONS_DEFAULT_i386= MMX # runtime detection
-MMX_BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
+MMX_BUILD_DEPENDS= yasm:devel/yasm
MMX_MAKE_ARGS= BUILD_MMX=1
-TREMOR_LIB_DEPENDS= libvorbisidec.so:${PORTSDIR}/audio/libtremor
+TREMOR_LIB_DEPENDS= libvorbisidec.so:audio/libtremor
TREMOR_MAKE_ARGS= BUILD_TREMOR=1 BUILD_VORBIS=""
-TREMOR_LIB_DEPENDS_OFF= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
+TREMOR_LIB_DEPENDS_OFF= libvorbisfile.so:audio/libvorbis
#
# To update snapshot: make makesum BOOTSTRAP=
@@ -62,7 +62,7 @@ SVN_REV?= ${PORTVERSION:E:S/r//}
.endif
.if defined(BOOTSTRAP) || defined(SVN_FETCH)
-FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+FETCH_DEPENDS+= svn:devel/subversion
do-fetch:
${MKDIR} ${WRKDIR}
diff --git a/games/openra/Makefile b/games/openra/Makefile
index c75d63d75048..8f1755fbedbe 100644
--- a/games/openra/Makefile
+++ b/games/openra/Makefile
@@ -44,8 +44,8 @@ COMMENT= Multiplayer re-envisioning of early RTS games by Westwood Studios
LICENSE= GPLv3
-LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libgdiplus.so:${PORTSDIR}/x11-toolkits/libgdiplus
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libgdiplus.so:x11-toolkits/libgdiplus
USE_GITHUB= yes
GH_PROJECT= OpenRA
@@ -66,14 +66,14 @@ PORTDOCS= *.html
OPTIONS_DEFINE= DOCS TEST ZENITY
OPTIONS_DEFAULT=ZENITY
-DOCS_BUILD_DEPENDS=markdown:${PORTSDIR}/textproc/markdown
+DOCS_BUILD_DEPENDS=markdown:textproc/markdown
DOCS_ALL_TARGET=docs
TEST_MAKE_ENV= HOME="${WRKDIR}"
TEST_ALL_TARGET=test
-ZENITY_RUN_DEPENDS=xdg-open:${PORTSDIR}/devel/xdg-utils \
- zenity:${PORTSDIR}/x11/zenity
+ZENITY_RUN_DEPENDS=xdg-open:devel/xdg-utils \
+ zenity:x11/zenity
ZENITY_DESC= Use native crash dialog
post-extract: