aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-18 16:14:23 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-18 16:14:23 +0800
commitb4f847b333aee56d4c19deeb8cc966fff73abd53 (patch)
tree985075045a3e320b7edb1a42256318fd6f5f3038 /games
parent9b4b8f5dd119fd815d042cd6c5796894d89bfc48 (diff)
downloadfreebsd-ports-gnome-b4f847b333aee56d4c19deeb8cc966fff73abd53.tar.gz
freebsd-ports-gnome-b4f847b333aee56d4c19deeb8cc966fff73abd53.tar.zst
freebsd-ports-gnome-b4f847b333aee56d4c19deeb8cc966fff73abd53.zip
More precisely specify USES=compiler to fix build on gcc-based
platforms such as powerpc64. Tested on powerpc64, amd64. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'games')
-rw-r--r--games/atanks/Makefile2
-rw-r--r--games/super_methane_brothers/Makefile2
-rw-r--r--games/taisei/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/games/atanks/Makefile b/games/atanks/Makefile
index 63c0f3e8cd19..2f56fbdbbd3c 100644
--- a/games/atanks/Makefile
+++ b/games/atanks/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= liballeg.so:devel/allegro
-USES= gmake
+USES= compiler:c++0x gmake
PORTDOCS= Changelog README README_ru.txt credits.txt
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index dee96306db8d..303f7a7e6972 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libclan23Core.so:devel/clanlib
-USES= gmake localbase pkgconfig tar:tgz
+USES= compiler:c++0x gmake localbase pkgconfig tar:tgz
MAKE_ENV= METHANE_FLAGS="${CPPFLAGS}" METHANE_LIBS="${LIBS}"
MAKE_JOBS_UNSAFE= yes
diff --git a/games/taisei/Makefile b/games/taisei/Makefile
index 3652e915fbda..5ad005df98f4 100644
--- a/games/taisei/Makefile
+++ b/games/taisei/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}-project
-USES= cmake pkgconfig
+USES= cmake compiler:c11 pkgconfig
CMAKE_ARGS= -DTAISEI_VERSION_OVERRIDE=${PORTVERSION}
USE_SDL= sdl2 ttf2 mixer2