aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-05-31 04:39:12 +0800
committerbapt <bapt@FreeBSD.org>2015-05-31 04:39:12 +0800
commitb59b6099b4d24dea62584334abcd9af40a23478c (patch)
treec6487f309b5d29e868c4ea46df98e320c50df957 /games
parent879b5d290b19b7c2735c5fabfe2901e1d2b76a4a (diff)
downloadfreebsd-ports-gnome-b59b6099b4d24dea62584334abcd9af40a23478c.tar.gz
freebsd-ports-gnome-b59b6099b4d24dea62584334abcd9af40a23478c.tar.zst
freebsd-ports-gnome-b59b6099b4d24dea62584334abcd9af40a23478c.zip
Update portaudio to v19/Remove portaudio2 [1]
Chase portaudio change Add patches from debian for games/cultivation Add patches from upsteam for audio/rezound Mark py-fastaudio as broken Approved by: maintainer
Diffstat (limited to 'games')
-rw-r--r--games/crrcsim/Makefile8
-rw-r--r--games/cultivation/Makefile6
-rw-r--r--games/cultivation/files/patch-gameSource_sound_SoundEffectsBank.cpp10
-rw-r--r--games/cultivation/files/patch-gameSource_sound_SoundPlayer.h13
-rw-r--r--games/cultivation/files/portaudio19.patch78
-rw-r--r--games/glob2/Makefile14
6 files changed, 112 insertions, 17 deletions
diff --git a/games/crrcsim/Makefile b/games/crrcsim/Makefile
index 135212451bcc..1177eea68bd0 100644
--- a/games/crrcsim/Makefile
+++ b/games/crrcsim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= crrcsim
PORTVERSION= 0.9.11
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= BERLIOS
@@ -11,7 +11,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Model-airplane flight simulation program
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
-LIB_DEPENDS= libportaudio.so.2:${PORTSDIR}/audio/portaudio2 \
+LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio \
libjpeg.so:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
@@ -19,8 +19,8 @@ USES= gmake
USE_SDL= sdl
USE_GL= gl glu
-CPPFLAGS+= -I${LOCALBASE}/include/portaudio2 -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib/portaudio2 -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
PORTDOCS= *
diff --git a/games/cultivation/Makefile b/games/cultivation/Makefile
index 6fefc8e59d81..a26acf31a372 100644
--- a/games/cultivation/Makefile
+++ b/games/cultivation/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cultivation
PORTVERSION= 8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/v${PORTVERSION}
DISTNAME= Cultivation_${PORTVERSION}_UnixSource
@@ -11,7 +11,7 @@ DISTNAME= Cultivation_${PORTVERSION}_UnixSource
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Unique game of conflict and cooperation in a gardening community
-LIB_DEPENDS= libportaudio.so.0:${PORTSDIR}/audio/portaudio
+LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio
USES= gmake
USE_XORG= x11 xi xext xmu
@@ -21,6 +21,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/game2
BUILD_WRKSRC= ${WRKSRC}/gameSource
MAKE_ARGS= CXX=${CXX}
+EXTRA_PATCHES= ${FILESDIR}/portaudio19.patch:-p2
+
PLIST_FILES= bin/Cultivation
PORTDATA= *
PORTDOCS= changeLog.txt how_to_play.txt
diff --git a/games/cultivation/files/patch-gameSource_sound_SoundEffectsBank.cpp b/games/cultivation/files/patch-gameSource_sound_SoundEffectsBank.cpp
new file mode 100644
index 000000000000..b43b590b1ff8
--- /dev/null
+++ b/games/cultivation/files/patch-gameSource_sound_SoundEffectsBank.cpp
@@ -0,0 +1,10 @@
+--- gameSource/sound/SoundEffectsBank.cpp.orig 2007-08-09 15:45:15 UTC
++++ gameSource/sound/SoundEffectsBank.cpp
+@@ -10,6 +10,7 @@
+
+ #include "minorGems/util/random/StdRandomSource.h"
+
++#include <math.h>
+
+ extern int globalSoundSampleRate;
+
diff --git a/games/cultivation/files/patch-gameSource_sound_SoundPlayer.h b/games/cultivation/files/patch-gameSource_sound_SoundPlayer.h
new file mode 100644
index 000000000000..1ffd5d98428f
--- /dev/null
+++ b/games/cultivation/files/patch-gameSource_sound_SoundPlayer.h
@@ -0,0 +1,13 @@
+--- gameSource/sound/SoundPlayer.h.orig 2015-05-30 19:01:03 UTC
++++ gameSource/sound/SoundPlayer.h
+@@ -52,9 +52,7 @@
+ #include "SoundFilter.h"
+ #include "PlayableSound.h"
+
+-#include "minorGems/sound/portaudio/pa_common/portaudio.h"
+-#include "minorGems/sound/portaudio/pablio/pablio.h"
+-
++#include <portaudio.h>
+
+ #include "minorGems/util/SimpleVector.h"
+
diff --git a/games/cultivation/files/portaudio19.patch b/games/cultivation/files/portaudio19.patch
new file mode 100644
index 000000000000..4cac2eb4de8e
--- /dev/null
+++ b/games/cultivation/files/portaudio19.patch
@@ -0,0 +1,78 @@
+Author: Barry deFreese <bdefreese@debian.org>
+Description: Patch system to utilize portaudio v19
+Bug-Debian: http://bugs.debian.org/594015
+Last-Update: 2013-06-01
+--- a/game2/gameSource/sound/SoundPlayer.h
++++ b/game2/gameSource/sound/SoundPlayer.h
+@@ -239,7 +239,7 @@
+ char mFadingIn;
+ int mNumFadeFramesRemaining;
+
+- PortAudioStream *mAudioStream;
++ PaStream *mAudioStream;
+
+ // realtime sounds that should be mixed into the next to-speaker call
+ SimpleVector<PlayableSound *> *mRealtimeSounds;
+--- a/game2/gameSource/sound/SoundPlayer.cpp
++++ b/game2/gameSource/sound/SoundPlayer.cpp
+@@ -52,9 +52,11 @@
+
+
+ // callback passed into portaudio
+-static int portaudioCallback( void *inputBuffer, void *outputBuffer,
++int portaudioCallback( const void *inputBuffer, void *outputBuffer,
+ unsigned long framesPerBuffer,
+- PaTimestamp outTime, void *userData ) {
++ const PaStreamCallbackTimeInfo *outTime,
++ PaStreamCallbackFlags statusFlags,
++ void *userData ) {
+
+
+ SoundPlayer *player = (SoundPlayer *)userData;
+@@ -157,21 +159,13 @@
+
+ if( error == paNoError ) {
+
+- error = Pa_OpenStream(
++ error = Pa_OpenDefaultStream(
+ &mAudioStream,
+- paNoDevice,// default input device
+ 0, // no input
+- paFloat32, // 32 bit floating point input
+- NULL,
+- Pa_GetDefaultOutputDeviceID(),
+ 2, // stereo output
+ paFloat32, // 32 bit floating point output
+- NULL,
+ mSampleRate,
+ 1024, // frames per buffer
+- 0, // number of buffers, if zero then use default minimum
+- paClipOff, // we won't output out of range samples so
+- // don't bother clipping them
+ portaudioCallback,
+ (void *)this ); // pass self-pointer to callback function
+
+--- a/game2/gameSource/sound/MusicPlayer.cpp
++++ b/game2/gameSource/sound/MusicPlayer.cpp
+@@ -112,13 +112,14 @@
+
+ // get parts and positions of gardeners
+ int numParts = 0;
+- Vector3D **positions =
+- globalWorld->getAllGardenerPositions( &numParts );
+- MusicPart **musicParts =
+- globalWorld->getAllGardenerMusicParts( &numParts );
+- double *volumeModifiers =
+- globalWorld->getAllGardenerMusicVolumeModifiers( &numParts );
+-
++ Vector3D **positions = NULL;
++ MusicPart **musicParts = NULL;
++ double *volumeModifiers = NULL;
++ if ( globalWorld ){
++ positions = globalWorld->getAllGardenerPositions( &numParts );
++ musicParts = globalWorld->getAllGardenerMusicParts( &numParts );
++ volumeModifiers = globalWorld->getAllGardenerMusicVolumeModifiers( &numParts );
++ }
+
+ // get center position from current player position
+ Vector3D *centerPosition = new Vector3D( &globalPlayerCurrentPosition );
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index 2854e0e71a6e..0e75c70a4552 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -26,15 +26,13 @@ USE_SDL= image net sdl ttf
USE_GL= gl glu
MAKE_ARGS= CCFLAGS="${CFLAGS}" \
LINKFLAGS="${LDFLAGS}" \
- LIBPATH="${LIBPATH}" \
BINDIR="${STAGEDIR}${PREFIX}/bin" \
INSTALLDIR="${STAGEDIR}${PREFIX}/share" \
DATADIR="${DATADIR}"
INSTALLS_ICONS= yes
-CFLAGS+= ${PA2_CFLAGS} -I${LOCALBASE}/include -Wno-return-type
-LDFLAGS+= -lpthread ${PA2_LDFLAGS} -L${LOCALBASE}/lib
-LIBPATH= ${LIBPATH2}${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include -Wno-return-type
+LDFLAGS+= -lpthread -L${LOCALBASE}/lib
PORTDOCS= README
SUB_FILES= pkg-message
@@ -42,10 +40,7 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPORTAUDIO}
-LIB_DEPENDS+= libportaudio.so.2:${PORTSDIR}/audio/portaudio2
-PA2_CFLAGS+= -I${LOCALBASE}/include/portaudio2
-PA2_LDFLAGS+= -L${LOCALBASE}/lib/portaudio2
-LIBPATH2= ${LOCALBASE}/lib/portaudio2:
+LIB_DEPENDS+= libportaudio.so:${PORTSDIR}/audio/portaudio
MAKE_ARGS+= --portaudio=true
.else
MAKE_ARGS+= --portaudio=false
@@ -56,9 +51,6 @@ pre-configure:
's|"-g"|""|' \
${WRKSRC}/SConstruct
${REINPLACE_CMD} -e \
- 's|portaudio.h|portaudio2/portaudio.h|' \
- ${WRKSRC}/src/VoiceRecorder.cpp
- ${REINPLACE_CMD} -e \
'/^Icon/s|=.*|=${PORTNAME}|' \
${WRKSRC}/data/${PORTNAME}.desktop
${REINPLACE_CMD} -e \