aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-07-26 00:10:59 +0800
committerjylefort <jylefort@FreeBSD.org>2005-07-26 00:10:59 +0800
commitbb5243c6a7ae81d4c53f754a3ea626cdedfae745 (patch)
treea0e9b9f54bfc8bbd1c65afecff300d0eb891bf03 /games
parente5091c86fa164e6832e6ae83d12c8c89b471d710 (diff)
downloadfreebsd-ports-gnome-bb5243c6a7ae81d4c53f754a3ea626cdedfae745.tar.gz
freebsd-ports-gnome-bb5243c6a7ae81d4c53f754a3ea626cdedfae745.tar.zst
freebsd-ports-gnome-bb5243c6a7ae81d4c53f754a3ea626cdedfae745.zip
Add alienwave.
A shoot'em up game written using ncurses where you control a spaceship and must kill as many alien spaceships as you can. WWW: http://www.cs.unibo.it/~pira/alienwave/aw.html PR: ports/83967 Submitted by: Travis Poppe <tlp@liquidx.org>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/alienwave/Makefile58
-rw-r--r--games/alienwave/distinfo2
-rw-r--r--games/alienwave/pkg-descr7
4 files changed, 68 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index beb461d24570..413d422499cd 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -28,6 +28,7 @@
SUBDIR += alephone
SUBDIR += alephone-data
SUBDIR += alienblaster
+ SUBDIR += alienwave
SUBDIR += amphetamine
SUBDIR += amy
SUBDIR += an
diff --git a/games/alienwave/Makefile b/games/alienwave/Makefile
new file mode 100644
index 000000000000..9f18bbb77644
--- /dev/null
+++ b/games/alienwave/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: alienwave
+# Date created: 23 July 2005
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alienwave
+PORTVERSION= 0.3.0
+CATEGORIES= games
+MASTER_SITES= http://www.cs.unibo.it/~pira/alienwave/
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= Shoot'em up game written using ncurses
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= ${PORTNAME}
+
+MAKE_ARGS= CC="${CC}" CFLAGS="-c ${CFLAGS}"
+
+PLIST_FILES= bin/alienwave
+PORTDOCS= README STORY TO_DO
+
+OPTIONS= RANDOM_LEVELS "Enable random waves" off \
+ LEVEL_EASY "Killing Xzarna: easy (default: medium)" off \
+ LEVEL_HARD "Killing Xzarna: hard (default: medium)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LEVEL_EASY)
+CFLAGS+= -DLEV_EASY
+.endif
+
+.if defined(WITH_LEVEL_HARD)
+CFLAGS+= -DLEV_HARD
+.endif
+
+.if defined(WITH_RANDOM_LEVELS)
+CFLAGS+= -DRANDOM_LEVELS
+.endif
+
+.if defined(WITH_LEVEL_EASY) && defined(WITH_LEVEL_HARD)
+pre-everything::
+ @${ECHO_CMD} "The LEVEL_EASY and LEVEL_HARD options are mutually exclusive."
+ @${ECHO_CMD} "Please run 'make config' again."
+ @${FALSE}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/alienwave ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/alienwave/distinfo b/games/alienwave/distinfo
new file mode 100644
index 000000000000..407aeca61f79
--- /dev/null
+++ b/games/alienwave/distinfo
@@ -0,0 +1,2 @@
+MD5 (alienwave-0.3.0.tar.gz) = 7d30b2aabf18e588cb8f6998e555cdc9
+SIZE (alienwave-0.3.0.tar.gz) = 22046
diff --git a/games/alienwave/pkg-descr b/games/alienwave/pkg-descr
new file mode 100644
index 000000000000..5977223c245f
--- /dev/null
+++ b/games/alienwave/pkg-descr
@@ -0,0 +1,7 @@
+A shoot'em up game written using ncurses where you control a spaceship and
+must kill as many alien spaceships as you can.
+
+WWW: http://www.cs.unibo.it/~pira/alienwave/aw.html
+
+- Travis Poppe
+tlp@liquidx.org