aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-12-25 11:03:42 +0800
committersteve <steve@FreeBSD.org>1999-12-25 11:03:42 +0800
commitc74acc225118d1b98c993452de32cd23b3e014b4 (patch)
tree0ec1457163bb63ae5fc52c907600a7fc75fde3a8 /games
parent930df2755f013e631ce05b6b6d74593f936d3017 (diff)
downloadfreebsd-ports-gnome-c74acc225118d1b98c993452de32cd23b3e014b4.tar.gz
freebsd-ports-gnome-c74acc225118d1b98c993452de32cd23b3e014b4.tar.zst
freebsd-ports-gnome-c74acc225118d1b98c993452de32cd23b3e014b4.zip
Addng cursive version 1.0.
Create ASCII character cursive handwriting. PR: 15260 Submitted by: James Howard <howardj@wam.umd.edu>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/cursive/Makefile23
-rw-r--r--games/cursive/distinfo1
-rw-r--r--games/cursive/files/patch-aa10
-rw-r--r--games/cursive/files/patch-ab11
-rw-r--r--games/cursive/files/patch-ac11
-rw-r--r--games/cursive/pkg-comment1
-rw-r--r--games/cursive/pkg-descr11
-rw-r--r--games/cursive/pkg-plist1
9 files changed, 70 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index b4eb1df52d28..14d7c416c38d 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -36,6 +36,7 @@
SUBDIR += crafty-open-rock
SUBDIR += crafty-open-small
SUBDIR += crossfire
+ SUBDIR += cursive
SUBDIR += dontspace
SUBDIR += doom
SUBDIR += dopewars
diff --git a/games/cursive/Makefile b/games/cursive/Makefile
new file mode 100644
index 000000000000..129dce83e496
--- /dev/null
+++ b/games/cursive/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: cursive
+# Version required: 1.0
+# Date created: 4 December 1999
+# Whom: James Howard <howardj@wam.umd.edu>
+#
+# $FreeBSD$
+#
+
+DISTNAME= cursive
+PKGNAME= cursive-1.0
+CATEGORIES= games
+MASTER_SITES= ftp://puck.nether.net/pub/janc/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= howardjp@wam.umd.edu
+
+MAN6= cursive.6
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cursive ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/cursive.6 ${PREFIX}/man/man6
+
+.include <bsd.port.mk>
diff --git a/games/cursive/distinfo b/games/cursive/distinfo
new file mode 100644
index 000000000000..4a600f07927a
--- /dev/null
+++ b/games/cursive/distinfo
@@ -0,0 +1 @@
+MD5 (cursive.tgz) = 6051416ca5dac79c63ba1511b915b6d2
diff --git a/games/cursive/files/patch-aa b/games/cursive/files/patch-aa
new file mode 100644
index 000000000000..3b719512d3f2
--- /dev/null
+++ b/games/cursive/files/patch-aa
@@ -0,0 +1,10 @@
+--- Makefile.orig Sat Dec 4 17:19:30 1999
++++ Makefile Sat Dec 4 17:19:40 1999
+@@ -1,5 +1,7 @@
+ CFLAGS = -g
+
++all: cursive
++
+ cursive: cursive.o x.o xs.o
+ cc -g -o cursive cursive.o x.o xs.o
+
diff --git a/games/cursive/files/patch-ab b/games/cursive/files/patch-ab
new file mode 100644
index 000000000000..8a3e553c4203
--- /dev/null
+++ b/games/cursive/files/patch-ab
@@ -0,0 +1,11 @@
+--- cursive.c.orig Sat Dec 4 17:20:55 1999
++++ cursive.c Sat Dec 4 17:21:32 1999
+@@ -128,7 +128,7 @@
+ else
+ {
+ /* Message from standard input */
+- while (gets(message) != NULL)
++ while (fgets(message, sizeof(message), stdin) != NULL)
+ prline(message);
+ }
+ }
diff --git a/games/cursive/files/patch-ac b/games/cursive/files/patch-ac
new file mode 100644
index 000000000000..fcf82cf4e2ab
--- /dev/null
+++ b/games/cursive/files/patch-ac
@@ -0,0 +1,11 @@
+--- cursive.6.orig Sat Dec 4 17:31:42 1999
++++ cursive.6 Sat Dec 4 17:32:03 1999
+@@ -3,7 +3,7 @@
+ .SH NAME
+ cursive \- print text in cursive script
+ .SH SYNOPSIS
+-.B /usr/games/cursive
++.B cursive
+ [
+ .BI \-i n
+ ]
diff --git a/games/cursive/pkg-comment b/games/cursive/pkg-comment
new file mode 100644
index 000000000000..bc564df80bab
--- /dev/null
+++ b/games/cursive/pkg-comment
@@ -0,0 +1 @@
+Create ASCII character cursive handwriting
diff --git a/games/cursive/pkg-descr b/games/cursive/pkg-descr
new file mode 100644
index 000000000000..f357d35c321f
--- /dev/null
+++ b/games/cursive/pkg-descr
@@ -0,0 +1,11 @@
+Cursive is a program for generating cursive signatures and text like
+
+ ___ _ __ _
+ ( ) ' ) / // _/_
+ __/___. ____ / / / __|/ / _ __
+ / / (_/|_/ / (_ (_(_/ (_) \_(__(/_/ (_
+ (_/
+
+Do not be fooled by inferior immitations (like the figlet font which
+doesn't connect letters right). This is the one and only original
+cursive program.
diff --git a/games/cursive/pkg-plist b/games/cursive/pkg-plist
new file mode 100644
index 000000000000..0f3ce41148e8
--- /dev/null
+++ b/games/cursive/pkg-plist
@@ -0,0 +1 @@
+bin/cursive