aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-16 22:05:28 +0800
committerkrion <krion@FreeBSD.org>2004-01-16 22:05:28 +0800
commitc8ef0117f2f7d5481e3ef5b70461e87caba14530 (patch)
tree7e11a1eed2bedd674cfe2c51b8944ac17ceb1868 /games
parent7b2bce80cbe22cf780225d759a03b053329c463b (diff)
downloadfreebsd-ports-gnome-c8ef0117f2f7d5481e3ef5b70461e87caba14530.tar.gz
freebsd-ports-gnome-c8ef0117f2f7d5481e3ef5b70461e87caba14530.tar.zst
freebsd-ports-gnome-c8ef0117f2f7d5481e3ef5b70461e87caba14530.zip
- Utilize USE_SDL
- PERL -> REINPLACE_CMD - Fix WWW: line PR: 61424 Submitted by: Ports Fury
Diffstat (limited to 'games')
-rw-r--r--games/lbreakout/Makefile19
-rw-r--r--games/lbreakout/pkg-descr2
2 files changed, 9 insertions, 12 deletions
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index c50f0ee67a88..ce78ca1f4ef9 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -14,20 +14,17 @@ MASTER_SITE_SUBDIR= lgames
MAINTAINER= ports@FreeBSD.org
COMMENT= A nice clone of classical Breakout game
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-
+USE_SDL= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-lcompat" \
- SDL_CONFIG="${SDL_CONFIG}"
+CONFIGURE_ENV= LIBS="-lcompat"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
- ${XARGS} ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|"SDL/SDL|"SDL|g ; \
+ s|<SDL/SDL|<SDL|g'
pre-install:
${MKDIR} /var/games/${PORTNAME}
diff --git a/games/lbreakout/pkg-descr b/games/lbreakout/pkg-descr
index 34098e98f780..5dc2d277ef1c 100644
--- a/games/lbreakout/pkg-descr
+++ b/games/lbreakout/pkg-descr
@@ -18,4 +18,4 @@ This is a list of LBreakout's features:
Cool effects
Own levels can be created
-WWW: http://lgames.sourceforge.net/#lbreakout
+WWW: http://lgames.sourceforge.net/index.php?project=LBreakout