aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2018-05-03 20:59:49 +0800
committersbruno <sbruno@FreeBSD.org>2018-05-03 20:59:49 +0800
commitc9b269159474f029c55d5df382555060656cd82e (patch)
tree5911b01b97b7967ba069d68079655380da3bb444 /games
parent5046cd33518649818b77733a12407c11f98df6dc (diff)
downloadfreebsd-ports-gnome-c9b269159474f029c55d5df382555060656cd82e.tar.gz
freebsd-ports-gnome-c9b269159474f029c55d5df382555060656cd82e.tar.zst
freebsd-ports-gnome-c9b269159474f029c55d5df382555060656cd82e.zip
games/cockatrice:
- bump to release 2.5.1 - Use this as the version number for the package - Add patch to indicate that this is the version number when selecting "About" in the menu. https://github.com/Cockatrice/Cockatrice/releases/tag/2018-04-16-Release-2.5.1
Diffstat (limited to 'games')
-rw-r--r--games/cockatrice/Makefile4
-rw-r--r--games/cockatrice/distinfo6
-rw-r--r--games/cockatrice/files/patch-CMakeLists.txt11
3 files changed, 16 insertions, 5 deletions
diff --git a/games/cockatrice/Makefile b/games/cockatrice/Makefile
index 898be93eff46..3d89579e04dc 100644
--- a/games/cockatrice/Makefile
+++ b/games/cockatrice/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Cockatrice
-PORTVERSION= 0.0.g2018.03.02
+PORTVERSION= 2.5.1.g2018.04.16
CATEGORIES= games
MAINTAINER= sbruno@FreeBSD.org
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libprotobuf.so:devel/protobuf
USE_GITHUB= yes
-GH_TAGNAME= 2018-03-02-Release-2.5.0
+GH_TAGNAME= 2018-04-16-Release-2.5.1
USES= cmake compiler:c++11-lib
USE_QT5= buildtools concurrent core multimedia network printsupport \
diff --git a/games/cockatrice/distinfo b/games/cockatrice/distinfo
index 49db09467a4a..d93701ea91d6 100644
--- a/games/cockatrice/distinfo
+++ b/games/cockatrice/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522428517
-SHA256 (Cockatrice-Cockatrice-0.0.g2018.03.02-2018-03-02-Release-2.5.0_GH0.tar.gz) = 4fbec9054ad0c64382e484ff42b9166676b4be3110e48bb3819a6f45316d9fd2
-SIZE (Cockatrice-Cockatrice-0.0.g2018.03.02-2018-03-02-Release-2.5.0_GH0.tar.gz) = 8354130
+TIMESTAMP = 1525274128
+SHA256 (Cockatrice-Cockatrice-2.5.1.g2018.04.16-2018-04-16-Release-2.5.1_GH0.tar.gz) = a088e460190b48b61fd4ea8681b3d5395cb9de84d515c42c44ac708fcd66367b
+SIZE (Cockatrice-Cockatrice-2.5.1.g2018.04.16-2018-04-16-Release-2.5.1_GH0.tar.gz) = 8357648
diff --git a/games/cockatrice/files/patch-CMakeLists.txt b/games/cockatrice/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a34d10250d06
--- /dev/null
+++ b/games/cockatrice/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-05-03 12:27:19 UTC
++++ CMakeLists.txt
+@@ -34,7 +34,7 @@ endif()
+
+ # A project name is needed for CPack
+ # Version can be overriden by git tags, see cmake/getversion.cmake
+-PROJECT("Cockatrice" VERSION 2.5.0)
++PROJECT("Cockatrice" VERSION 2.5.1)
+
+ # Use c++11 for all targets
+ set(CMAKE_CXX_STANDARD 11 CACHE STRING "C++ ISO Standard")