aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-01-31 21:08:11 +0800
committermarino <marino@FreeBSD.org>2016-01-31 21:08:11 +0800
commitce959c6bfa7bc0d8c2f6cc50618c3ace9decdf1c (patch)
tree75f20559aac7c5d48d7e8b39975bcd55f50f3941 /games
parent0c13c4c9bb30043ed420984e8450b56a95f7f077 (diff)
downloadfreebsd-ports-gnome-ce959c6bfa7bc0d8c2f6cc50618c3ace9decdf1c.tar.gz
freebsd-ports-gnome-ce959c6bfa7bc0d8c2f6cc50618c3ace9decdf1c.tar.zst
freebsd-ports-gnome-ce959c6bfa7bc0d8c2f6cc50618c3ace9decdf1c.zip
games/tads: USES+= ncurses, respect LDFLAGS
while here, regenerate patches (but maintain non-standard patch names)
Diffstat (limited to 'games')
-rw-r--r--games/tads/Makefile1
-rw-r--r--games/tads/files/patch-makefile8
-rw-r--r--games/tads/files/patch-tads2_osunixt.c7
-rw-r--r--games/tads/files/patch-tads2_osunixt.h5
4 files changed, 12 insertions, 9 deletions
diff --git a/games/tads/Makefile b/games/tads/Makefile
index 35c91f02cfbd..81423dd3be0f 100644
--- a/games/tads/Makefile
+++ b/games/tads/Makefile
@@ -17,6 +17,7 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
CONFLICTS= frobtads-1.*
+USES= ncurses
WRKSRC= ${WRKDIR}/tads-3.0.8/tads2
DATADIR= ${PREFIX}/share/tads2
diff --git a/games/tads/files/patch-makefile b/games/tads/files/patch-makefile
index 7267ca0c8852..6f4e414f15fc 100644
--- a/games/tads/files/patch-makefile
+++ b/games/tads/files/patch-makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Fri Jan 17 00:30:32 2003
-+++ Makefile Fri Jan 17 00:30:49 2003
-@@ -238,16 +238,16 @@
+--- Makefile.orig 2004-11-05 13:34:49 UTC
++++ Makefile
+@@ -246,16 +246,16 @@ MATT=Matt Herberg <meherberg@earthlink.n
# compatibility libraries installed. It has not been tested with a bare
# FreeBSD system without the Linux libraries.
#
@@ -22,7 +22,7 @@
+AFLAGS=
+OVLFLG=
+MACHDEP=
-+LIBS=-ltermcap
++LIBS=$(LDFLAGS) -lncurses
+MAKEXEC=touch
# OpenBSD 3.0 with gcc 2.95.3
diff --git a/games/tads/files/patch-tads2_osunixt.c b/games/tads/files/patch-tads2_osunixt.c
index 6906c77668d9..7f56c28ba497 100644
--- a/games/tads/files/patch-tads2_osunixt.c
+++ b/games/tads/files/patch-tads2_osunixt.c
@@ -1,5 +1,6 @@
-Index: osunixt.c
-@@ -960,7 +960,7 @@
+--- osunixt.c.orig 2004-12-15 02:06:26 UTC
++++ osunixt.c
+@@ -960,7 +960,7 @@ t_tty(int action)
t.c_cc[VMIN] = 1;
t.c_cc[VTIME] = 0;
#if !defined(SGI_IRIX)
@@ -8,7 +9,7 @@ Index: osunixt.c
#else
t.c_oflag &= (~TAB3);
#endif
-@@ -984,7 +984,7 @@
+@@ -984,7 +984,7 @@ t_tty(int action)
#ifdef USE_SGTTY
ospeed = t.sg_ospeed;
#else
diff --git a/games/tads/files/patch-tads2_osunixt.h b/games/tads/files/patch-tads2_osunixt.h
index 49b3b1bb9118..f61c9063e5d6 100644
--- a/games/tads/files/patch-tads2_osunixt.h
+++ b/games/tads/files/patch-tads2_osunixt.h
@@ -1,5 +1,6 @@
-Index: osunixt.h
-@@ -84,7 +84,7 @@
+--- osunixt.h.orig 2004-02-17 02:20:41 UTC
++++ osunixt.h
+@@ -84,7 +84,7 @@ Tue Nov 22 15:16:10 EST 1994 Dave Bag
* Define the following to use sgtty.h instead of termios or direct
* ioctl hacking.
*/