aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-10-30 02:13:29 +0800
committerdanilo <danilo@FreeBSD.org>2013-10-30 02:13:29 +0800
commitd024291c9aa61f9e4a281794690f1172858324ba (patch)
treefd25fdf111fb1e326dd0dba9e6c91083cd59f95a /games
parenta0820bbd697198060f05dfd5ff388c8426b42969 (diff)
downloadfreebsd-ports-gnome-d024291c9aa61f9e4a281794690f1172858324ba.tar.gz
freebsd-ports-gnome-d024291c9aa61f9e4a281794690f1172858324ba.tar.zst
freebsd-ports-gnome-d024291c9aa61f9e4a281794690f1172858324ba.zip
- Add stage support
- Add DOCS option
Diffstat (limited to 'games')
-rw-r--r--games/KnightCap/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/KnightCap/Makefile b/games/KnightCap/Makefile
index 640087361e52..b9385c86478f 100644
--- a/games/KnightCap/Makefile
+++ b/games/KnightCap/Makefile
@@ -17,16 +17,15 @@ USE_XORG= xmu xt xext x11 xi
USE_GL= glut
ALL_TARGET= KnightCap
+OPTIONS_DEFINE= DOCS
+
DOCSDIR= ${PREFIX}/share/doc/KnightCap
PORTDOCS= README
PLIST_FILES= bin/KnightCap
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/KnightCap ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/KnightCap ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>