aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2013-10-05 04:29:31 +0800
committerlme <lme@FreeBSD.org>2013-10-05 04:29:31 +0800
commitd491220cd71272d6c683ee7ae92b9af8e5923495 (patch)
treedbf73c4c8306796ecfc1e1dd09e48d7aec3d1074 /games
parent9bee86dbbe5c8380408381e057effd24aa25eb68 (diff)
downloadfreebsd-ports-gnome-d491220cd71272d6c683ee7ae92b9af8e5923495.tar.gz
freebsd-ports-gnome-d491220cd71272d6c683ee7ae92b9af8e5923495.tar.zst
freebsd-ports-gnome-d491220cd71272d6c683ee7ae92b9af8e5923495.zip
- Update to 1.6.0
- Support staging - Use new LIB_DEPENDS syntax - USES gmake - Use upstream installation logic - Remove the no longer needed patch
Diffstat (limited to 'games')
-rw-r--r--games/scummvm-tools/Makefile44
-rw-r--r--games/scummvm-tools/distinfo4
-rw-r--r--games/scummvm-tools/files/patch-encode_dxa.cpp10
-rw-r--r--games/scummvm-tools/pkg-plist41
4 files changed, 27 insertions, 72 deletions
diff --git a/games/scummvm-tools/Makefile b/games/scummvm-tools/Makefile
index 44fecdde53aa..014d060600f7 100644
--- a/games/scummvm-tools/Makefile
+++ b/games/scummvm-tools/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= scummvm-tools
-DISTVERSION= 1.0.0rc1
-PORTREVISION= 5
+DISTVERSION= 1.6.0
CATEGORIES= games emulators
MASTER_SITES= SF/scummvm/${PORTNAME}/${DISTVERSION}
@@ -16,22 +15,18 @@ BUILD_DEPENDS= lame:${PORTSDIR}/audio/lame \
oggenc:${PORTSDIR}/audio/vorbis-tools \
oggdec:${PORTSDIR}/audio/vorbis-tools \
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- vorbis.4:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
+GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-
-
-LDFLAGS+= -L${LOCALBASE}/lib
-CXXFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+CONFIGURE_TARGET=
OPTIONS_DEFINE= WXGTK
OPTIONS_DEFAULT= WXGTK
-NO_STAGE= yes
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
@@ -42,31 +37,12 @@ WX_COMP= wx:lib:build
GUI_BIN= tools_gui
PLIST_SUB= WX=""
.else
+CONFIGURE_ARGS+= --disable-wxwidgets
PLIST_SUB= WX="@comment "
.endif
-post-patch:
-.if ${PORT_OPTIONS:MWXGTK}
- @${REINPLACE_CMD} -e 's,wx-config,${WX_CONFIG},' ${WRKSRC}/Makefile
-.else
- @${REINPLACE_CMD} -e '/tools_gui$$(EXEEXT)$$/d' ${WRKSRC}/Makefile
-.endif
-
-do-install:
-.for i in compress_agos compress_kyra compress_queen compress_saga \
- compress_scumm_bun compress_scumm_san compress_scumm_sou \
- compress_sword1 compress_sword2 compress_touche compress_tucker \
- decine dekyra descumm desword2 degob encode_dxa extract_agos \
- extract_cine extract_kyra extract_loom_tg16 extract_mm_apple \
- extract_mm_c64 extract_mm_nes extract_parallaction \
- extract_scumm_mac extract_t7g_mac extract_zak_c64 \
- extract_gob_stk ${GUI_BIN}
- @${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
-.endfor
-
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
diff --git a/games/scummvm-tools/distinfo b/games/scummvm-tools/distinfo
index 0e3e48e3a790..51244fd8418b 100644
--- a/games/scummvm-tools/distinfo
+++ b/games/scummvm-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scummvm-tools-1.0.0rc1.tar.bz2) = 437d32f06bb00ae9a5bf6b38b73b8447ebf2ab9e28ecaf5580fcdef6be1c7545
-SIZE (scummvm-tools-1.0.0rc1.tar.bz2) = 241672
+SHA256 (scummvm-tools-1.6.0.tar.bz2) = 66ac40732ab60d7bc3ab4fc6b6cd40191e1e1ede1bf4fd94dd01fa08ce1b9988
+SIZE (scummvm-tools-1.6.0.tar.bz2) = 954223
diff --git a/games/scummvm-tools/files/patch-encode_dxa.cpp b/games/scummvm-tools/files/patch-encode_dxa.cpp
deleted file mode 100644
index 08dbb53b08d0..000000000000
--- a/games/scummvm-tools/files/patch-encode_dxa.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- encode_dxa.cpp.orig 2009-08-23 15:44:34.000000000 +0200
-+++ encode_dxa.cpp 2012-04-29 06:59:57.000000000 +0200
-@@ -25,6 +25,7 @@
- #include "util.h"
-
- #include <png.h>
-+#include <pngpriv.h>
-
- const uint32 typeDEXA = 0x41584544;
- const uint32 typeFRAM = 0x4d415246;
diff --git a/games/scummvm-tools/pkg-plist b/games/scummvm-tools/pkg-plist
index c172e32525e7..c085c9c22ccc 100644
--- a/games/scummvm-tools/pkg-plist
+++ b/games/scummvm-tools/pkg-plist
@@ -1,32 +1,21 @@
-bin/compress_agos
-bin/compress_kyra
-bin/compress_queen
-bin/compress_saga
-bin/compress_scumm_bun
-bin/compress_scumm_san
-bin/compress_scumm_sou
-bin/compress_sword1
-bin/compress_sword2
-bin/compress_touche
-bin/compress_tucker
+bin/construct_mohawk
+bin/create_sjisfnt
bin/decine
bin/degob
bin/dekyra
+bin/deriven
bin/descumm
bin/desword2
-bin/encode_dxa
-bin/extract_agos
-bin/extract_cine
-bin/extract_gob_stk
-bin/extract_kyra
-bin/extract_loom_tg16
-bin/extract_mm_apple
-bin/extract_mm_c64
-bin/extract_mm_nes
-bin/extract_parallaction
-bin/extract_scumm_mac
-bin/extract_t7g_mac
-bin/extract_zak_c64
-%%WX%%bin/tools_gui
+bin/extract_mohawk
+bin/gob_loadcalc
+%%WX%%bin/scummvm-tools
+bin/scummvm-tools-cli
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%DATADIR%%/detaillogo.jpg
+%%DATADIR%%/logo.jpg
+%%DATADIR%%/scummvmtools.icns
+%%DATADIR%%/scummvmtools.ico
+%%DATADIR%%/scummvmtools_128.png
+%%DATADIR%%/tile.gif
+@dirrmtry %%DATADIR%%
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%