aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-13 19:40:10 +0800
committerpawel <pawel@FreeBSD.org>2014-04-13 19:40:10 +0800
commite10f592f37aa6f02e7f5d0e6920801c5a0e1107a (patch)
tree866216f2c25bb80f3637a31966dd6c589a2e4768 /games
parent6052b05decc9d9f83a7550171c7df60a86cdab14 (diff)
downloadfreebsd-ports-gnome-e10f592f37aa6f02e7f5d0e6920801c5a0e1107a.tar.gz
freebsd-ports-gnome-e10f592f37aa6f02e7f5d0e6920801c5a0e1107a.tar.zst
freebsd-ports-gnome-e10f592f37aa6f02e7f5d0e6920801c5a0e1107a.zip
- Add staging support
- Use option helper
Diffstat (limited to 'games')
-rw-r--r--games/endgame-singularity/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/games/endgame-singularity/Makefile b/games/endgame-singularity/Makefile
index 89378c4608b6..5db7ed94bf98 100644
--- a/games/endgame-singularity/Makefile
+++ b/games/endgame-singularity/Makefile
@@ -24,13 +24,7 @@ PROJECTHOST= ${PKGNAMEPREFIX}${PORTNAME}
OPTIONS_DEFINE= MUSIC DOCS
OPTIONS_DEFAULT= MUSIC
MUSIC_DESC= Install original music pack
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMUSIC}
-RUN_DEPENDS+= endgame-singularity-music>=006:${PORTSDIR}/games/endgame-singularity-music
-.endif
+MUSIC_RUN_DEPENDS= endgame-singularity-music>=006:${PORTSDIR}/games/endgame-singularity-music
post-extract:
@${FIND} ${WRKSRC} -name '*.pyc' -delete
@@ -67,11 +61,9 @@ post-build:
@${ECHO_CMD} 'import ${PORTNAME}.${PORTNAME}' >> ${WRKSRC}/${PORTNAME}.py
post-install:
- @cd ${WRKSRC}/data/&&${COPYTREE_SHARE} . ${DATADIR}/
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
-.if ${PORT_OPTIONS:MDOCS}
- @${INSTALL} -d ${DOCSDIR}/
- @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
-.endif
+ (cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>