aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-09-17 01:29:39 +0800
committerbsam <bsam@FreeBSD.org>2009-09-17 01:29:39 +0800
commite4ea0d857b08ad14073de8613373215d9699fa17 (patch)
treec005c5937cd26daf8325f4f3af7d944dc4c70ef0 /games
parent1005d6f99fcd0113d4eb80a18a5a7eecd295d34c (diff)
downloadfreebsd-ports-gnome-e4ea0d857b08ad14073de8613373215d9699fa17.tar.gz
freebsd-ports-gnome-e4ea0d857b08ad14073de8613373215d9699fa17.tar.zst
freebsd-ports-gnome-e4ea0d857b08ad14073de8613373215d9699fa17.zip
. respect using USE_LINUX_APPS;
. respect using linux libglu. Approved by: scf (maintainer, at emulation@) Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/linux-nwnclient/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 720250126362..143ee0b5d663 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -19,19 +19,19 @@ COMMENT= Neverwinter Nights Linux (x86) Client
RUN_DEPENDS= ${LOCALBASE}/share/nwndata/NWNv129.txt:${PORTSDIR}/games/nwndata
-.ifdef WITH_NVIDIA_GL
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
- ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
-.else
-USE_LINUX_APPS+=dri
-.endif
-
NO_BUILD= yes
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_LINUX_APPS= sdl12 xorglibs
NWNDATADIR= ${LOCALBASE}/share/nwndata
+.ifdef WITH_NVIDIA_GL
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+USE_LINUX_APPS+=libglu
+.else
+USE_LINUX_APPS+=dri
+.endif
+
PLIST_SUB+= NWNVERSION="${PORTVERSION:S/.//}"
do-extract: