aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
committerbapt <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
commite6b8ed87b5e99e0ddfa7f575594f03f1992cf201 (patch)
tree1485083919fd5b153bf056ea17ac895ea758a8a9 /games
parent729d5d5ddb37fd2035af319a95b99466360a2e7e (diff)
downloadfreebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.tar.gz
freebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.tar.zst
freebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.zip
Replace lang/lua with the new lang/lua51
lang/lua51 is working the same way lang/lua52, chase ports using lua 5.1 Make the default lua lua52 Make all lua ports using USES=lua Approved by: portmgr (implicit)
Diffstat (limited to 'games')
-rw-r--r--games/allacrost/Makefile6
-rw-r--r--games/asc/Makefile4
-rw-r--r--games/battletanks/Makefile4
-rw-r--r--games/boswars/Makefile2
-rw-r--r--games/corsix-th/Makefile3
-rw-r--r--games/enigma/Makefile7
-rw-r--r--games/fillets-ng/Makefile3
-rw-r--r--games/freedroidrpg/Makefile5
-rw-r--r--games/glest/Makefile3
-rw-r--r--games/hedgewars/Makefile3
-rw-r--r--games/instead/Makefile3
-rw-r--r--games/irrlamb/Makefile3
-rw-r--r--games/jvgs/Makefile5
-rw-r--r--games/nlarn/Makefile11
-rw-r--r--games/palomino/Makefile4
-rw-r--r--games/stonesoup/Makefile3
-rw-r--r--games/stratagus/Makefile6
-rw-r--r--games/sumwars/Makefile4
-rw-r--r--games/valyriatear/Makefile3
-rw-r--r--games/widelands/Makefile3
-rw-r--r--games/xmoto/Makefile3
21 files changed, 32 insertions, 56 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 2cced4997f2e..2978e4dc189e 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= gettext gmake openal:al
-USE_LUA= 5.1
+USES= gettext gmake openal:al lua:51
USE_SDL= sdl ttf net
USE_GL= yes
USE_GCC= any # problems in luabind
@@ -58,7 +57,8 @@ post-patch:
@${REINPLACE_CMD} -e '/^LIBS =/ s|$$| @INTLLIBS@|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^bindir = / s|games|bin|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/qt4_incdirs/ s|".*"|"${QT_INCDIR}"|; \
- /qt4_libdirs/ s|".*"|"${QT_LIBDIR}"|; /test/ s|==|=|' \
+ /qt4_libdirs/ s|".*"|"${QT_LIBDIR}"|; /test/ s|==|=| ; \
+ s/-llua /-llua-${LUA_VER} /g;' \
${WRKSRC}/configure
.if ${PORT_OPTIONS:MEDITOR}
@${REINPLACE_CMD} -e '/^INCLUDES = / s|=|= -I${QT_INCDIR}/QtGui \
diff --git a/games/asc/Makefile b/games/asc/Makefile
index f8a64ff0ac08..bc9d41e74d32 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -27,13 +27,11 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= MUSIC XVID
MUSIC_DESC= Install extra music files
-USES= gmake libtool perl5 pkgconfig tar:bzip2
+USES= gmake libtool lua:51 perl5 pkgconfig tar:bzip2
USE_SDL= image mixer sound sdl
USE_WX= 3.0
WX_UNICODE= yes
WX_CONF_ARGS= absolute
-USE_LUA= 5.1
-LUA_COMPS= lua
USE_PERL5= build
GNU_CONFIGURE= yes
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index aca966ca1c36..ffc9fa16f30f 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -16,10 +16,8 @@ LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
libsmpeg.so:${PORTSDIR}/multimedia/smpeg
-USES= openal:al pkgconfig
-USE_BZIP2= yes
+USES= openal:al pkgconfig lua:51 tar:bzip2
USE_LDCONFIG= yes
-USE_LUA= 5.0+
USE_SDL= image sdl
USE_SCONS= yes
USE_PYTHON_BUILD= yes
diff --git a/games/boswars/Makefile b/games/boswars/Makefile
index a451321193ad..04270cc03133 100644
--- a/games/boswars/Makefile
+++ b/games/boswars/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
theora:${PORTSDIR}/multimedia/libtheora \
vorbis:${PORTSDIR}/audio/libvorbis
-USE_LUA= 5.1
+USES= lua:51
USE_SDL= sdl
USE_GL= yes
USE_SCONS= yes
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index 2ae94afdab72..9d08b4515393 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -13,8 +13,7 @@ LICENSE= MIT
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-USES= cmake compiler:c++11-lang dos2unix pkgconfig
-USE_LUA= yes
+USES= cmake compiler:c++11-lang dos2unix lua:51 pkgconfig
USE_SDL= mixer
DOS2UNIX_FILES= CMake/FindFFmpeg.cmake \
CorsixTH/CMakeLists.txt \
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index 560c01fb92ba..6387c3a3bc55 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -12,12 +12,11 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Enigma is a reimplementation of Oxyd, a puzzle game
LIB_DEPENDS= libxerces-c.so:${PORTSDIR}/textproc/xerces-c2 \
- libpng.so:${PORTSDIR}/graphics/png
+ libpng.so:${PORTSDIR}/graphics/png \
+ libtoluaxx-${LUA_VER}.so:${PORTSDIR}/lang/tolua++
BUILD_DEPENDS= ${LOCALBASE}/lib/libenet.a:${PORTSDIR}/net/enet
-USES= gettext gmake
-USE_LUA= 5.1
-LUA_COMPS= lua toluaxx
+USES= gettext gmake lua:51
USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-cxxlua \
diff --git a/games/fillets-ng/Makefile b/games/fillets-ng/Makefile
index b33433ab9d3e..dec5788279a9 100644
--- a/games/fillets-ng/Makefile
+++ b/games/fillets-ng/Makefile
@@ -14,8 +14,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A wonderful puzzle game
USE_SDL= sdl mixer image ttf
-USE_LUA= 5.1
-USES= gmake
+USES= gmake lua
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LUA_INCDIR}
LDFLAGS+= -L${LUA_LIBDIR}
diff --git a/games/freedroidrpg/Makefile b/games/freedroidrpg/Makefile
index a13502321986..8128a8af9781 100644
--- a/games/freedroidrpg/Makefile
+++ b/games/freedroidrpg/Makefile
@@ -11,10 +11,9 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Modification of the classical Freedroid engine into an RPG
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake lua:51
USE_SDL= sdl image mixer gfx
-USE_LUA= 5.1+
-CONFIGURE_ENV= LUA_CFLAGS="-I${LUA_INCDIR}" LUA_LIBS="-L${LUA_LIBDIR} -llua"
+CONFIGURE_ENV= LUA_CFLAGS="-I${LUA_INCDIR}" LUA_LIBS="-L${LUA_LIBDIR} -llua-${LUA_VER}"
USE_GCC= any # doesn't build with clang
PORTDATA= *
diff --git a/games/glest/Makefile b/games/glest/Makefile
index c7cda97960fd..3788c937bfdf 100644
--- a/games/glest/Makefile
+++ b/games/glest/Makefile
@@ -17,9 +17,8 @@ LIB_DEPENDS= libxerces-c.so:${PORTSDIR}/textproc/xerces-c3 \
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
RUN_DEPENDS= ${DATADIR}/servers.ini:${PORTSDIR}/games/glest-data
-USES= dos2unix openal:al,alut pkgconfig zip:infozip
+USES= dos2unix openal:al,alut pkgconfig zip:infozip lua:51
USE_AUTOTOOLS= automake:env autoconf:env
-USE_LUA= 5.1
USE_SDL= yes
USE_GL= yes
GNU_CONFIGURE= yes
diff --git a/games/hedgewars/Makefile b/games/hedgewars/Makefile
index 559c8b3a67dc..19f6f213c9b0 100644
--- a/games/hedgewars/Makefile
+++ b/games/hedgewars/Makefile
@@ -18,10 +18,9 @@ LICENSE_COMB= multi
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= depends on fpc which is only available for i386 and amd64
-USES= tar:bzip2 cmake
+USES= tar:bzip2 cmake lua:51
USE_SDL= sdl mixer image ttf net
USE_FPC= opengl libpng
-USE_LUA= 5.1+
USE_QT4= corelib gui moc_build network \
qmake_build rcc_build svg xml \
uic_build linguist_build
diff --git a/games/instead/Makefile b/games/instead/Makefile
index 387e85128a26..657e476b37d4 100644
--- a/games/instead/Makefile
+++ b/games/instead/Makefile
@@ -12,9 +12,8 @@ COMMENT= Simple Text Adventure, The Interpreter
LICENSE= MIT
-USES= cmake:outsource pkgconfig iconv
+USES= cmake:outsource pkgconfig iconv lua:51
CMAKE_ARGS= -DMANDIR=man
-USE_LUA= 5.1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/irrlamb/Makefile b/games/irrlamb/Makefile
index 4e8e7128fc32..9ab28caef8ce 100644
--- a/games/irrlamb/Makefile
+++ b/games/irrlamb/Makefile
@@ -15,9 +15,8 @@ LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
BUILD_DEPENDS= ${LOCALBASE}/lib/libIrrlicht.so:${PORTSDIR}/x11-toolkits/irrlicht
RUN_DEPENDS= ${LOCALBASE}/lib/libIrrlicht.so:${PORTSDIR}/x11-toolkits/irrlicht
-USE_LUA= 5.1+
USE_SCONS= yes
-USES= scons dos2unix
+USES= scons dos2unix lua:51
DOS2UNIX_FILES= src/engine/save.h src/objects/orb.cpp src/objects/player.cpp
CPPPATH= ${LOCALBASE}/include ${LUA_INCDIR}
diff --git a/games/jvgs/Makefile b/games/jvgs/Makefile
index 3d48d7aeae5e..73349829f12a 100644
--- a/games/jvgs/Makefile
+++ b/games/jvgs/Makefile
@@ -11,13 +11,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A minimalistic platform game
-BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+BUILD_DEPENDS= libswig.so:${PORTSDIR}/devel/swig13
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-USES= cmake
+USES= cmake lua:51
USE_SDL= sdl mixer
USE_GL= gl glu
-USE_LUA= 5.1+
SUB_FILES= ${PORTNAME}
diff --git a/games/nlarn/Makefile b/games/nlarn/Makefile
index 3a06201d695c..2e7d1be18233 100644
--- a/games/nlarn/Makefile
+++ b/games/nlarn/Makefile
@@ -11,19 +11,16 @@ COMMENT= Roguelike game and as such a remake of the classic game Larn
LICENSE= GPLv3
-USES= pkgconfig
-USE_LUA= 5.1
+USES= gmake lua pkgconfig
USE_GNOME= glib20
-USE_GMAKE= yes
-NO_STAGE= yes
post-configure:
@${REINPLACE_CMD} 's|/usr/share/nlarn|${DATADIR}|' \
${WRKSRC}/src/game.c
do-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/nlarn ${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/nlarn.ini-sample ${WRKSRC}/lib/* ${DATADIR}/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/nlarn ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/nlarn.ini-sample ${WRKSRC}/lib/* ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/games/palomino/Makefile b/games/palomino/Makefile
index af2e23162bf1..d2e7346e1701 100644
--- a/games/palomino/Makefile
+++ b/games/palomino/Makefile
@@ -18,10 +18,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libosg.so:${PORTSDIR}/graphics/osg
-USES= cmake tar:xz
+USES= cmake tar:xz lua:51
USE_GL= gl
-USE_LUA= 5.1
-LUA_COMPS= lua:build
MISC_VER= 20091027
MODELS_VER= 20090615
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 3674f3c10795..ff41f8de69a4 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKDIR}/stone_soup-${PORTVERSION}/licence.txt
USE_SQLITE= yes
-USES= bison compiler gmake perl5 pkgconfig tar:xz
-USE_LUA= 5.1
+USES= bison compiler gmake perl5 pkgconfig tar:xz lua:51
USE_PERL5= build
SAVEDIR= \~/.stonesoup
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index c11a6a3a1913..dc82cafac947 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -12,7 +12,8 @@ COMMENT= Free cross-platform real-time strategy gaming engine
LICENSE= GPLv2
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libtolua++-${LUA_VER}.so:${PORTSDIR}/lang/tolua++
OPTIONS_DEFINE= MIKMOD MNG THEORA VORBIS DOCS
OPTIONS_DEFAULT= VORBIS
@@ -20,8 +21,7 @@ OPTIONS_DEFAULT= VORBIS
USE_GL= glu
USE_SDL= sdl
USE_SQLITE= 3
-USE_LUA= 5.0+
-LUA_COMPS= toluaxx
+USES= lua:51
USES= cmake:outsource pkgconfig
CMAKE_ARGS= -DGAMEDIR:STRING="bin" \
-DTOLUA++_APP:STRING="${TOLUAXX_CMD}" \
diff --git a/games/sumwars/Makefile b/games/sumwars/Makefile
index 877e1b40c3d2..daff82af1d7e 100644
--- a/games/sumwars/Makefile
+++ b/games/sumwars/Makefile
@@ -24,11 +24,9 @@ LIB_DEPENDS= CEGUIBase-0.so:${PORTSDIR}/graphics/cegui \
PocoNet.12:${PORTSDIR}/devel/poco \
physfs.1:${PORTSDIR}/devel/physfs
-USES= cmake gettext gmake openal:al,alut pkgconfig
+USES= cmake gettext gmake openal:al,alut pkgconfig lua:51 tar:bzip2
USE_GL= gl glu
-USE_BZIP2= yes
INSTALLS_ICONS= yes
-USE_LUA= 5.1
CMAKE_ARGS+= -DGETTEXT_SEARCH_PATH=${LOCALBASE}/lib
diff --git a/games/valyriatear/Makefile b/games/valyriatear/Makefile
index 53b37ca265cc..d52247de11c5 100644
--- a/games/valyriatear/Makefile
+++ b/games/valyriatear/Makefile
@@ -23,11 +23,10 @@ GH_ACCOUNT= Bertram25
GH_PROJECT= ValyriaTear
GH_COMMIT= a324297
-USES= cmake iconv openal
+USES= cmake iconv openal lua:51
CMAKE_ARGS= -DUSE_PCH_COMPILATION=OFF
USE_SDL= sdl image ttf
USE_GL= gl
-USE_LUA= 5.1
INSTALLS_ICONS= yes
LDFLAGS= -L${LOCALBASE}/lib ${ICONV_LIB} -lintl
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index 463f8e84c4eb..125f36d2946d 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -17,13 +17,12 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libexecinfo.so:${PORTSDIR}/devel/libexecinfo
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-USES= tar:bzip2 cmake:outsource gettext compiler:c++11-lib
+USES= tar:bzip2 cmake:outsource gettext compiler:c++11-lib lua:51
CMAKE_ARGS= -DWL_INSTALL_PREFIX="${PREFIX}" \
-DWL_INSTALL_DATADIR="share/widelands" \
-DWL_INSTALL_BINDIR="bin" \
-DWL_VERSION="${DISTVERSION}" \
-DWL_COMPILERFLAG_OPTIMIZATIONS=""
-USE_LUA= 5.1
USE_SDL= sdl mixer image net ttf gfx
USE_PYTHON_BUILD=yes
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 30fb01a2ddad..556cdaec1b64 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -20,9 +20,8 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= gmake dos2unix
+USES= gmake dos2unix lua:51
USE_GNOME= libxml2
-USE_LUA= 5.1
USE_SQLITE= 3
USE_SDL= sdl mixer ttf net
USE_GL= gl glu