aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-01-20 19:28:18 +0800
committeredwin <edwin@FreeBSD.org>2004-01-20 19:28:18 +0800
commitee87aa4a03b156f7a06c96a1cf7a61984970743a (patch)
treeb6711724a8b53c4c1b4d2176b54cccf4b89e0627 /games
parent332948c8d65beda4907e3cdea9af032b245afe0e (diff)
downloadfreebsd-ports-gnome-ee87aa4a03b156f7a06c96a1cf7a61984970743a.tar.gz
freebsd-ports-gnome-ee87aa4a03b156f7a06c96a1cf7a61984970743a.tar.zst
freebsd-ports-gnome-ee87aa4a03b156f7a06c96a1cf7a61984970743a.zip
Move more of my ports which use one or more SDL libraries towards USE_SDL.
Submitted by: edwin@mavetju.org
Diffstat (limited to 'games')
-rw-r--r--games/bomberclone/Makefile8
-rw-r--r--games/circuslinux/Makefile8
-rw-r--r--games/sopwith/Makefile4
-rw-r--r--games/xpired/Makefile6
4 files changed, 5 insertions, 21 deletions
diff --git a/games/bomberclone/Makefile b/games/bomberclone/Makefile
index e7b7a4c2657b..1ef603d7b905 100644
--- a/games/bomberclone/Makefile
+++ b/games/bomberclone/Makefile
@@ -14,17 +14,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= edwin@mavetju.org
COMMENT= Reimplementation of Atomic Bomber Man
-LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
+USE_SDL= image mixer sdl
GNU_CONFIGURE= yes
USE_XLIB= yes
-USE_SDL= yes
USE_GMAKE= yes
USE_BZIP2= yes
CONFIGURE_ARGS= --target=""
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CXXFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include"
.include <bsd.port.mk>
diff --git a/games/circuslinux/Makefile b/games/circuslinux/Makefile
index 8a2e9cb83aa8..f5ab50418b97 100644
--- a/games/circuslinux/Makefile
+++ b/games/circuslinux/Makefile
@@ -13,15 +13,9 @@ MASTER_SITES= http://www.nbswebfx.com/downloads/
MAINTAINER= edwin@mavetju.org
COMMENT= "Circus Linux!" is a clone of the Atari 2600 game "Circus Atari"
-BUILD_DEPENDS= sdl11-config:${PORTSDIR}/devel/sdl12
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
+USE_SDL= image mixer sdl
GNU_CONFIGURE= yes
USE_XLIB= yes
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
CONFIGURE_ARGS= --target=""
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
.include <bsd.port.mk>
diff --git a/games/sopwith/Makefile b/games/sopwith/Makefile
index 409290ee09c8..2fcc9ec6bc22 100644
--- a/games/sopwith/Makefile
+++ b/games/sopwith/Makefile
@@ -15,12 +15,10 @@ DISTNAME= sdl_${PORTNAME}-${PORTVERSION}
MAINTAINER= edwin@mavetju.org
COMMENT= A classic WW1 biplane game
-BUILD_DEPENDS= ${LOCALBASE}/bin/sdl11-config:${PORTSDIR}/devel/sdl12
-
+USE_SDL= sdl
USE_GMAKE= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CONFIGURE_ENV= SDL_CONFIG=${LOCALBASE}/bin/sdl11-config
MAN6= sopwith.6
diff --git a/games/xpired/Makefile b/games/xpired/Makefile
index 3236154c59b6..b33d080f115d 100644
--- a/games/xpired/Makefile
+++ b/games/xpired/Makefile
@@ -16,11 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-linux_source
MAINTAINER= edwin@mavetju.org
COMMENT= An action-puzzle maze escape game (SDL)
-LIB_DEPENDS= SDL_gfx.10:${PORTSDIR}/graphics/sdl_gfx \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image \
- SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
+USE_SDL= gfx image mixer sdl
WRKSRC= ${WRKDIR}/src
do-install: