aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-07-02 02:49:43 +0800
committervs <vs@FreeBSD.org>2004-07-02 02:49:43 +0800
commitfbed943893fec26fe5db45875f620944c20e7d59 (patch)
tree0d0ee037a38a912feac92512ad977e6afc20b458 /games
parent77c565eea3c9786cff9f1dd6d3f0f82ca49dff64 (diff)
downloadfreebsd-ports-gnome-fbed943893fec26fe5db45875f620944c20e7d59.tar.gz
freebsd-ports-gnome-fbed943893fec26fe5db45875f620944c20e7d59.tar.zst
freebsd-ports-gnome-fbed943893fec26fe5db45875f620944c20e7d59.zip
- Fix MENUCOLORS-support on -CURRENT
- Add WITH_MAIL-knob PR: ports/68522 Submitted by Jeremy Chadwick
Diffstat (limited to 'games')
-rw-r--r--games/nethack34/Makefile23
-rw-r--r--games/nethack34/files/patch-ad12
2 files changed, 28 insertions, 7 deletions
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index f7ff7b7d3317..0e9423f33cda 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -49,6 +49,7 @@ GRAPHICS= # none
PATCHFILES+= nh343-menucolor.diff
PATCH_SITES+= http://www.cs.joensuu.fi/~pkalli/code/
PATCH_DIST_STRIP= -p1
+MAKE_ENV+= LIBTTY="-lgnuregex"
.endif
.elif ${PKGNAMESUFFIX} == "-qt"
USE_QT_VER= 3
@@ -59,6 +60,17 @@ GRAPHICS= QT_GRAPHICS
.endif
.endif
+.include <bsd.port.pre.mk>
+
+# FreeBSD 5.2.1-RELEASE (or, well, almost) and above use include/gnu/regex.h
+# while prior releases use include/gnuregex.h. This simply gets rid of the
+# repetitive warning during the build process on 5.x.
+.if ${OSVERSION} >= 502010
+GNU_REGEX_H= <gnu/regex.h>
+.else
+GNU_REGEX_H= <gnuregex.h>
+.endif
+
pre-everything::
@if [ "${PKGBASE}" != "nethack" ]; then \
${ECHO_MSG} "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!" ; \
@@ -73,13 +85,16 @@ post-patch:
.for f in include/config.h sys/unix/Makefile.src sys/unix/Makefile.top
${REINPLACE_CMD} -e 's|%%HACKNAME%%|${HACKNAME}|g;s|%%HACKDIR%%|${PREFIX}/${HACKDIR}|g' ${WRKSRC}/${f}
.endfor
- ${REINPLACE_CMD} -e 's|<regex.h>|<gnuregex.h>|g' ${WRKSRC}/src/sounds.c
+ ${REINPLACE_CMD} -e 's|<regex.h>|${GNU_REGEX_H}|g' ${WRKSRC}/src/sounds.c
${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/win/Qt/qt_win.cpp
.if defined(WITHOUT_SHELL)
- @${REINPLACE_CMD} -e 's|#define SHELL|/* #define SHELL|' ${WRKSRC}/include/unixconf.h
+ ${REINPLACE_CMD} -e 's|#define SHELL|/* #define SHELL|' ${WRKSRC}/include/unixconf.h
.endif
.if defined(WITH_MENUCOLORS)
- ${REINPLACE_CMD} -e 's|<regex.h>|<gnuregex.h>|g' ${WRKSRC}/include/color.h
+ ${REINPLACE_CMD} -e 's|<regex.h>|${GNU_REGEX_H}|g' ${WRKSRC}/include/color.h
+.endif
+.if defined(WITH_MAIL)
+ ${REINPLACE_CMD} -e 's|/\* #define MAIL \*/|#define MAIL|' ${WRKSRC}/include/unixconf.h
.endif
pre-configure:
@@ -92,4 +107,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${PREFIX}/${HACKDOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/nethack34/files/patch-ad b/games/nethack34/files/patch-ad
index b41a098d4ada..0c6dfb8f83d3 100644
--- a/games/nethack34/files/patch-ad
+++ b/games/nethack34/files/patch-ad
@@ -1,5 +1,6 @@
---- sys/unix/Makefile.src.orig Sat Aug 30 09:08:04 2003
-+++ sys/unix/Makefile.src Mon Sep 1 23:12:45 2003
+diff -ruN sys.orig/unix/Makefile.src sys/unix/Makefile.src
+--- sys.orig/unix/Makefile.src Sun Dec 7 15:39:13 2003
++++ sys/unix/Makefile.src Wed Jun 30 08:27:32 2004
@@ -146,19 +146,29 @@
# directories. The ones given below is the usual spot for linux systems.
# The paths are for glibconfig.h and gnomesupport.h respectively.
@@ -61,7 +62,12 @@
# on some systems the termcap library is in -ltermcap or -lcurses
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
-@@ -235,19 +264,19 @@
+@@ -231,23 +260,23 @@
+ # WINTTYLIB = -lcurses
+ # WINTTYLIB = -lcurses16
+ # WINTTYLIB = -lncurses
+-WINTTYLIB = -ltermlib
++WINTTYLIB = -ltermlib ${LIBTTY}
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.