aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
committerflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
commit02ba370ac4348e20c88c9698d4e91f3fe34868c8 (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /games
parentab79042bad4c4010d43e6983f39a47e3575126a5 (diff)
downloadfreebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.gz
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.zst
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Diffstat (limited to 'games')
-rw-r--r--games/mangos/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/games/mangos/Makefile b/games/mangos/Makefile
index 67adfcdb44b0..2a6922903ffd 100644
--- a/games/mangos/Makefile
+++ b/games/mangos/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mangos
-# Date created: 15 March 2007
-# Whom: Artemiy Kropachev <neon_cyrex@mail.ru>
-#
+# Created by: Artemiy Kropachev <neon_cyrex@mail.ru>
# $FreeBSD$
-#
PORTNAME= mangos
PORTVERSION= 5101
@@ -89,7 +85,7 @@ post-build:
post-install:
@for i in mangosd realmd;do cd ${PREFIX}/etc/&&\
${INSTALL_DATA} ${WRKSRC}/src/$$i/$$i.conf $$i.conf.sample&&\
- ${CP} -np $$i.conf.sample $$i.conf;done
+ ${CP} -np $$i.conf.sample $$i.conf || ${TRUE} ;done
.ifdef WITH_SCRIPTDEV2
@(cd ${INSTALL_WRKSRC}/src/bindings/ScriptDev2 && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.endif