aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-11 04:48:45 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:06:28 +0800
commit094c3de1d3cb3642af7e983a75a4a27204437c18 (patch)
treeb5cbaf5f9b6ea3a343222dc99e8f6f8f21de70bd /games
parent09e4065c82da9ab4ac85dfd677e5880be168b51a (diff)
downloadfreebsd-ports-gnome-094c3de1d3cb3642af7e983a75a4a27204437c18.tar.gz
freebsd-ports-gnome-094c3de1d3cb3642af7e983a75a4a27204437c18.tar.zst
freebsd-ports-gnome-094c3de1d3cb3642af7e983a75a4a27204437c18.zip
- Those ports fail to build with python3
- Add some explicit FLAVOR to dependencies where needed
Diffstat (limited to 'games')
-rw-r--r--games/kajongg/Makefile4
-rw-r--r--games/magicor/Makefile4
-rw-r--r--games/openalchemist/Makefile2
3 files changed, 5 insertions, 5 deletions
diff --git a/games/kajongg/Makefile b/games/kajongg/Makefile
index 113cb5363a27..e860afdba9c1 100644
--- a/games/kajongg/Makefile
+++ b/games/kajongg/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= games kde kde-kde4
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR}
NO_ARCH= yes
-USES= cmake:outsource kde:4 python tar:xz shebangfix sqlite
+USES= cmake:outsource kde:4 python:2.7 tar:xz shebangfix sqlite
USE_KDE= kdelibs pykde4 automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
CMAKE_ARGS= -DINSTALL_KAJONGG:BOOL=TRUE
diff --git a/games/magicor/Makefile b/games/magicor/Makefile
index 5bf8376f872c..37aea0151ae6 100644
--- a/games/magicor/Makefile
+++ b/games/magicor/Makefile
@@ -15,7 +15,7 @@ COMMENT= Old-school, puzzle game similar to Solomon's Key
LICENSE= PD
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:devel/py-game
+RUN_DEPENDS= ${PYGAME}
USES= python:2.7 shebangfix
SHEBANG_FILES= *.py
@@ -37,7 +37,7 @@ OPTIONS_DEFAULT=EDITOR
OPTIONS_SUB= yes
EDITOR_DESC= Enable editor
-EDITOR_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:x11-toolkits/py-gtk2
+EDITOR_USE= gnome=pygtk2
post-patch:
@${REINPLACE_CMD} -e 's|###CONFIG_PATH###|${PREFIX}/etc/magicor/magicor.conf|' \
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index 1a8ad05f68cf..597f29f10b25 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -26,7 +26,7 @@ USE_GNOME= pygtk2
USE_XORG= xxf86vm xi x11 xmu xext xdamage xfixes xau xdmcp xt sm ice
USE_GL= gl glu
USE_SDL= sdl gfx
-USES= autoreconf gmake iconv jpeg pkgconfig python:run shebangfix
+USES= autoreconf gmake iconv jpeg pkgconfig python:2.7,run shebangfix
SHEBANG_FILES= openalchemist-config
PORTDOCS= AUTHORS ChangeLog README TODO