aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
committeraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
commit0a9e5efb9de6b8811964b263c03b83ec89719f71 (patch)
treeaf6266e338105f6caa968f90afd0c4e98288d6f5 /games
parent161ee4e405ddee7d6c945754c827684829ef8e90 (diff)
downloadfreebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.gz
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.zst
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'games')
-rw-r--r--games/atr3d/Makefile11
-rw-r--r--games/atr3d/pkg-descr1
-rw-r--r--games/falconseye/Makefile2
-rw-r--r--games/gracer/Makefile8
4 files changed, 7 insertions, 15 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 6108746c59da..11faaedae2eb 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: atr3d
-# Date created: 11 Jun 2003
-# Whom: Kirill Ponomarew <ponomarew@oberon.net>
-#
+# Created by: Kirill Ponomarew <ponomarew@oberon.net>
# $FreeBSD$
-#
PORTNAME= atr3d
PORTVERSION= 0.6
@@ -44,8 +40,9 @@ CONFIGURE_ARGS+= --disable-sound
.endif
pre-patch:
- @${PERL} -pi.orig -e 's|^aclocal|${ACLOCAL}|; \
- s|^autoconf|${AUTOCONF}|; s|^automake|${AUTOMAKE}|' \
+ @${REINPLACE_CMD} -i '' -e 's|^aclocal|${ACLOCAL}|' \
+ -e 's|^autoconf|${AUTOCONF}|' \
+ -e 's|^automake|${AUTOMAKE}|' \
${WRKSRC}/autogen.sh
@${REINPLACE_CMD} -e 's|-lopenal|& -lalut|' ${WRKSRC}/Makefile.am
diff --git a/games/atr3d/pkg-descr b/games/atr3d/pkg-descr
index f4b808ab263c..40f80d44b743 100644
--- a/games/atr3d/pkg-descr
+++ b/games/atr3d/pkg-descr
@@ -2,4 +2,3 @@ Avoid The Roid 3D is a 3D asteroids-like multiplayer game. The
player flies around in a three dimensional space, shooting
asteroids and other ships while trying to avoid running into
any of them or being shot.
-
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index 4a7121d77140..f188719000b5 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -26,7 +26,7 @@ NO_WRKSUBDIR= yes
MAKE_JOBS_UNSAFE= yes
post-patch:
- @${PERL} -pi -e "s@<malloc.h>@<stdlib.h>@g" \
+ @${REINPLACE_CMD} -i '' -e "s|<malloc.h>|<stdlib.h>|" \
${WRKSRC}/include/jtp_gen.h ${WRKSRC}/win/jtp/jtp_dirx.c \
${WRKSRC}/win/jtp/jtp_keys.c ${WRKSRC}/win/jtp/jtp_sdl.c \
${WRKSRC}/win/Qt/qt_win.cpp
diff --git a/games/gracer/Makefile b/games/gracer/Makefile
index 903f87fb7c09..e0e190b8f8a7 100644
--- a/games/gracer/Makefile
+++ b/games/gracer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gracer
-# Date created: Fri Jul 30 20:50:16 MET DST 1999
-# Whom: nox@jelal.kn-bremen.de
-#
+# Created by: nox@jelal.kn-bremen.de
# $FreeBSD$
-#
PORTNAME= gracer
PORTVERSION= 0.1.5
@@ -36,7 +32,7 @@ MAN6= gracer.6
.include <bsd.port.pre.mk>
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -i '' -e 's|<malloc.h>|<stdlib.h>|' \
${WRKSRC}/common/gr_memory.h
.include <bsd.port.post.mk>