aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-05-31 02:05:23 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-05-31 02:05:23 +0800
commit117c63a5c43ab492fe0cb4908acd0d1b754a20de (patch)
tree9ef5773456087d3fa27323e592e5de509234344f /games
parent2b1ddfd980bbec4385a87f21dacf303e3899c93e (diff)
downloadfreebsd-ports-gnome-117c63a5c43ab492fe0cb4908acd0d1b754a20de.tar.gz
freebsd-ports-gnome-117c63a5c43ab492fe0cb4908acd0d1b754a20de.tar.zst
freebsd-ports-gnome-117c63a5c43ab492fe0cb4908acd0d1b754a20de.zip
- Trim Makefile header
- Fix build with clang
Diffstat (limited to 'games')
-rw-r--r--games/tecnoballz/Makefile6
-rw-r--r--games/tecnoballz/files/patch-include-surface_sdl.h11
2 files changed, 12 insertions, 5 deletions
diff --git a/games/tecnoballz/Makefile b/games/tecnoballz/Makefile
index 51b56afeed82..62fd3438fc2b 100644
--- a/games/tecnoballz/Makefile
+++ b/games/tecnoballz/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: TecnoballZ
-# Date created: 19 Jan 2005
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= tecnoballz
PORTVERSION= 0.92
diff --git a/games/tecnoballz/files/patch-include-surface_sdl.h b/games/tecnoballz/files/patch-include-surface_sdl.h
new file mode 100644
index 000000000000..f88b4644a4e9
--- /dev/null
+++ b/games/tecnoballz/files/patch-include-surface_sdl.h
@@ -0,0 +1,11 @@
+--- include/surface_sdl.h.orig 2013-05-30 22:00:54.478112221 +0400
++++ include/surface_sdl.h 2013-05-30 22:02:18.114218658 +0400
+@@ -46,7 +46,7 @@
+ ~surface_sdl ();
+ SDL_Surface* get_surface ();
+ char* get_pixel_data ();
+- char* get_pixel_data (Uint32 coord_x, Uint32 coord_x);
++ char* get_pixel_data (Uint32 coord_x, Uint32 coord_y);
+ Uint32 get_row_size ();
+ Uint32 get_offset (Uint32 xcoord, Uint32 ycoord);
+ void clear (Uint32 color = 0);