aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-09-14 09:14:54 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-09-14 09:14:54 +0800
commit12015dfd21645826c4e4963d3c79dfba07f4016b (patch)
tree04d63020640d902c373479e2c46416d589f892c3 /games
parent19e18c8ab9d9dc221e1b657fc3d16b534fceac38 (diff)
downloadfreebsd-ports-gnome-12015dfd21645826c4e4963d3c79dfba07f4016b.tar.gz
freebsd-ports-gnome-12015dfd21645826c4e4963d3c79dfba07f4016b.tar.zst
freebsd-ports-gnome-12015dfd21645826c4e4963d3c79dfba07f4016b.zip
Fix build with clang/libc++
Diffstat (limited to 'games')
-rw-r--r--games/openxcom/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/openxcom/Makefile b/games/openxcom/Makefile
index 02b305ec4b5c..fc6114386e82 100644
--- a/games/openxcom/Makefile
+++ b/games/openxcom/Makefile
@@ -23,7 +23,6 @@ GH_COMMIT= 5c8b540
USES= gmake pkgconfig
USE_SDL= sdl mixer image gfx
USE_GL= gl
-USE_GCC= yes
BUILD_WRKSRC= ${WRKSRC}/src
MAKEFILE= Makefile.simple
@@ -39,6 +38,10 @@ PORTDATA= *
.include <bsd.port.options.mk>
+.if ${OSVERSION} < 1000000
+USE_GCC= yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/pch.h \
${WRKSRC}/src/Engine/Surface.cpp