aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-04-24 15:35:40 +0800
committerak <ak@FreeBSD.org>2013-04-24 15:35:40 +0800
commit13feb6e9c86e3bbcaac393343b3b6a912b9372db (patch)
tree83aac97dcee746842718f1f34dfa58caca71df28 /games
parent4a8d53d2e0b671fee11a9ef2f3ba8f703817c908 (diff)
downloadfreebsd-ports-gnome-13feb6e9c86e3bbcaac393343b3b6a912b9372db.tar.gz
freebsd-ports-gnome-13feb6e9c86e3bbcaac393343b3b6a912b9372db.tar.zst
freebsd-ports-gnome-13feb6e9c86e3bbcaac393343b3b6a912b9372db.zip
- Convert USE_GETTEXT to USES (part 1)
Approved by: portmgr (bapt)
Diffstat (limited to 'games')
-rw-r--r--games/gnmm/Makefile3
-rw-r--r--games/gnomememoryblocks/Makefile3
-rw-r--r--games/gtetrinet/Makefile3
-rw-r--r--games/klavaro/Makefile3
-rw-r--r--games/monster-masher/Makefile3
-rw-r--r--games/plee-the-bear/Makefile3
-rw-r--r--games/poker-engine/Makefile3
-rw-r--r--games/sumwars/Makefile3
-rw-r--r--games/widelands/Makefile3
9 files changed, 9 insertions, 18 deletions
diff --git a/games/gnmm/Makefile b/games/gnmm/Makefile
index 9bda7a2b67a8..911be93c4ca1 100644
--- a/games/gnmm/Makefile
+++ b/games/gnmm/Makefile
@@ -11,10 +11,9 @@ DIST_SUBDIR= gnome
MAINTAINER= ports@FreeBSD.org
COMMENT= A "nine mens' morris" implementation for the GNOME Desktop Environment
-USE_GETTEXT= yes
USE_ICONV= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix gnomelibs gdkpixbuf
GNU_CONFIGURE= yes
diff --git a/games/gnomememoryblocks/Makefile b/games/gnomememoryblocks/Makefile
index da984245a057..8e7f57e7742e 100644
--- a/games/gnomememoryblocks/Makefile
+++ b/games/gnomememoryblocks/Makefile
@@ -11,8 +11,7 @@ DISTNAME= gnome-memblocks-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Memory Blocks game for GNOME
-USE_GETTEXT= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix gnomelibs gdkpixbuf
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
diff --git a/games/gtetrinet/Makefile b/games/gtetrinet/Makefile
index fe8b0a0f5fdf..6b8eb6d2d3d5 100644
--- a/games/gtetrinet/Makefile
+++ b/games/gtetrinet/Makefile
@@ -11,9 +11,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= ports@FreeBSD.org
COMMENT= Version of the popular TetriNET multiplayer Tetris clone
-USE_GETTEXT= yes
USE_BZIP2= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= esound gnomeprefix libgnomeui
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/klavaro/Makefile b/games/klavaro/Makefile
index 5fb726f4728a..7ea93b2e5337 100644
--- a/games/klavaro/Makefile
+++ b/games/klavaro/Makefile
@@ -22,10 +22,9 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
gtkdatabox:${PORTSDIR}/x11-toolkits/gtkdatabox \
xcb:${PORTSDIR}/x11/libxcb
-USES= pkgconfig
+USES= pkgconfig gettext
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
USE_ICONV= yes
USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xrandr xrender
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index 622bfed868b7..734ee1701705 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -17,10 +17,9 @@ LIB_DEPENDS= gnomecanvasmm-2.6:${PORTSDIR}/graphics/libgnomecanvasmm26 \
glademm-2.4:${PORTSDIR}/devel/libglademm24
USE_BZIP2= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack libgnome esound
USE_GMAKE= yes
-USE_GETTEXT= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lesd
diff --git a/games/plee-the-bear/Makefile b/games/plee-the-bear/Makefile
index 1157a49e3927..cea924f1f4bb 100644
--- a/games/plee-the-bear/Makefile
+++ b/games/plee-the-bear/Makefile
@@ -18,11 +18,10 @@ USE_GL= gl glu
WANT_GNOME= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
USE_GCC= 4.6+
-USES= cmake
+USES= cmake gettext
CMAKE_ARGS= -Dlibclaw_DIR="${LOCALBASE}/share/libclaw/cmake" \
-DBEAR_NO_EDITOR=YES
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index e5850340a64b..3e5faeb36dc9 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -22,9 +22,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig
+USES= pkgconfig gettext
USE_PYTHON= 2.5-2.7
-USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/games/sumwars/Makefile b/games/sumwars/Makefile
index 3dfcde165acf..96c9d67573fc 100644
--- a/games/sumwars/Makefile
+++ b/games/sumwars/Makefile
@@ -27,9 +27,8 @@ LIB_DEPENDS= CEGUIBase-0.7.9.0:${PORTSDIR}/graphics/cegui \
physfs.1:${PORTSDIR}/devel/physfs
USE_GMAKE= yes
-USES= cmake
+USES= cmake gettext
USE_GL= gl glu
-USE_GETTEXT= yes
USE_BZIP2= yes
INSTALLS_ICONS= yes
USE_LUA= 5.1
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index 31128f4ebe9c..82d880e95cb8 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
-USES= cmake:outsource
-USE_GETTEXT= yes
+USES= cmake:outsource gettext
CMAKE_ARGS= -DWL_INSTALL_PREFIX="${PREFIX}" \
-DWL_INSTALL_DATADIR="share/widelands" \
-DWL_INSTALL_BINDIR="bin" \