aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-01-12 04:05:34 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:22:46 +0800
commit249b23742855aed08af673490b2d707e55e72550 (patch)
tree8f069d9187ca454d021d4f55728e79e9b0b0711a /games
parent9edbe701e8278c13d123922235adb42004800518 (diff)
downloadfreebsd-ports-gnome-249b23742855aed08af673490b2d707e55e72550.tar.gz
freebsd-ports-gnome-249b23742855aed08af673490b2d707e55e72550.tar.zst
freebsd-ports-gnome-249b23742855aed08af673490b2d707e55e72550.zip
- Fix dependency on ncurses and respect it properly
Diffstat (limited to 'games')
-rw-r--r--games/ascii-invaders/Makefile6
-rw-r--r--games/ascii-invaders/files/patch-Makefile16
2 files changed, 22 insertions, 0 deletions
diff --git a/games/ascii-invaders/Makefile b/games/ascii-invaders/Makefile
index 02f4f2225d3e..17522774f395 100644
--- a/games/ascii-invaders/Makefile
+++ b/games/ascii-invaders/Makefile
@@ -4,6 +4,7 @@
PORTNAME= ascii-invaders
PORTVERSION= 1.0.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@@ -15,6 +16,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= macdice
+USES= ncurses
+
+CFLAGS+= -isystem${LOCALBASE}/include -isystem${NCURSESINC}
+LDFLAGS+= -L${NCURSESLIB} -ltinfo
+
PLIST_FILES= bin/ascii_invaders
do-install:
diff --git a/games/ascii-invaders/files/patch-Makefile b/games/ascii-invaders/files/patch-Makefile
new file mode 100644
index 000000000000..3e40e4999dad
--- /dev/null
+++ b/games/ascii-invaders/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile.orig 2016-12-09 02:53:39 UTC
++++ Makefile
+@@ -1,5 +1,5 @@
+ CFLAGS+=-Wall
+-LIBS=-lcurses
++LIBS= -lncurses
+
+ all: ascii_invaders
+
+@@ -7,5 +7,5 @@ clean:
+ rm -f invaders.o ascii_invaders
+
+ ascii_invaders: invaders.o
+- $(CC) $(CFLAGS) $(LIBS) invaders.o -o ascii_invaders
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LIBS) invaders.o -o ascii_invaders
+