aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-06-10 00:56:01 +0800
committermiwi <miwi@FreeBSD.org>2013-06-10 00:56:01 +0800
commit264bb4cc5e39dace07cfad743a3de0ea613e8282 (patch)
tree5d46596c66504e330c7d83892224abed7069682e /games
parent46b7cc751ddba158cd5a7c21719c282441797b81 (diff)
downloadfreebsd-ports-gnome-264bb4cc5e39dace07cfad743a3de0ea613e8282.tar.gz
freebsd-ports-gnome-264bb4cc5e39dace07cfad743a3de0ea613e8282.tar.zst
freebsd-ports-gnome-264bb4cc5e39dace07cfad743a3de0ea613e8282.zip
- Update to version 2.s764
PR: 179220 Submitted by: Ports Fury
Diffstat (limited to 'games')
-rw-r--r--games/qgo/Makefile49
-rw-r--r--games/qgo/distinfo4
-rw-r--r--games/qgo/files/patch-src::wavfile.c34
-rw-r--r--games/qgo/files/patch-src::wavplay.c30
-rw-r--r--games/qgo/files/patch-src__listviews.cpp11
-rw-r--r--games/qgo/files/patch-src__mainwin.cpp16
-rw-r--r--games/qgo/files/patch-src__mainwindow_settings.cpp17
-rw-r--r--games/qgo/files/patch-src__parser.cpp18
-rw-r--r--games/qgo/pkg-plist47
9 files changed, 58 insertions, 168 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
index 32b329b55ee9..bba995ad74c4 100644
--- a/games/qgo/Makefile
+++ b/games/qgo/Makefile
@@ -1,35 +1,42 @@
-# ex:ts=8
-# Ports collection makefile for: qgo
-# Date created: Mar 22, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= qgo
-PORTVERSION= 1.5.4.3
-PORTREVISION= 3
+PORTVERSION= 2.s764
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}-r${PORTVERSION:E}
+MASTER_SITES= DEBIAN
+DISTNAME= ${PORTNAME}_2~svn764.orig
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Go board and SGF editor written with the Qt library
+COMMENT= Go board and SGF editor written with the Qt library
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+WRKSRC= ${WRKDIR}/${PORTNAME}
-DEPRECATED= Depends on QT3; unmaintained
-EXPIRATION_DATE= 2013-07-01
+USE_BZIP2= yes
+USES= desktop-file-utils
+USE_QT4= gui network qtestlib moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
-USE_XORG= x11 ice xext
-USE_QT_VER= 3
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
+PLIST_FILES= bin/qgo share/applications/qgo.desktop share/pixmaps/qgo.png
+PLIST_DIRSTRY= share/applications
post-patch:
- @${REINPLACE_CMD} -e '/NOOPT/s|^CXXFLAGS=|#CXXFLAGS=|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
- 's|/usr/share|${PREFIX}/share|g' ${WRKSRC}/templates/*.desktop
+ '/Icon/s|=.*|=${PREFIX}/share/pixmaps/qgo.png| ; \
+ /^MimeType/s|=.*|=text/sgf|' ${WRKSRC}/src/qgo.desktop
+ @${REINPLACE_CMD} -e \
+ 's|debug|release|' ${WRKSRC}/src/src.pro
+ @${REINPLACE_CMD} -e \
+ 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/src/mainwindow_settings.cpp
+
+do-configure:
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
+
+do-install:
+ (cd ${WRKSRC}/bin && ${INSTALL_PROGRAM} qgo ${PREFIX}/bin)
+ @${MKDIR} ${DESKTOPDIR}
+ (cd ${WRKSRC}/src && ${INSTALL_DATA} qgo.desktop ${DESKTOPDIR})
+ (cd ${WRKSRC}/src/ressources/pics && ${INSTALL_DATA} qgo.png \
+ ${PREFIX}/share/pixmaps)
.include <bsd.port.mk>
diff --git a/games/qgo/distinfo b/games/qgo/distinfo
index c54a2048ce35..28ed2058ab4e 100644
--- a/games/qgo/distinfo
+++ b/games/qgo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qgo-1.5.4-r3.tar.gz) = ddfb66ada7027b844838895061f266bda03b327e8dfec2ee2782e14748bac104
-SIZE (qgo-1.5.4-r3.tar.gz) = 2490737
+SHA256 (qgo_2~svn764.orig.tar.bz2) = 07620bf2d08def7630aab69338ce345451d36e1c19acde649ec44be500102205
+SIZE (qgo_2~svn764.orig.tar.bz2) = 2491726
diff --git a/games/qgo/files/patch-src::wavfile.c b/games/qgo/files/patch-src::wavfile.c
deleted file mode 100644
index f8ccf8f33b34..000000000000
--- a/games/qgo/files/patch-src::wavfile.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/wavfile.c.orig Sun Oct 31 08:36:45 2004
-+++ src/wavfile.c Thu Dec 16 01:18:54 2004
-@@ -41,7 +41,7 @@
- * wavplay project.
- */
-
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
-
- static const char rcsid[] = "@(#)wavfile.c $Revision: 1.6 $";
-
-@@ -52,7 +52,9 @@
- #include <unistd.h>
- #include <errno.h>
- #include <fcntl.h>
-+#if defined(__linux__)
- #include <malloc.h>
-+#endif
- #include <string.h>
- #include <memory.h>
- #include <signal.h>
-@@ -60,7 +62,12 @@
- #include <sys/ipc.h>
- #include <sys/ioctl.h>
- #include <assert.h>
-+#if defined(__linux__)
- #include <linux/soundcard.h>
-+#endif
-+#if defined(__FreeBSD__)
-+#include <sys/soundcard.h>
-+#endif
-
-
-
diff --git a/games/qgo/files/patch-src::wavplay.c b/games/qgo/files/patch-src::wavplay.c
deleted file mode 100644
index ee2aade04373..000000000000
--- a/games/qgo/files/patch-src::wavplay.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/wavplay.c.orig Sun Oct 31 08:35:00 2004
-+++ src/wavplay.c Tue Dec 14 19:32:31 2004
-@@ -54,19 +54,26 @@
- *
- */
-
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
-
- static const char rcsid[] = "@(#)recplay.c $Revision: 1.8 $";
-
- #include <stdio.h>
- #include <stdarg.h>
- #include <stdlib.h>
-+#if defined(__linux__)
- #include <malloc.h>
-+#endif
- #include <string.h>
- #include <fcntl.h>
- #include <errno.h>
- #include <sys/stat.h>
-+#if defined(__linux__)
- #include <linux/soundcard.h>
-+#endif
-+#if defined(__FreeBSD__)
-+#include <sys/soundcard.h>
-+#endif
- #include "wavplay.h"
- /*/#include "server.h"*/
-
diff --git a/games/qgo/files/patch-src__listviews.cpp b/games/qgo/files/patch-src__listviews.cpp
new file mode 100644
index 000000000000..216799bad5cd
--- /dev/null
+++ b/games/qgo/files/patch-src__listviews.cpp
@@ -0,0 +1,11 @@
+--- src/listviews.cpp.orig
++++ src/listviews.cpp
+@@ -342,7 +342,7 @@
+ {
+ for(int i = 0; i < items.count(); i++)
+ {
+- GamesListItem * const item = static_cast<const GamesListItem *>(items[i]);
++ const GamesListItem * item = static_cast<const GamesListItem *>(items[i]);
+ if(item->getListing() == l)
+ {
+ /* Really this is supposed to be not QModelIndex() but the
diff --git a/games/qgo/files/patch-src__mainwin.cpp b/games/qgo/files/patch-src__mainwin.cpp
deleted file mode 100644
index b08df9f2238f..000000000000
--- a/games/qgo/files/patch-src__mainwin.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/mainwin.cpp.orig Mon Mar 27 06:37:41 2006
-+++ src/mainwin.cpp Wed Apr 12 13:36:58 2006
-@@ -1589,11 +1589,11 @@
- //set the params of "who command"
- if ((whoBox1->currentItem() >1) || (whoBox2->currentItem() >1))
- {
-- wparam.append(whoBox1->currentItem()==1 ? "9p" : whoBox1->currentText());
-+ wparam.append(whoBox1->currentItem()==1 ? QString("9p") : whoBox1->currentText());
- if ((whoBox1->currentItem()) && (whoBox2->currentItem()))
- wparam.append("-");
-
-- wparam.append(whoBox2->currentItem()==1 ? "9p" : whoBox2->currentText());
-+ wparam.append(whoBox2->currentItem()==1 ? QString("9p") : whoBox2->currentText());
- }
- else if ((whoBox1->currentItem()) || (whoBox2->currentItem()))
- wparam.append("1p-9p");
diff --git a/games/qgo/files/patch-src__mainwindow_settings.cpp b/games/qgo/files/patch-src__mainwindow_settings.cpp
new file mode 100644
index 000000000000..4d955d784579
--- /dev/null
+++ b/games/qgo/files/patch-src__mainwindow_settings.cpp
@@ -0,0 +1,17 @@
+--- src/mainwindow_settings.cpp.orig
++++ src/mainwindow_settings.cpp
+@@ -269,7 +269,13 @@
+ QVariant var;
+
+ ui.comboBox_language->setCurrentIndex (settings.value("LANGUAGE").toInt());
+- ui.LineEdit_computer->setText(settings.value("COMPUTER_PATH").toString());
++ QString computer_path = settings.value("COMPUTER_PATH").toString();
++ qDebug() << "COMPUTER_PATH" << computer_path;
++ if (computer_path == "") {
++ computer_path = "%%LOCALBASE%%/bin/gnugo";
++ settings.setValue("COMPUTER_PATH", computer_path);
++ }
++ ui.LineEdit_computer->setText(computer_path);
+ if(settings.value("COMPUTER_PLAYS_WHITE").toBool())
+ ui.computerPlaysWhite->setChecked(TRUE);
+ else
diff --git a/games/qgo/files/patch-src__parser.cpp b/games/qgo/files/patch-src__parser.cpp
deleted file mode 100644
index 808b76151330..000000000000
--- a/games/qgo/files/patch-src__parser.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/parser.cpp.orig Tue Dec 27 17:49:01 2005
-+++ src/parser.cpp Wed Jan 18 03:20:10 2006
-@@ -1176,13 +1176,13 @@
- {
- aGameInfo->wname = element(line, 1, ":","(");
- aGameInfo->wtime = (time1.toInt()==0 ? time2 : time1);
-- aGameInfo->wstones = (time1.toInt()==0 ?stones: "-1") ;
-+ aGameInfo->wstones = (time1.toInt()==0 ? stones : QString("-1")) ;
- }
- else if (line.contains("(B)"))
- {
- aGameInfo->bname = element(line, 1, ":","(");
- aGameInfo->btime = (time1.toInt()==0 ? time2 : time1);
-- aGameInfo->bstones = (time1.toInt()==0 ? stones:"-1") ;
-+ aGameInfo->bstones = (time1.toInt()==0 ? stones : QString("-1")) ;
- }
- else //never know with IGS ...
- return IT_OTHER;
diff --git a/games/qgo/pkg-plist b/games/qgo/pkg-plist
deleted file mode 100644
index 06268c1709b4..000000000000
--- a/games/qgo/pkg-plist
+++ /dev/null
@@ -1,47 +0,0 @@
-bin/qgo
-share/applnk/Games/qgo.desktop
-share/mimelnk/text/sgf.desktop
-share/qGo/pics/Bowl.png
-share/qGo/pics/barcelona_cherry.jpg
-share/qGo/pics/birch.jpg
-share/qGo/pics/eurobeech.jpg
-share/qGo/pics/goldenbeech.jpg
-share/qGo/pics/kaya.png
-share/qGo/pics/lemontree.jpg
-share/qGo/pics/manitoba.jpg
-share/qGo/pics/maple.jpg
-share/qGo/pics/plain.png
-share/qGo/pics/synthetic_1.png
-share/qGo/pics/synthetic_2.png
-share/qGo/sounds/click.wav
-share/qGo/sounds/connect.wav
-share/qGo/sounds/enter.wav
-share/qGo/sounds/gameend.wav
-share/qGo/sounds/leave.wav
-share/qGo/sounds/match.wav
-share/qGo/sounds/pass.wav
-share/qGo/sounds/say.wav
-share/qGo/sounds/stone.wav
-share/qGo/sounds/talk.wav
-share/qGo/sounds/tictoc.wav
-share/qGo/translations/qgo_cz.qm
-share/qGo/translations/qgo_de.qm
-share/qGo/translations/qgo_dk.qm
-share/qGo/translations/qgo_fr.qm
-share/qGo/translations/qgo_it.qm
-share/qGo/translations/qgo_la.qm
-share/qGo/translations/qgo_nl.qm
-share/qGo/translations/qgo_pl.qm
-share/qGo/translations/qgo_pt.qm
-share/qGo/translations/qgo_ru.qm
-share/qGo/translations/qgo_tr.qm
-share/qGo/translations/qgo_zh.qm
-share/qGo/translations/qgo_zh_cn.qm
-@dirrm share/qGo/translations
-@dirrm share/qGo/sounds
-@dirrm share/qGo/pics
-@dirrm share/qGo
-@dirrmtry share/mimelnk/text
-@dirrmtry share/mimelnk
-@dirrmtry share/applnk/Games
-@dirrmtry share/applnk