aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-08-03 05:38:09 +0800
committermat <mat@FreeBSD.org>2013-08-03 05:38:09 +0800
commit2705230b44322223d2223a1efa852bd2986be440 (patch)
tree6a21c7eedce3ab02121c1a526e479099181228ef /games
parentf47f83f9c8923b3b0f740482331aab0d0aa669e9 (diff)
downloadfreebsd-ports-gnome-2705230b44322223d2223a1efa852bd2986be440.tar.gz
freebsd-ports-gnome-2705230b44322223d2223a1efa852bd2986be440.tar.zst
freebsd-ports-gnome-2705230b44322223d2223a1efa852bd2986be440.zip
- Convert to new perl framework
- Trim Makefile header
Diffstat (limited to 'games')
-rw-r--r--games/p5-Algorithm-Pair-Swiss/Makefile9
-rw-r--r--games/p5-Games-AlphaBeta/Makefile9
2 files changed, 6 insertions, 12 deletions
diff --git a/games/p5-Algorithm-Pair-Swiss/Makefile b/games/p5-Algorithm-Pair-Swiss/Makefile
index bd8401256653..bb56231de9c9 100644
--- a/games/p5-Algorithm-Pair-Swiss/Makefile
+++ b/games/p5-Algorithm-Pair-Swiss/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Algorithm-Pair-Swiss
-# Date created: 12 Jun 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Algorithm-Pair-Swiss
PORTVERSION= 0.14
@@ -18,6 +14,7 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
MAN3= Algorithm::Pair::Swiss.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/games/p5-Games-AlphaBeta/Makefile b/games/p5-Games-AlphaBeta/Makefile
index 46f54e80ec8e..920da704e490 100644
--- a/games/p5-Games-AlphaBeta/Makefile
+++ b/games/p5-Games-AlphaBeta/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Games-AlphaBeta
-# Date created: 27 July 2005
-# Whom: Aaron Dalton <aaron@daltons.ca>
-#
+# Created by: Aaron Dalton <aaron@daltons.ca>
# $FreeBSD$
-#
PORTNAME= Games-AlphaBeta
PORTVERSION= 0.4.7
@@ -15,7 +11,8 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Game-tree search with object oriented interface
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= othello-demo.1
MAN3= Games::AlphaBeta.3 Games::AlphaBeta::Position.3 \