aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-10-06 20:13:26 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-10-06 20:13:26 +0800
commit277137ea6335593067f0b9c1d6e8ad8e845b1a46 (patch)
treed88485cc6e1e44f6b6285cb5cd76f2c61eeca30e /games
parent754da8b8c1c57e2a16f963c69b95cd93b7ed4c3f (diff)
downloadfreebsd-ports-gnome-277137ea6335593067f0b9c1d6e8ad8e845b1a46.tar.gz
freebsd-ports-gnome-277137ea6335593067f0b9c1d6e8ad8e845b1a46.tar.zst
freebsd-ports-gnome-277137ea6335593067f0b9c1d6e8ad8e845b1a46.zip
Pachi el marciano is a platforms game inspired by games like Manic Miner and
Jet Set Willy from the legend Mathew Smith. The goal of the game is to collect all the objects of each level, when this is made, the exit gate to the next stage will appear and you can pass trough. Pachi is a comic character created by Nicolas Radeff in 2001. PR: 86845 Submitted by: Dmitry Marakasov <amdmi3@mail.ru> Approved by: novel (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/pachi/Makefile55
-rw-r--r--games/pachi/distinfo2
-rw-r--r--games/pachi/pkg-descr11
-rw-r--r--games/pachi/pkg-install16
-rw-r--r--games/pachi/pkg-plist68
6 files changed, 153 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 7bd63b9fb678..75be1b5ad26e 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -401,6 +401,7 @@
SUBDIR += p5-Games-Bingo-Print
SUBDIR += p5-Games-Dice
SUBDIR += p5-Games-Sequential
+ SUBDIR += pachi
SUBDIR += pathological
SUBDIR += pcgen
SUBDIR += pengpong
diff --git a/games/pachi/Makefile b/games/pachi/Makefile
new file mode 100644
index 000000000000..4b91310d416a
--- /dev/null
+++ b/games/pachi/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: pachi
+# Date created: 18 Sep 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pachi
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dragontech
+DISTNAME= pachi_source
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A platforms game similar to Manic Miner
+
+USE_SDL= mixer sdl
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}" CXX="${CXX}"
+
+WRKSRC= ${WRKDIR}/Pachi
+
+SCOREDIR= /var/games/pachi
+SCOREFILE= ${SCOREDIR}/scores.dat
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/src/faes.cpp
+ @${REINPLACE_CMD} -e 's|/var/lib/games/$$PACKAGE|${SCOREDIR}|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|SCOREDIR[^,]*|"${SCOREFILE}"|' \
+ ${WRKSRC}/src/file.c
+ @${REINPLACE_CMD} -e 's|:\ install-docDATA|:|' \
+ ${WRKSRC}/docs/Makefile.in
+ @${REINPLACE_CMD} -e 's|install-scoreDATA\ install-data-local||' \
+ ${WRKSRC}/data/Makefile.in
+
+post-install:
+ ${CHGRP} games ${PREFIX}/bin/pachi
+ ${CHMOD} g+s ${PREFIX}/bin/pachi
+ ${MKDIR} ${SCOREDIR}
+.if !exists(${SCOREFILE})
+ ${INSTALL_DATA} ${WRKSRC}/data/scores.dat /var/games/pachi
+.endif
+ ${CHGRP} -R games ${SCOREDIR}
+ ${CHMOD} g+w ${SCOREFILE}
+
+.include <bsd.port.mk>
diff --git a/games/pachi/distinfo b/games/pachi/distinfo
new file mode 100644
index 000000000000..35281b14975f
--- /dev/null
+++ b/games/pachi/distinfo
@@ -0,0 +1,2 @@
+MD5 (pachi_source.tgz) = 64906110d6236adc15c81910b43a1ae9
+SIZE (pachi_source.tgz) = 3215871
diff --git a/games/pachi/pkg-descr b/games/pachi/pkg-descr
new file mode 100644
index 000000000000..9b6f6e0ae6f3
--- /dev/null
+++ b/games/pachi/pkg-descr
@@ -0,0 +1,11 @@
+Pachi el marciano is a platforms game inspired by games like Manic Miner and
+Jet Set Willy from the legend Mathew Smith.
+
+The goal of the game is to collect all the objects of each level, when this is
+made, the exit gate to the next stage will appear and you can pass trough.
+
+Pachi is a comic character created by Nicolas Radeff in 2001.
+
+WWW: http://dragontech.sourceforge.net/
+
+- Dmitry Marakasov <amdmi3@mail.ru>
diff --git a/games/pachi/pkg-install b/games/pachi/pkg-install
new file mode 100644
index 000000000000..b98908372032
--- /dev/null
+++ b/games/pachi/pkg-install
@@ -0,0 +1,16 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+SCOREDIR="/var/games/pachi"
+SCOREFILE="/var/games/pachi/scores.dat"
+
+[ "$2" != "POST-INSTALL" -o -f "$SCOREFILE" ] && exit 0
+
+echo "Creating hiscore file..."
+mkdir -p "$SCOREDIR"
+
+# Empty scorefile seem to contain 170 zero bytes
+truncate -s 170 "$SCOREFILE"
+chgrp -R games "$SCOREDIR"
+chmod g+w "$SCOREFILE"
diff --git a/games/pachi/pkg-plist b/games/pachi/pkg-plist
new file mode 100644
index 000000000000..9b4377328e29
--- /dev/null
+++ b/games/pachi/pkg-plist
@@ -0,0 +1,68 @@
+bin/pachi
+%%DATADIR%%/Tgfx/backgrounds.T8
+%%DATADIR%%/Tgfx/bright.T8
+%%DATADIR%%/Tgfx/castle.T8
+%%DATADIR%%/Tgfx/cave.T8
+%%DATADIR%%/Tgfx/cemetery.T8
+%%DATADIR%%/Tgfx/comic_01.T8
+%%DATADIR%%/Tgfx/comic_02.T8
+%%DATADIR%%/Tgfx/comic_03.T8
+%%DATADIR%%/Tgfx/comic_04.T8
+%%DATADIR%%/Tgfx/comic_05.T8
+%%DATADIR%%/Tgfx/comic_06.T8
+%%DATADIR%%/Tgfx/comic_07.T8
+%%DATADIR%%/Tgfx/comic_08.T8
+%%DATADIR%%/Tgfx/comic_09.T8
+%%DATADIR%%/Tgfx/comic_10.T8
+%%DATADIR%%/Tgfx/comic_11.T8
+%%DATADIR%%/Tgfx/comic_12.T8
+%%DATADIR%%/Tgfx/comic_13.T8
+%%DATADIR%%/Tgfx/comic_14.T8
+%%DATADIR%%/Tgfx/dragontech.T8
+%%DATADIR%%/Tgfx/endcredits.T8
+%%DATADIR%%/Tgfx/gameover.T8
+%%DATADIR%%/Tgfx/gamepanel.T8
+%%DATADIR%%/Tgfx/help.T8
+%%DATADIR%%/Tgfx/icon.bmp
+%%DATADIR%%/Tgfx/intro.T8
+%%DATADIR%%/Tgfx/lab.T8
+%%DATADIR%%/Tgfx/left.T8
+%%DATADIR%%/Tgfx/line1.T8
+%%DATADIR%%/Tgfx/line2.T8
+%%DATADIR%%/Tgfx/monsters.T8
+%%DATADIR%%/Tgfx/pachi.T8
+%%DATADIR%%/Tgfx/right.T8
+%%DATADIR%%/Tgfx/tiles.T8
+%%DATADIR%%/data/backs.dat
+%%DATADIR%%/data/monsters.dat
+%%DATADIR%%/data/objects_v2.dat
+%%DATADIR%%/data/rooms_v2.dat
+%%DATADIR%%/fonts/font1.T8
+%%DATADIR%%/fonts/font16a.T
+%%DATADIR%%/fonts/font16b.T
+%%DATADIR%%/fonts/font16c.T
+%%DATADIR%%/fonts/font16d.T
+%%DATADIR%%/fonts/font32r.T8
+%%DATADIR%%/fonts/font32v.T8
+%%DATADIR%%/music/credits.s3m
+%%DATADIR%%/music/menu.s3m
+%%DATADIR%%/music/stage1.s3m
+%%DATADIR%%/music/stage2.stm
+%%DATADIR%%/music/stage3.s3m
+%%DATADIR%%/music/stage4.s3m
+%%DATADIR%%/sounds/die.wav
+%%DATADIR%%/sounds/exit.wav
+%%DATADIR%%/sounds/jump.wav
+%%DATADIR%%/sounds/obj.wav
+%%DATADIR%%/sounds/objseq.wav
+%%DATADIR%%/sounds/option.wav
+%%DATADIR%%/sounds/respawn.wav
+%%DATADIR%%/sounds/stageready.wav
+%%DATADIR%%/sounds/storm.wav
+%%DATADIR%%/sounds/timer.wav
+@dirrm %%DATADIR%%/Tgfx
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%