aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2011-03-24 01:43:16 +0800
committerdhn <dhn@FreeBSD.org>2011-03-24 01:43:16 +0800
commit27dba8d4b8f55481591588c2ae053dc4b7c227b9 (patch)
tree9f5f5cdb9125e7a46757cae69db452351e1d1beb /games
parent77edb71ca9dc4868d1d33f2d884b3cce24aaaa62 (diff)
downloadfreebsd-ports-gnome-27dba8d4b8f55481591588c2ae053dc4b7c227b9.tar.gz
freebsd-ports-gnome-27dba8d4b8f55481591588c2ae053dc4b7c227b9.tar.zst
freebsd-ports-gnome-27dba8d4b8f55481591588c2ae053dc4b7c227b9.zip
- Update to 0.138
PR: ports/155810 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'games')
-rw-r--r--games/poker-eval/Makefile9
-rw-r--r--games/poker-eval/distinfo5
-rw-r--r--games/poker-eval/files/patch-config-ltmain.sh15
-rw-r--r--games/poker-eval/pkg-descr2
-rw-r--r--games/poker-eval/pkg-plist5
-rw-r--r--games/py-poker-eval/Makefile21
-rw-r--r--games/py-poker-eval/distinfo4
-rw-r--r--games/py-poker-eval/files/patch-Makefile.am26
-rw-r--r--games/py-poker-eval/files/patch-config-ltmain.sh15
-rw-r--r--games/py-poker-eval/files/patch-config__ccpython.m421
-rw-r--r--games/py-poker-eval/pkg-descr2
-rw-r--r--games/py-poker-eval/pkg-plist1
12 files changed, 72 insertions, 54 deletions
diff --git a/games/poker-eval/Makefile b/games/poker-eval/Makefile
index a5c07aa83608..a58f87a51aea 100644
--- a/games/poker-eval/Makefile
+++ b/games/poker-eval/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= poker-eval
-PORTVERSION= 0.136
+PORTVERSION= 0.138
CATEGORIES= games
MASTER_SITES= http://download.gna.org/pokersource/sources/
DISTNAME= ${PORTNAME}-${PORTVERSION:E}.0
@@ -15,11 +15,14 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:E}.0
MAINTAINER= ports@FreeBSD.org
COMMENT= A C library to evaluate poker hands
-USE_GNOME= gnometarget
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
-CONFIGURE_ENV= MD5SUM=${MD5}
+USE_GNOME= pkgconfig
USE_GMAKE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/games/poker-eval/distinfo b/games/poker-eval/distinfo
index 7e15ec2a1e13..36241dc4e13c 100644
--- a/games/poker-eval/distinfo
+++ b/games/poker-eval/distinfo
@@ -1,3 +1,2 @@
-MD5 (poker-eval-136.0.tar.gz) = 7707f88e5ff93dcdb4c14d6f1a7a825c
-SHA256 (poker-eval-136.0.tar.gz) = dd0e442297ee5ffb7de99c3d8b055555f5744bc35116efb0e3fb36a9fd4c30d9
-SIZE (poker-eval-136.0.tar.gz) = 458915
+SHA256 (poker-eval-138.0.tar.gz) = 92659e4a90f6856ebd768bad942e9894bd70122dab56f3b23dd2c4c61bdbcf68
+SIZE (poker-eval-138.0.tar.gz) = 470224
diff --git a/games/poker-eval/files/patch-config-ltmain.sh b/games/poker-eval/files/patch-config-ltmain.sh
deleted file mode 100644
index dcba9b0700af..000000000000
--- a/games/poker-eval/files/patch-config-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/ltmain.sh.orig 2009-09-08 00:56:30.722444585 +0800
-+++ config/ltmain.sh 2009-09-08 00:57:14.609940717 +0800
-@@ -2077,10 +2077,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- func_basename "$file"
- name="$func_basename_result"
- instname="$dir/$name"i
- func_show_eval "$install_prog $instname $destdir/$name" 'exit $?'
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/games/poker-eval/pkg-descr b/games/poker-eval/pkg-descr
index dda668dddd26..a11f5c93711c 100644
--- a/games/poker-eval/pkg-descr
+++ b/games/poker-eval/pkg-descr
@@ -6,4 +6,4 @@ holdem, omaha, etc.) and more can be added. poker-eval is designed
for speed so that it can be used within poker simulation software
using either exhaustive exploration or Monte Carlo.
-WWW: http://www.pokersource.org/poker-eval.php
+WWW: http://www.pokersource.info/wiki/poker-eval
diff --git a/games/poker-eval/pkg-plist b/games/poker-eval/pkg-plist
index 6615f6ff25b2..d054ed01a9b0 100644
--- a/games/poker-eval/pkg-plist
+++ b/games/poker-eval/pkg-plist
@@ -35,9 +35,10 @@ include/poker-eval/rules_astud.h
include/poker-eval/rules_joker.h
include/poker-eval/rules_std.h
include/poker-eval/rules_undef.h
-@dirrm include/poker-eval/inlines
-@dirrm include/poker-eval
lib/libpoker-eval.a
+lib/libpoker-eval.la
lib/libpoker-eval.so
lib/libpoker-eval.so.1
libdata/pkgconfig/poker-eval.pc
+@dirrm include/poker-eval/inlines
+@dirrm include/poker-eval
diff --git a/games/py-poker-eval/Makefile b/games/py-poker-eval/Makefile
index 819bcac36fce..4f168dfabc80 100644
--- a/games/py-poker-eval/Makefile
+++ b/games/py-poker-eval/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= poker-eval
-PORTVERSION= 0.137
-PORTREVISION= 1
+PORTVERSION= 0.138
CATEGORIES= games python
MASTER_SITES= http://download.gna.org/pokersource/sources/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,20 +18,18 @@ COMMENT= Python adaptor for the poker-eval toolkit
LIB_DEPENDS= poker-eval.1:${PORTSDIR}/games/poker-eval
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_GNOME= pkgconfig
-USE_PYTHON= 2.5-2.6
-GNU_CONFIGURE= yes
+USE_PYTHON= 2.5-2.7
+USE_AUTOTOOLS= aclocal autoconf automake libtool
+ACLOCAL_ARGS= -I config
+CONFIGURE_ARGS= PYTHON=""
+MAKE_JOBS_SAFE= yes
PLIST_SUB= PYVER=${_PYTHON_VERSION:S/./_/}
-do-configure:
- @cd ${CONFIGURE_WRKSRC} && ./${CONFIGURE_SCRIPT}
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|{libdir}/pkgconfig|(prefix)/libdata/pkgconfig|g' \
- ${WRKSRC}/Makefile.in
-
test:
@cd ${WRKSRC} && ${MAKE} check
diff --git a/games/py-poker-eval/distinfo b/games/py-poker-eval/distinfo
index ee011fd6a91d..7f1b368cbedf 100644
--- a/games/py-poker-eval/distinfo
+++ b/games/py-poker-eval/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pypoker-eval-137.0.tar.gz) = b3f95a59a7e6f9e332473dd79ec57046919a4e8f07be8252504b2b05b24d5ad6
-SIZE (pypoker-eval-137.0.tar.gz) = 338195
+SHA256 (pypoker-eval-138.0.tar.gz) = 6db002a3ecfb220a74bcbc86ebb19caa7ae479554391d2fa1f0ac89308e93493
+SIZE (pypoker-eval-138.0.tar.gz) = 344958
diff --git a/games/py-poker-eval/files/patch-Makefile.am b/games/py-poker-eval/files/patch-Makefile.am
new file mode 100644
index 000000000000..fa26c192a91a
--- /dev/null
+++ b/games/py-poker-eval/files/patch-Makefile.am
@@ -0,0 +1,26 @@
+--- Makefile.am.orig 2008-12-03 04:04:51.000000000 +0900
++++ Makefile.am 2011-03-19 05:18:20.000000000 +0900
+@@ -32,6 +32,14 @@
+ python_PYTHON = \
+ pokereval.py
+
++if PYTHON_2_7
++py2_7exec_LTLIBRARIES = _pokereval_2_7.la
++_pokereval_2_7_la_SOURCES = pypokereval.c
++_pokereval_2_7_la_LDFLAGS = -module -no-undefined -version-info 1:0:0
++_pokereval_2_7_la_LIBADD = ${PYTHON2_7_LIBS} ${POKER_EVAL_LIBS}
++_pokereval_2_7_la_CFLAGS = ${PYTHON2_7_CFLAGS} ${POKER_EVAL_CFLAGS} -DPYTHON_VERSION=\"2_7\" -D'VERSION_NAME(w)=w\#\#2_7'
++endif
++
+ if PYTHON_2_6
+ py2_6exec_LTLIBRARIES = _pokereval_2_6.la
+ _pokereval_2_6_la_SOURCES = pypokereval.c
+@@ -64,7 +72,7 @@
+ _pokereval_2_3_la_CFLAGS = ${PYTHON2_3_CFLAGS} ${POKER_EVAL_CFLAGS} -DPYTHON_VERSION=\"2_3\" -D'VERSION_NAME(w)=w\#\#2_3'
+ endif
+
+-pkgconfigdir = ${libdir}/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = pypoker-eval.pc
+
+ EXTRA_DIST = config/python.m4 config/ccpython.m4 \
diff --git a/games/py-poker-eval/files/patch-config-ltmain.sh b/games/py-poker-eval/files/patch-config-ltmain.sh
deleted file mode 100644
index 348682462a3b..000000000000
--- a/games/py-poker-eval/files/patch-config-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/ltmain.sh.orig 2009-09-08 01:06:40.961772193 +0800
-+++ config/ltmain.sh 2009-09-08 01:06:54.440767557 +0800
-@@ -2077,10 +2077,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- func_basename "$file"
- name="$func_basename_result"
- instname="$dir/$name"i
- func_show_eval "$install_prog $instname $destdir/$name" 'exit $?'
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/games/py-poker-eval/files/patch-config__ccpython.m4 b/games/py-poker-eval/files/patch-config__ccpython.m4
new file mode 100644
index 000000000000..f0581ea8f6f9
--- /dev/null
+++ b/games/py-poker-eval/files/patch-config__ccpython.m4
@@ -0,0 +1,21 @@
+--- config/ccpython.m4.orig 2008-12-26 05:49:24.000000000 +0900
++++ config/ccpython.m4 2011-03-19 04:41:14.000000000 +0900
+@@ -110,7 +110,7 @@
+
+ AC_DEFUN([ALL_CC_PYTHON],
+ [
+-m4_define([_AM_PYTHON_INTERPRETER_LIST], [python2.6 python2.5 python2.4 python2.3])
++m4_define([_AM_PYTHON_INTERPRETER_LIST], [python2.7 python2.6 python2.5 python2.4 python2.3])
+ PYTHONS=''
+ found_one=''
+ _ONE_CC_PYTHON([=2.3], [2_3])
+@@ -124,6 +124,9 @@
+ unset PYTHON
+ _ONE_CC_PYTHON([=2.6], [2_6])
+ if test -f "$PYTHON" ; then found_one=$PYTHON ; PYTHONS="$PYTHON $PYTHONS" ; fi
++unset PYTHON
++_ONE_CC_PYTHON([=2.7], [2_7])
++if test -f "$PYTHON" ; then found_one=$PYTHON ; PYTHONS="$PYTHON $PYTHONS" ; fi
+ PYTHON=$found_one
+ if ! test "$found_one" ; then
+ AC_MSG_ERROR([No python development environments found])
diff --git a/games/py-poker-eval/pkg-descr b/games/py-poker-eval/pkg-descr
index 01129de47211..e47c5bc2ccf4 100644
--- a/games/py-poker-eval/pkg-descr
+++ b/games/py-poker-eval/pkg-descr
@@ -5,4 +5,4 @@ somewhat simpler than the C API of poker-eval. It assumes that the
caller is willing to have a higher level API and is not interested in
a one to one mapping of the poker-eval API.
-WWW: http://www.pokersource.org/pypoker-eval.php
+WWW: http://www.pokersource.info/wiki/pypoker-eval
diff --git a/games/py-poker-eval/pkg-plist b/games/py-poker-eval/pkg-plist
index 104c0f8526bd..16bb80e626df 100644
--- a/games/py-poker-eval/pkg-plist
+++ b/games/py-poker-eval/pkg-plist
@@ -1,4 +1,5 @@
%%PYTHON_SITELIBDIR%%/_pokereval_%%PYVER%%.a
+%%PYTHON_SITELIBDIR%%/_pokereval_%%PYVER%%.la
%%PYTHON_SITELIBDIR%%/_pokereval_%%PYVER%%.so
%%PYTHON_SITELIBDIR%%/_pokereval_%%PYVER%%.so.1
%%PYTHON_SITELIBDIR%%/pokereval.py