aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-09-21 19:06:03 +0800
committerdinoex <dinoex@FreeBSD.org>2013-09-21 19:06:03 +0800
commit2b046d64117ade41e336404023c6f8150293fc4a (patch)
tree2051ba0023bbf060fa37051dc7fc6990710a53b1 /games
parenta68540824c2afc9f423babe69b1494598b151be9 (diff)
downloadfreebsd-ports-gnome-2b046d64117ade41e336404023c6f8150293fc4a.tar.gz
freebsd-ports-gnome-2b046d64117ade41e336404023c6f8150293fc4a.tar.zst
freebsd-ports-gnome-2b046d64117ade41e336404023c6f8150293fc4a.zip
- fix misplaced NO_STAGE in slaveports and ifdefs
Diffstat (limited to 'games')
-rw-r--r--games/xboing/Makefile3
-rw-r--r--games/xinfocom/Makefile6
-rw-r--r--games/xneko/Makefile3
-rw-r--r--games/xrubik/Makefile5
-rw-r--r--games/xscrabble/Makefile3
-rw-r--r--games/xzip/Makefile6
6 files changed, 15 insertions, 11 deletions
diff --git a/games/xboing/Makefile b/games/xboing/Makefile
index f67f4fc88cc4..c4c29aee16d0 100644
--- a/games/xboing/Makefile
+++ b/games/xboing/Makefile
@@ -14,6 +14,8 @@ COMMENT= X11 arcade game
LICENSE= MIT
+NO_STAGE= yes
+
USES= imake
USE_XORG= xpm xext x11
WRKSRC= ${WRKDIR}/xboing
@@ -26,7 +28,6 @@ PLIST_SUB+= WITH_SOUND="@comment "
PLIST_SUB+= WITH_SOUND=""
.endif
-NO_STAGE= yes
post-install:
${CHOWN} root:games ${PREFIX}/bin/xboing
${CHMOD} 2755 ${PREFIX}/bin/xboing
diff --git a/games/xinfocom/Makefile b/games/xinfocom/Makefile
index 18a46476b9ce..186901bd04ae 100644
--- a/games/xinfocom/Makefile
+++ b/games/xinfocom/Makefile
@@ -14,11 +14,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= dinoex@FreeBSD.org
COMMENT= An Infocom game interpreter for X11
-PLIST_FILES= bin/xinfocom
-WRKSRC= ${WRKDIR}/xinfocom
+NO_STAGE= yes
USES= imake
USE_XORG= xt sm ice xext x11
+WRKSRC= ${WRKDIR}/xinfocom
+PLIST_FILES= bin/xinfocom
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/xneko/Makefile b/games/xneko/Makefile
index da1c1dd207a7..ffbfb79ad9b3 100644
--- a/games/xneko/Makefile
+++ b/games/xneko/Makefile
@@ -13,11 +13,12 @@ DISTNAME= ${PORTNAME}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= The classic cat-and-mouse
+NO_STAGE= yes
+
NO_WRKSUBDIR= yes
USES= imake
USE_XORG= x11
MAN6= xneko.6
PLIST_FILES= bin/xneko
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/xrubik/Makefile b/games/xrubik/Makefile
index fd2610844631..6b544c859cf0 100644
--- a/games/xrubik/Makefile
+++ b/games/xrubik/Makefile
@@ -11,14 +11,15 @@ MASTER_SITE_SUBDIR= games/xpuzzles
MAINTAINER= dinoex@FreeBSD.org
COMMENT= X-based rubik's cube(tm)
+NO_STAGE= yes
+
WRKSRC= ${WRKDIR}/xrubik
USES= imake
USE_XORG= xt sm ice xext x11
-MAN1= xrubik.1
XFREE86_HTML_MAN= no
NO_INSTALL_MANPAGES= yes
+MAN1= xrubik.1
-NO_STAGE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xrubik ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/Rubik.ad ${PREFIX}/lib/X11/app-defaults/Rubik
diff --git a/games/xscrabble/Makefile b/games/xscrabble/Makefile
index 933acc099713..769a22d883d4 100644
--- a/games/xscrabble/Makefile
+++ b/games/xscrabble/Makefile
@@ -11,6 +11,8 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}_en${EXTRACT_SUFX}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= X version of the popular board game
+NO_STAGE= yes
+
USES= imake
USE_BZIP2= yes
USE_XORG= xaw
@@ -18,7 +20,6 @@ NO_INSTALL_MANPAGES= yes
XSCRABBLEDIR= ${PREFIX}/lib/X11/xscrabble
-NO_STAGE= yes
post-patch:
@${ECHO_CMD} '#define VERSION ${PORTVERSION:S/.//g}' \
> ${WRKSRC}/src/config.h
diff --git a/games/xzip/Makefile b/games/xzip/Makefile
index 04ca2757e631..855a76e16a37 100644
--- a/games/xzip/Makefile
+++ b/games/xzip/Makefile
@@ -14,13 +14,13 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= dinoex@FreeBSD.org
COMMENT= An Infocom game interpreter that runs under X11
-WRKSRC= ${WRKDIR}/xzip
-ALL_TARGET=
+NO_STAGE= yes
USE_XORG= x11
+WRKSRC= ${WRKDIR}/xzip
+ALL_TARGET=
MAN1= xzip.1
PLIST_FILES= bin/xzip
-NO_STAGE= yes
.include <bsd.port.mk>