aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-12-26 07:41:52 +0800
committerrakuco <rakuco@FreeBSD.org>2016-12-26 07:41:52 +0800
commit315368967301f4c8bc1c69e8b9d16793df979199 (patch)
treec7ae2126ef9c7bb68626abbeea96f7a68d4a5b15 /games
parent02716dc00f0e3dacebfbd46ea1d5ef5613d248eb (diff)
downloadfreebsd-ports-gnome-315368967301f4c8bc1c69e8b9d16793df979199.tar.gz
freebsd-ports-gnome-315368967301f4c8bc1c69e8b9d16793df979199.tar.zst
freebsd-ports-gnome-315368967301f4c8bc1c69e8b9d16793df979199.zip
Set ALL_TARGET instead of defining a post-build target
Instead of manually invoking some make targets in post-build, use the ALL_TARGET variable, which is cleaner and reduces the size of the Makefile. PR: 215548 Approved by: m.tsatsenko@gmail.com (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/ufoai/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 30004547782e..4b8f82f66e74 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= libvorbis.so:audio/libvorbis \
BUILD_DEPENDS= zip:archivers/zip
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/base/default.cfg:games/ufoai-data
+ALL_TARGET= all lang
USE_GL= yes
USE_SDL= sdl image mixer ttf
USE_CXXSTD= c++11
@@ -66,6 +67,7 @@ PLIST_SUB+= UFO2MAP="@comment "
.endif
.if ${PORT_OPTIONS:MUFORADIANT}
+ALL_TARGET+= uforadiant
CONFIGURE_ARGS+=--enable-uforadiant
USE_GNOME+= gtk20 glib20 gtksourceview2 libxml2
LIB_DEPENDS+= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext
@@ -95,12 +97,6 @@ post-extract:
${WRKSRC}/build/modes/release.mk
.endif
-post-build:
- @cd ${WRKSRC} && ${MAKE_CMD} lang
-.if ${PORT_OPTIONS:MUFORADIANT}
- @cd ${WRKSRC} && ${MAKE_CMD} uforadiant
-.endif
-
do-install:
${MKDIR} ${STAGEDIR}${UFO_DIR}
.for FILE in ${UFO_FILES}