aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2018-01-19 20:25:34 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:26:17 +0800
commit33a78c90d79dd09bf0a40693b64ec89808922688 (patch)
tree868486124cd237118934443d28f5f016c25ba607 /games
parent5bd94f6055c44d6f3dfd8746d09828bdc176a0cb (diff)
downloadfreebsd-ports-gnome-33a78c90d79dd09bf0a40693b64ec89808922688.tar.gz
freebsd-ports-gnome-33a78c90d79dd09bf0a40693b64ec89808922688.tar.zst
freebsd-ports-gnome-33a78c90d79dd09bf0a40693b64ec89808922688.zip
- Update netpaanzer to 0.8.7
- Fix build with clang 6 - Convert to PLIST_FILES - Regenerate patches
Diffstat (limited to 'games')
-rw-r--r--games/netpanzer/Makefile31
-rw-r--r--games/netpanzer/distinfo5
-rw-r--r--games/netpanzer/files/patch-SConstruct20
-rw-r--r--games/netpanzer/files/patch-src_Lib_ArrayUtil_QueueTemplate.hpp11
-rw-r--r--games/netpanzer/files/patch-src_Lib_Network_Address.hpp6
-rw-r--r--games/netpanzer/files/patch-src_Lib_Network_SocketBase.cpp11
-rw-r--r--games/netpanzer/files/patch-src_Lib_optionmm_command__line.hpp (renamed from games/netpanzer/files/patch-src_Lib_optionmm_command_line.hpp)6
-rw-r--r--games/netpanzer/pkg-plist5
8 files changed, 49 insertions, 46 deletions
diff --git a/games/netpanzer/Makefile b/games/netpanzer/Makefile
index 4200b3a058a5..4d4e912cb0e0 100644
--- a/games/netpanzer/Makefile
+++ b/games/netpanzer/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= netpanzer
-PORTVERSION= 0.8.4
-PORTREVISION= 4
+PORTVERSION= 0.8.7
+DISTVERSIONSUFFIX= -source
CATEGORIES= games
-MASTER_SITES= LOCAL/madpilot/netpanzer
+MASTER_SITES= http://www.netpanzer.info/Download/NetPanzer/Releases/${PORTVERSION}/
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Real time, isometric view, tank multiplayer strategy game
@@ -14,11 +14,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LDFLAGS+= -lpthreads
-USES= scons tar:bzip2
+USES= scons zip
USE_SDL= sdl mixer image
USE_GNOME= libxml2
-SCONS_ARGS+= datadir="${DATADIR}"
-SCONS_BUILDENV= ${SCONS_ENV}
+MAKE_ARGS+= datadir="${DATADIR}"
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/netpanzer \
+ share/applications/netpanzer.desktop \
+ share/pixmaps/netpanzer.png \
+ share/pixmaps/netpanzer.xpm
PORTDOCS= *
PORTDATA= *
@@ -29,13 +34,15 @@ post-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/netpanzer ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "cache maps pics powerups scripts sound units wads" ${STAGEDIR}${DATADIR})
- ${INSTALL_MAN} ${WRKSRC}/docs/netpanzer.6 ${STAGEDIR}${MANPREFIX}/man/man6
- ${INSTALL_DATA} ${WRKSRC}/netpanzer.desktop ${STAGEDIR}${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/netpanzer.png ${WRKSRC}/netpanzer.xpm ${STAGEDIR}${PREFIX}/share/pixmaps
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "cache maps pics powerups scripts sound units wads" \
+ ${STAGEDIR}${DATADIR})
+ ${INSTALL_DATA} ${WRKSRC}/support/win32/netpanzer.desktop ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/netpanzer.png ${WRKSRC}/support/icon/netpanzer.xpm \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} COPYING ChangeLog README RELNOTES TODO ${STAGEDIR}${DOCSDIR})
- (cd ${WRKSRC}/docs && ${INSTALL_DATA} Doxyfile code-notes.txt coding.txt serverhowto.html tipofday.txt ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC} && ${INSTALL_DATA} COPYING README ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC}/docs && ${INSTALL_DATA} code-notes.txt coding.txt old/serverhowto.html \
+ ${STAGEDIR}${DOCSDIR})
do-fetch-svn:
svn export svn://svn.berlios.de/${PORTNAME}/tags/${PORTNAME}/${PORTVERSION} ${PORTNAME}-${PORTVERSION}
diff --git a/games/netpanzer/distinfo b/games/netpanzer/distinfo
index 037452969dfc..0b7f77bf3ba1 100644
--- a/games/netpanzer/distinfo
+++ b/games/netpanzer/distinfo
@@ -1,2 +1,3 @@
-SHA256 (netpanzer-0.8.4.tar.bz2) = 96ee69fbe0f84cd46647e35f0983c9ef8869ad2f2b9e244a82d34d8ea6279712
-SIZE (netpanzer-0.8.4.tar.bz2) = 11731818
+TIMESTAMP = 1516265645
+SHA256 (netpanzer-0.8.7-source.zip) = 90e2b78d43cc32fb3f6af027788162dc9d272941f9630b43fc34f203a55c86a7
+SIZE (netpanzer-0.8.7-source.zip) = 13466285
diff --git a/games/netpanzer/files/patch-SConstruct b/games/netpanzer/files/patch-SConstruct
index 5e2f83c7bced..a4bf784e5ad8 100644
--- a/games/netpanzer/files/patch-SConstruct
+++ b/games/netpanzer/files/patch-SConstruct
@@ -1,19 +1,19 @@
---- SConstruct.orig 2011-12-22 19:32:06.000000000 +0100
-+++ SConstruct 2012-04-24 23:49:38.000000000 +0200
-@@ -69,7 +69,7 @@
- ('crossmingwsdlconfig','sets the sdl-config full path for mingw cross compiler', 'sdl-config')
+--- SConstruct.orig 2016-04-09 13:14:00 UTC
++++ SConstruct
+@@ -95,7 +95,7 @@ opts.AddVariables(
+ ('compilerprefix', 'sets the prefix for the cross linux compiler, example: i686-pc-linux-gnu-', ''),
)
-env = Environment(ENV = os.environ, options = opts)
+env = Environment(ENV = os.environ, options = opts, CC = os.environ['CC'], CXX = os.environ['CXX'])
Help(opts.GenerateHelpText(env))
- ################################################################
-@@ -240,6 +240,7 @@
- SetupSpawn(env)
+ env.Append( CCFLAGS = [ '-DPACKAGE_VERSION=\\"' + NPVERSION + '\\"' ] )
+@@ -202,6 +202,7 @@ elif thisplatform == 'win32':
else:
+ networkenv.ParseConfig(env['sdlconfig'] + ' --cflags --libs')
env.ParseConfig(env['sdlconfig'] + ' --cflags --libs')
+ env.Append( _LIBFLAGS = [ '-L%%LOCALBASE%%/lib' ] )
- env.Append( NPLIBS = [ 'SDL_mixer' ] )
-
- # for crossmingw platform
+ # note: for some magic reason, now doesn't need to put the full path for
+ # SDL_mixer when using mingw crosscompilation
+ env.Append( LIBS = ['SDL_mixer' ] )
diff --git a/games/netpanzer/files/patch-src_Lib_ArrayUtil_QueueTemplate.hpp b/games/netpanzer/files/patch-src_Lib_ArrayUtil_QueueTemplate.hpp
deleted file mode 100644
index 4063a78da49b..000000000000
--- a/games/netpanzer/files/patch-src_Lib_ArrayUtil_QueueTemplate.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Lib/ArrayUtil/QueueTemplate.hpp.orig 2012-04-24 23:51:05.000000000 +0200
-+++ src/Lib/ArrayUtil/QueueTemplate.hpp 2012-04-24 23:51:15.000000000 +0200
-@@ -42,7 +42,7 @@
-
- bool enqueue(const TYPE& object )
- {
-- add( object, (rear + 1) % this->size );
-+ this->add( object, (rear + 1) % this->size );
- rear = (rear + 1) % this->size;
-
- if ( front == rear )
diff --git a/games/netpanzer/files/patch-src_Lib_Network_Address.hpp b/games/netpanzer/files/patch-src_Lib_Network_Address.hpp
index 28e7e1810bcc..64e303d095ca 100644
--- a/games/netpanzer/files/patch-src_Lib_Network_Address.hpp
+++ b/games/netpanzer/files/patch-src_Lib_Network_Address.hpp
@@ -1,6 +1,6 @@
---- src/Lib/Network/Address.hpp.orig 2010-01-19 17:08:17.000000000 +0100
-+++ src/Lib/Network/Address.hpp 2012-04-20 17:34:26.306480287 +0200
-@@ -47,7 +47,7 @@
+--- src/Lib/Network/Address.hpp.orig 2016-04-09 13:14:00 UTC
++++ src/Lib/Network/Address.hpp
+@@ -62,7 +62,7 @@ class Address (public)
struct sockaddr * getSockaddr() const { return (struct sockaddr *)&ss; };
socklen_t getSockaddrLen() const
{
diff --git a/games/netpanzer/files/patch-src_Lib_Network_SocketBase.cpp b/games/netpanzer/files/patch-src_Lib_Network_SocketBase.cpp
new file mode 100644
index 000000000000..e73e49b5f30d
--- /dev/null
+++ b/games/netpanzer/files/patch-src_Lib_Network_SocketBase.cpp
@@ -0,0 +1,11 @@
+--- src/Lib/Network/SocketBase.cpp.orig 2016-04-09 13:14:00 UTC
++++ src/Lib/Network/SocketBase.cpp
+@@ -147,7 +147,7 @@ SocketBase::bindSocketTo(const Address& toaddr) throw(
+ {
+ if ( state == CONFIGURED )
+ {
+- int res = bind(sockfd, toaddr.getSockaddr(), toaddr.getSockaddrLen());
++ int res = ::bind(sockfd, toaddr.getSockaddr(), toaddr.getSockaddrLen());
+ if(res == SOCKET_ERROR) {
+ lastError = GET_NET_ERROR();
+ doClose();
diff --git a/games/netpanzer/files/patch-src_Lib_optionmm_command_line.hpp b/games/netpanzer/files/patch-src_Lib_optionmm_command__line.hpp
index f61f3f3041c5..f3fd7b704651 100644
--- a/games/netpanzer/files/patch-src_Lib_optionmm_command_line.hpp
+++ b/games/netpanzer/files/patch-src_Lib_optionmm_command__line.hpp
@@ -1,6 +1,6 @@
---- src/Lib/optionmm/command_line.hpp.orig 2013-09-27 10:31:25.000000000 +0200
-+++ src/Lib/optionmm/command_line.hpp 2013-09-27 10:38:10.000000000 +0200
-@@ -212,7 +212,13 @@
+--- src/Lib/optionmm/command_line.hpp.orig 2007-04-16 13:36:42 UTC
++++ src/Lib/optionmm/command_line.hpp
+@@ -212,7 +212,13 @@ struct toggle_value<bool>
{
x = !x;
}
diff --git a/games/netpanzer/pkg-plist b/games/netpanzer/pkg-plist
deleted file mode 100644
index 60ed8d0115e0..000000000000
--- a/games/netpanzer/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/netpanzer
-man/man6/netpanzer.6.gz
-share/applications/netpanzer.desktop
-share/pixmaps/netpanzer.png
-share/pixmaps/netpanzer.xpm