aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-01-11 19:15:28 +0800
committerjylefort <jylefort@FreeBSD.org>2006-01-11 19:15:28 +0800
commit380e45ac88a81778dccd9366fc4ac7b134c7cc78 (patch)
tree9cb40bc767fb0668e58dbbd5cbc786c15bb30ba6 /games
parentc07896713c1e38579f15addec67fa35fb36199d0 (diff)
downloadfreebsd-ports-gnome-380e45ac88a81778dccd9366fc4ac7b134c7cc78.tar.gz
freebsd-ports-gnome-380e45ac88a81778dccd9366fc4ac7b134c7cc78.tar.zst
freebsd-ports-gnome-380e45ac88a81778dccd9366fc4ac7b134c7cc78.zip
Add glpuzzle.
glpuzzle is a jigsaw puzzle game. Choose from 12 puzzles of various difficulties (4 to 25 pieces), and move the pieces around to create the desired picture. glpuzzle uses OpenGL for smooth movement and anti-aliased display. WWW: http://www.iua.upf.es/~mdeboer/resorama/glpuzzle/ PR: ports/91619 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/glpuzzle/Makefile49
-rw-r--r--games/glpuzzle/distinfo3
-rw-r--r--games/glpuzzle/files/patch-Makefile10
-rw-r--r--games/glpuzzle/files/patch-main.cxx10
-rw-r--r--games/glpuzzle/pkg-descr6
-rw-r--r--games/glpuzzle/pkg-plist49
-rw-r--r--games/jigzo/Makefile49
-rw-r--r--games/jigzo/distinfo3
-rw-r--r--games/jigzo/files/patch-Makefile10
-rw-r--r--games/jigzo/files/patch-main.cxx10
-rw-r--r--games/jigzo/pkg-descr6
-rw-r--r--games/jigzo/pkg-plist49
13 files changed, 255 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 3061df0d701b..4cad4428c366 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -213,6 +213,7 @@
SUBDIR += glife
SUBDIR += glmaze
SUBDIR += glob2
+ SUBDIR += glpuzzle
SUBDIR += gltron
SUBDIR += gma
SUBDIR += gnarr
diff --git a/games/glpuzzle/Makefile b/games/glpuzzle/Makefile
new file mode 100644
index 000000000000..293e26abc01e
--- /dev/null
+++ b/games/glpuzzle/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: glpuzzle
+# Date created: 09 Jan 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glpuzzle
+PORTVERSION= 0.1.2
+CATEGORIES= games
+MASTER_SITES= http://www.iua.upf.es/~mdeboer/resorama/glpuzzle/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= An OpenGL jigsaw puzzle game
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_X_PREFIX= yes
+USE_SDL= sdl
+USE_GL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+MAKE_ENV= CXX="${CXX}" \
+ CPPFLAGS="`${SDL_CONFIG} --cflags` -I${X11BASE}/include" \
+ LDFLAGS="`${SDL_CONFIG} --libs` -L${X11BASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|font/|${DATADIR}/font/|g" ${WRKSRC}/main.cxx
+ @${REINPLACE_CMD} -e "s|puzzle-preview/|${DATADIR}/puzzle-preview/|g" ${WRKSRC}/main.cxx
+ @${REINPLACE_CMD} -e "s|puzzle-maps/|${DATADIR}/puzzle-maps/|g" ${WRKSRC}/puzzle-preview/preview.map
+ @${RM} -f ${WRKSRC}/puzzle-preview/preview.map.bak
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/glpuzzle ${PREFIX}/bin
+.for i in font puzzle-maps puzzle-preview
+ ${MKDIR} ${DATADIR}/${i}
+ ${INSTALL_DATA} ${WRKSRC}/${i}/* ${DATADIR}/${i}
+.endfor
+
+.ifndef (NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/glpuzzle/distinfo b/games/glpuzzle/distinfo
new file mode 100644
index 000000000000..161e75cbd107
--- /dev/null
+++ b/games/glpuzzle/distinfo
@@ -0,0 +1,3 @@
+MD5 (glpuzzle-0.1.2.tgz) = dda33d2b77a00b39bd3240cd65710d77
+SHA256 (glpuzzle-0.1.2.tgz) = 1dde2a5fefeb957358697d49054ef8043e7d7d0486b672647ccaa9a7ca3922c7
+SIZE (glpuzzle-0.1.2.tgz) = 3207022
diff --git a/games/glpuzzle/files/patch-Makefile b/games/glpuzzle/files/patch-Makefile
new file mode 100644
index 000000000000..4f5102491711
--- /dev/null
+++ b/games/glpuzzle/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig Mon Jan 9 03:32:53 2006
++++ Makefile Tue Jan 10 02:57:36 2006
+@@ -23,6 +23,6 @@
+ chmod +x $(PREFIX)/bin/glpuzzle
+
+ glpuzzle: main.cxx version.h
+- g++ -O2 -Wall -I/usr/include/SDL main.cxx -lpthread -lSDL -lGL -lpthread -lpng -ljpeg -o glpuzzle
++ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) -lGL -lpng -ljpeg -o glpuzzle main.cxx
+
+
diff --git a/games/glpuzzle/files/patch-main.cxx b/games/glpuzzle/files/patch-main.cxx
new file mode 100644
index 000000000000..8228e5a919fc
--- /dev/null
+++ b/games/glpuzzle/files/patch-main.cxx
@@ -0,0 +1,10 @@
+--- main.cxx.orig Wed Jan 11 04:42:54 2006
++++ main.cxx Wed Jan 11 04:43:04 2006
+@@ -24,6 +24,7 @@
+ *
+ */
+
++#include <unistd.h>
+ #include <cstdio>
+ #include <cstdlib>
+ #include <cstring>
diff --git a/games/glpuzzle/pkg-descr b/games/glpuzzle/pkg-descr
new file mode 100644
index 000000000000..0fc18050cd52
--- /dev/null
+++ b/games/glpuzzle/pkg-descr
@@ -0,0 +1,6 @@
+glpuzzle is a jigsaw puzzle game. Choose from 12 puzzles of various
+difficulties (4 to 25 pieces), and move the pieces around to create
+the desired picture. glpuzzle uses OpenGL for smooth movement and
+anti-aliased display.
+
+WWW: http://www.iua.upf.es/~mdeboer/resorama/glpuzzle/
diff --git a/games/glpuzzle/pkg-plist b/games/glpuzzle/pkg-plist
new file mode 100644
index 000000000000..2d255b24b1ae
--- /dev/null
+++ b/games/glpuzzle/pkg-plist
@@ -0,0 +1,49 @@
+bin/glpuzzle
+%%DATADIR%%/font/charmap.jpg
+%%DATADIR%%/font/charmap.map
+%%DATADIR%%/font/charmap.png
+%%DATADIR%%/puzzle-maps/bike-3x4.jpg
+%%DATADIR%%/puzzle-maps/bike-3x4.map
+%%DATADIR%%/puzzle-maps/bike-3x4.png
+%%DATADIR%%/puzzle-maps/bird-4x4.jpg
+%%DATADIR%%/puzzle-maps/bird-4x4.map
+%%DATADIR%%/puzzle-maps/bird-4x4.png
+%%DATADIR%%/puzzle-maps/blackberry-3x3.jpg
+%%DATADIR%%/puzzle-maps/blackberry-3x3.map
+%%DATADIR%%/puzzle-maps/blackberry-3x3.png
+%%DATADIR%%/puzzle-maps/castle-6x3.jpg
+%%DATADIR%%/puzzle-maps/castle-6x3.map
+%%DATADIR%%/puzzle-maps/castle-6x3.png
+%%DATADIR%%/puzzle-maps/clouds-4x4.jpg
+%%DATADIR%%/puzzle-maps/clouds-4x4.map
+%%DATADIR%%/puzzle-maps/clouds-4x4.png
+%%DATADIR%%/puzzle-maps/goat-4x3.jpg
+%%DATADIR%%/puzzle-maps/goat-4x3.map
+%%DATADIR%%/puzzle-maps/goat-4x3.png
+%%DATADIR%%/puzzle-maps/gorilla-4x3.jpg
+%%DATADIR%%/puzzle-maps/gorilla-4x3.map
+%%DATADIR%%/puzzle-maps/gorilla-4x3.png
+%%DATADIR%%/puzzle-maps/heli-4x3.jpg
+%%DATADIR%%/puzzle-maps/heli-4x3.map
+%%DATADIR%%/puzzle-maps/heli-4x3.png
+%%DATADIR%%/puzzle-maps/horse-4x3.jpg
+%%DATADIR%%/puzzle-maps/horse-4x3.map
+%%DATADIR%%/puzzle-maps/horse-4x3.png
+%%DATADIR%%/puzzle-maps/penguin-3x2.jpg
+%%DATADIR%%/puzzle-maps/penguin-3x2.map
+%%DATADIR%%/puzzle-maps/penguin-3x2.png
+%%DATADIR%%/puzzle-maps/penguins-5x5.jpg
+%%DATADIR%%/puzzle-maps/penguins-5x5.map
+%%DATADIR%%/puzzle-maps/penguins-5x5.png
+%%DATADIR%%/puzzle-maps/train-2x2.jpg
+%%DATADIR%%/puzzle-maps/train-2x2.map
+%%DATADIR%%/puzzle-maps/train-2x2.png
+%%DATADIR%%/puzzle-preview/preview.jpg
+%%DATADIR%%/puzzle-preview/preview.map
+%%DATADIR%%/puzzle-preview/preview.png
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/puzzle-preview
+@dirrm %%DATADIR%%/puzzle-maps
+@dirrm %%DATADIR%%/font
+@dirrm %%DATADIR%%
diff --git a/games/jigzo/Makefile b/games/jigzo/Makefile
new file mode 100644
index 000000000000..293e26abc01e
--- /dev/null
+++ b/games/jigzo/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: glpuzzle
+# Date created: 09 Jan 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glpuzzle
+PORTVERSION= 0.1.2
+CATEGORIES= games
+MASTER_SITES= http://www.iua.upf.es/~mdeboer/resorama/glpuzzle/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= An OpenGL jigsaw puzzle game
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_X_PREFIX= yes
+USE_SDL= sdl
+USE_GL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+MAKE_ENV= CXX="${CXX}" \
+ CPPFLAGS="`${SDL_CONFIG} --cflags` -I${X11BASE}/include" \
+ LDFLAGS="`${SDL_CONFIG} --libs` -L${X11BASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|font/|${DATADIR}/font/|g" ${WRKSRC}/main.cxx
+ @${REINPLACE_CMD} -e "s|puzzle-preview/|${DATADIR}/puzzle-preview/|g" ${WRKSRC}/main.cxx
+ @${REINPLACE_CMD} -e "s|puzzle-maps/|${DATADIR}/puzzle-maps/|g" ${WRKSRC}/puzzle-preview/preview.map
+ @${RM} -f ${WRKSRC}/puzzle-preview/preview.map.bak
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/glpuzzle ${PREFIX}/bin
+.for i in font puzzle-maps puzzle-preview
+ ${MKDIR} ${DATADIR}/${i}
+ ${INSTALL_DATA} ${WRKSRC}/${i}/* ${DATADIR}/${i}
+.endfor
+
+.ifndef (NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/jigzo/distinfo b/games/jigzo/distinfo
new file mode 100644
index 000000000000..161e75cbd107
--- /dev/null
+++ b/games/jigzo/distinfo
@@ -0,0 +1,3 @@
+MD5 (glpuzzle-0.1.2.tgz) = dda33d2b77a00b39bd3240cd65710d77
+SHA256 (glpuzzle-0.1.2.tgz) = 1dde2a5fefeb957358697d49054ef8043e7d7d0486b672647ccaa9a7ca3922c7
+SIZE (glpuzzle-0.1.2.tgz) = 3207022
diff --git a/games/jigzo/files/patch-Makefile b/games/jigzo/files/patch-Makefile
new file mode 100644
index 000000000000..4f5102491711
--- /dev/null
+++ b/games/jigzo/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig Mon Jan 9 03:32:53 2006
++++ Makefile Tue Jan 10 02:57:36 2006
+@@ -23,6 +23,6 @@
+ chmod +x $(PREFIX)/bin/glpuzzle
+
+ glpuzzle: main.cxx version.h
+- g++ -O2 -Wall -I/usr/include/SDL main.cxx -lpthread -lSDL -lGL -lpthread -lpng -ljpeg -o glpuzzle
++ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) -lGL -lpng -ljpeg -o glpuzzle main.cxx
+
+
diff --git a/games/jigzo/files/patch-main.cxx b/games/jigzo/files/patch-main.cxx
new file mode 100644
index 000000000000..8228e5a919fc
--- /dev/null
+++ b/games/jigzo/files/patch-main.cxx
@@ -0,0 +1,10 @@
+--- main.cxx.orig Wed Jan 11 04:42:54 2006
++++ main.cxx Wed Jan 11 04:43:04 2006
+@@ -24,6 +24,7 @@
+ *
+ */
+
++#include <unistd.h>
+ #include <cstdio>
+ #include <cstdlib>
+ #include <cstring>
diff --git a/games/jigzo/pkg-descr b/games/jigzo/pkg-descr
new file mode 100644
index 000000000000..0fc18050cd52
--- /dev/null
+++ b/games/jigzo/pkg-descr
@@ -0,0 +1,6 @@
+glpuzzle is a jigsaw puzzle game. Choose from 12 puzzles of various
+difficulties (4 to 25 pieces), and move the pieces around to create
+the desired picture. glpuzzle uses OpenGL for smooth movement and
+anti-aliased display.
+
+WWW: http://www.iua.upf.es/~mdeboer/resorama/glpuzzle/
diff --git a/games/jigzo/pkg-plist b/games/jigzo/pkg-plist
new file mode 100644
index 000000000000..2d255b24b1ae
--- /dev/null
+++ b/games/jigzo/pkg-plist
@@ -0,0 +1,49 @@
+bin/glpuzzle
+%%DATADIR%%/font/charmap.jpg
+%%DATADIR%%/font/charmap.map
+%%DATADIR%%/font/charmap.png
+%%DATADIR%%/puzzle-maps/bike-3x4.jpg
+%%DATADIR%%/puzzle-maps/bike-3x4.map
+%%DATADIR%%/puzzle-maps/bike-3x4.png
+%%DATADIR%%/puzzle-maps/bird-4x4.jpg
+%%DATADIR%%/puzzle-maps/bird-4x4.map
+%%DATADIR%%/puzzle-maps/bird-4x4.png
+%%DATADIR%%/puzzle-maps/blackberry-3x3.jpg
+%%DATADIR%%/puzzle-maps/blackberry-3x3.map
+%%DATADIR%%/puzzle-maps/blackberry-3x3.png
+%%DATADIR%%/puzzle-maps/castle-6x3.jpg
+%%DATADIR%%/puzzle-maps/castle-6x3.map
+%%DATADIR%%/puzzle-maps/castle-6x3.png
+%%DATADIR%%/puzzle-maps/clouds-4x4.jpg
+%%DATADIR%%/puzzle-maps/clouds-4x4.map
+%%DATADIR%%/puzzle-maps/clouds-4x4.png
+%%DATADIR%%/puzzle-maps/goat-4x3.jpg
+%%DATADIR%%/puzzle-maps/goat-4x3.map
+%%DATADIR%%/puzzle-maps/goat-4x3.png
+%%DATADIR%%/puzzle-maps/gorilla-4x3.jpg
+%%DATADIR%%/puzzle-maps/gorilla-4x3.map
+%%DATADIR%%/puzzle-maps/gorilla-4x3.png
+%%DATADIR%%/puzzle-maps/heli-4x3.jpg
+%%DATADIR%%/puzzle-maps/heli-4x3.map
+%%DATADIR%%/puzzle-maps/heli-4x3.png
+%%DATADIR%%/puzzle-maps/horse-4x3.jpg
+%%DATADIR%%/puzzle-maps/horse-4x3.map
+%%DATADIR%%/puzzle-maps/horse-4x3.png
+%%DATADIR%%/puzzle-maps/penguin-3x2.jpg
+%%DATADIR%%/puzzle-maps/penguin-3x2.map
+%%DATADIR%%/puzzle-maps/penguin-3x2.png
+%%DATADIR%%/puzzle-maps/penguins-5x5.jpg
+%%DATADIR%%/puzzle-maps/penguins-5x5.map
+%%DATADIR%%/puzzle-maps/penguins-5x5.png
+%%DATADIR%%/puzzle-maps/train-2x2.jpg
+%%DATADIR%%/puzzle-maps/train-2x2.map
+%%DATADIR%%/puzzle-maps/train-2x2.png
+%%DATADIR%%/puzzle-preview/preview.jpg
+%%DATADIR%%/puzzle-preview/preview.map
+%%DATADIR%%/puzzle-preview/preview.png
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/puzzle-preview
+@dirrm %%DATADIR%%/puzzle-maps
+@dirrm %%DATADIR%%/font
+@dirrm %%DATADIR%%