aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-09-19 02:34:14 +0800
committerpawel <pawel@FreeBSD.org>2011-09-19 02:34:14 +0800
commit436ff869764d183f547ff6d5de0fd2425fb1c677 (patch)
tree3cd068afb0704672edaead007c5fd6b09eeddc40 /games
parent827f0a904821bb77d037457a6127288d62ded7cb (diff)
downloadfreebsd-ports-gnome-436ff869764d183f547ff6d5de0fd2425fb1c677.tar.gz
freebsd-ports-gnome-436ff869764d183f547ff6d5de0fd2425fb1c677.tar.zst
freebsd-ports-gnome-436ff869764d183f547ff6d5de0fd2425fb1c677.zip
Add desktop entries for individual games
Approved by: miwi, wen (mentors implicit)
Diffstat (limited to 'games')
-rw-r--r--games/alephone-data/Makefile6
-rw-r--r--games/alephone-scenarios/Makefile14
2 files changed, 20 insertions, 0 deletions
diff --git a/games/alephone-data/Makefile b/games/alephone-data/Makefile
index 95cb49df3ead..2f439575b291 100644
--- a/games/alephone-data/Makefile
+++ b/games/alephone-data/Makefile
@@ -38,6 +38,8 @@ DATADIR!= cd ${PORTSDIR}/games/alephone && ${MAKE} -V DATADIR
DISTFILES+= M1A1${EXTRACT_SUFX}
PLIST_SUB+= MARATHON=""
AO_PACKS+= marathon
+DESKTOP_ENTRIES+="Marathon" "" "" "alephone-marathon" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= MARATHON="@comment "
.endif
@@ -46,6 +48,8 @@ PLIST_SUB+= MARATHON="@comment "
DISTFILES+= Marathon2${EXTRACT_SUFX}
PLIST_SUB+= DURANDAL=""
AO_PACKS+= durandal
+DESKTOP_ENTRIES+="Marathon 2: Durandal" "" "" "alephone-durandal" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= DURANDAL="@comment "
.endif
@@ -54,6 +58,8 @@ PLIST_SUB+= DURANDAL="@comment "
DISTFILES+= MarathonInfinity${EXTRACT_SUFX}
PLIST_SUB+= INFINITY=""
AO_PACKS+= infinity
+DESKTOP_ENTRIES+="Marathon Infinity" "" "" "alephone-infinity" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= INFINITY="@comment "
.endif
diff --git a/games/alephone-scenarios/Makefile b/games/alephone-scenarios/Makefile
index 1a4a439df5e4..52d2dda95918 100644
--- a/games/alephone-scenarios/Makefile
+++ b/games/alephone-scenarios/Makefile
@@ -49,6 +49,8 @@ EMR_FILE= emr-3.0-0602.tgz
DISTFILES+= ${EMR_FILE}:emr
PLIST_SUB+= EMR=""
AO_PACKS+= emr
+DESKTOP_ENTRIES+="Excalibur: Morgana's Revenge" "" "" "alephone-emr" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= EMR="@comment "
.endif
@@ -58,6 +60,8 @@ DISTFILES+= EternalXv103Full${EXTRACT_SUFX}:eternal
EXTRACT_ONLY+= EternalXv103Full${EXTRACT_SUFX}
PLIST_SUB+= ETERNAL=""
AO_PACKS+= eternal
+DESKTOP_ENTRIES+="Eternal X" "" "" "alephone-eternal" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= ETERNAL="@comment "
.endif
@@ -67,6 +71,8 @@ DISTFILES+= MarathonEvil${EXTRACT_SUFX}:bungie
EXTRACT_ONLY+= MarathonEvil${EXTRACT_SUFX}
PLIST_SUB+= EVIL=""
AO_PACKS+= evil
+DESKTOP_ENTRIES+="Evil" "" "" "alephone-evil" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= EVIL="@comment "
.endif
@@ -76,6 +82,8 @@ DISTFILES+= MarathonRED${EXTRACT_SUFX}:bungie
EXTRACT_ONLY+= MarathonRED${EXTRACT_SUFX}
PLIST_SUB+= RED=""
AO_PACKS+= red
+DESKTOP_ENTRIES+="Marathon Red" "" "" "alephone-red" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= RED="@comment "
.endif
@@ -85,6 +93,8 @@ DISTFILES+= marathonRubiconX${EXTRACT_SUFX}:rubicon
EXTRACT_ONLY+= marathonRubiconX${EXTRACT_SUFX}
PLIST_SUB+= RUBICON=""
AO_PACKS+= rubicon
+DESKTOP_ENTRIES+="Rubicon X" "" "" "alephone-rubicon" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= RUBICON="@comment "
.endif
@@ -94,6 +104,8 @@ DISTFILES+= Tempus_Irae${EXTRACT_SUFX}:nardofiles
EXTRACT_ONLY+= Tempus_Irae${EXTRACT_SUFX}
PLIST_SUB+= TI=""
AO_PACKS+= tempus_irae
+DESKTOP_ENTRIES+="Tempus Irae" "" "" "alephone-tempus_irae" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= TI="@comment "
.endif
@@ -103,6 +115,8 @@ DISTFILES+= tgi${EXTRACT_SUFX}:gray
EXTRACT_ONLY+= tgi${EXTRACT_SUFX}
PLIST_SUB+= GRAY=""
AO_PACKS+= gray
+DESKTOP_ENTRIES+="The Gray Incident" "" "" "alephone-gray" \
+ "Game;ActionGame;" false
.else
PLIST_SUB+= GRAY="@comment "
.endif