aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-03 02:21:05 +0800
committeraz <az@FreeBSD.org>2013-08-03 02:21:05 +0800
commit4539b36e07dc5d3a00796c31225b2da419544ef0 (patch)
tree59a0148ef943ecb5bc12a830cc669c801d3c91f8 /games
parenta7f25a26617517dba99672639956e265390f576a (diff)
downloadfreebsd-ports-gnome-4539b36e07dc5d3a00796c31225b2da419544ef0.tar.gz
freebsd-ports-gnome-4539b36e07dc5d3a00796c31225b2da419544ef0.tar.zst
freebsd-ports-gnome-4539b36e07dc5d3a00796c31225b2da419544ef0.zip
- Convert to new perl framework
Diffstat (limited to 'games')
-rw-r--r--games/lm-solve/Makefile3
-rw-r--r--games/p5-Algorithm-Pair-Best/Makefile3
-rw-r--r--games/p5-Games-GuessWord/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/games/lm-solve/Makefile b/games/lm-solve/Makefile
index 80b840e87065..773ba1e9e759 100644
--- a/games/lm-solve/Makefile
+++ b/games/lm-solve/Makefile
@@ -16,7 +16,8 @@ DISTNAME= Games-LMSolve-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Computerized Solver for Logic Mazes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= lm-solve.1
MAN3= Games::LMSolve.3 Games::LMSolve::Base.3 Games::LMSolve::Input.3 \
diff --git a/games/p5-Algorithm-Pair-Best/Makefile b/games/p5-Algorithm-Pair-Best/Makefile
index 5acd4fec98e4..6c5715e0371f 100644
--- a/games/p5-Algorithm-Pair-Best/Makefile
+++ b/games/p5-Algorithm-Pair-Best/Makefile
@@ -16,7 +16,8 @@ COMMENT= Perl module to generate tournament pairings
DEPRECATED= Use games/p5-Algorithm-Pair-Best2 instead
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Algorithm::Pair::Best.3
diff --git a/games/p5-Games-GuessWord/Makefile b/games/p5-Games-GuessWord/Makefile
index 944250788da4..bb5c15e8908f 100644
--- a/games/p5-Games-GuessWord/Makefile
+++ b/games/p5-Games-GuessWord/Makefile
@@ -16,6 +16,7 @@ COMMENT= Guess the letters in a word (ie Hangman)
MAN3= Games::GuessWord.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>