aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
committerpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
commit4682c2c61dcb7a63ae78f7c087ba5d0bda84f154 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /games
parent31dd4fd824aafa89c7f4eb95e23f32974c053110 (diff)
downloadfreebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.gz
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.zst
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.zip
Convert my ports to current standards
- Switch USE_GMAKE to USES=gmake - Define supported options so users can see them in config dialogs - Use OPTIONS_SUB for plist alteration - Convert to options macros for better readability - Use PORTDOCS where it makes sense
Diffstat (limited to 'games')
-rw-r--r--games/gigalomania/Makefile2
-rw-r--r--games/quackle/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/games/gigalomania/Makefile b/games/gigalomania/Makefile
index 67247e2de92e..9adf2992a9e6 100644
--- a/games/gigalomania/Makefile
+++ b/games/gigalomania/Makefile
@@ -15,6 +15,8 @@ USE_SDL= image mixer sdl
PORTDOCS= readme.html
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/games/quackle/Makefile b/games/quackle/Makefile
index 559d0ef72901..8c4aeabb8498 100644
--- a/games/quackle/Makefile
+++ b/games/quackle/Makefile
@@ -18,7 +18,7 @@ LICENSE_COMB= dual
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/quacker
-USE_GMAKE= yes
+USES= gmake
USE_GCC= any
USE_QT4= gui moc_build qmake_build
MAKE_JOBS_SAFE= yes