aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-04-11 06:03:33 +0800
committerpav <pav@FreeBSD.org>2008-04-11 06:03:33 +0800
commit4ee815b37ea7633cde82d6c8653ef031cfa406a1 (patch)
treea1aa4187f2978d66a5530eae1416f3801a636b33 /games
parenta91bea3201461c9fc047354e0ce943c8337d956b (diff)
downloadfreebsd-ports-gnome-4ee815b37ea7633cde82d6c8653ef031cfa406a1.tar.gz
freebsd-ports-gnome-4ee815b37ea7633cde82d6c8653ef031cfa406a1.tar.zst
freebsd-ports-gnome-4ee815b37ea7633cde82d6c8653ef031cfa406a1.zip
- Add missing dependency and fix the build
Pointy hat to: danfe
Diffstat (limited to 'games')
-rw-r--r--games/battletanks/Makefile3
-rw-r--r--games/battletanks/files/patch-sdlx-SConscript10
2 files changed, 12 insertions, 1 deletions
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index 71f4b6b97752..880e0d4f4f6c 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -15,7 +15,8 @@ COMMENT= Fast 2D tank arcade game with multiplayer and split-screen modes
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
openal.0:${PORTSDIR}/audio/openal \
- expat.6:${PORTSDIR}/textproc/expat2
+ expat.6:${PORTSDIR}/textproc/expat2 \
+ vorbisfile.5:${PORTSDIR}/audio/libvorbis
USE_BZIP2= yes
USE_LDCONFIG= yes
diff --git a/games/battletanks/files/patch-sdlx-SConscript b/games/battletanks/files/patch-sdlx-SConscript
new file mode 100644
index 000000000000..4619d7d791ce
--- /dev/null
+++ b/games/battletanks/files/patch-sdlx-SConscript
@@ -0,0 +1,10 @@
+--- sdlx/SConscript.orig 2007-11-16 08:26:16.000000000 +0100
++++ sdlx/SConscript 2008-04-10 23:54:03.000000000 +0200
+@@ -14,7 +14,6 @@
+ #c_map_env.Append(CXXFLAGS=['-fforce-addr', '-fprefetch-loop-arrays'])
+ c_map = c_map_env.SharedObject('c_map.cpp')
+ #libs.append('GL')
+- libs.append('rt')
+ libs.append('X11')
+ env.Append(LINKFLAGS=' -Wl,-rpath-link build/' + env['mode'] + '/mrt')
+ else: