aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-01-02 09:51:11 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:17:30 +0800
commit4fecaf09c1011a0c6e7306b67fc6c2c8d6bd67bd (patch)
tree4002a273642352b5ae4344367514d816f9ff7949 /games
parent95693101c56a47048afa4c11d8a7be241a98bd00 (diff)
downloadfreebsd-ports-gnome-4fecaf09c1011a0c6e7306b67fc6c2c8d6bd67bd.tar.gz
freebsd-ports-gnome-4fecaf09c1011a0c6e7306b67fc6c2c8d6bd67bd.tar.zst
freebsd-ports-gnome-4fecaf09c1011a0c6e7306b67fc6c2c8d6bd67bd.zip
Fix up Makefiles for ports that used to fetch from www.sourcefiles.org.
It is gone. While here, chase other mastersites, pet portlint, and set DEPRECATED for ports that do not fetch from alternative sites. Note: most of these ports are ancient and unmaintained.
Diffstat (limited to 'games')
-rw-r--r--games/adgali/Makefile5
-rw-r--r--games/tuxpuck/Makefile7
2 files changed, 9 insertions, 3 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 7ab60847d7f5..0d09425ef6ca 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -5,7 +5,7 @@ PORTNAME= adgali
PORTVERSION= 0.2.4
PORTREVISION= 15
CATEGORIES= games devel
-MASTER_SITES= http://www.sourcefiles.org/Programming/Libraries/Games/
+MASTER_SITES= # disappeared
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source game library useful for 2D game development
@@ -13,6 +13,9 @@ COMMENT= Open source game library useful for 2D game development
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Mastersite disappeared
+EXPIRATION_DATE= 2018-03-01
+
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libfreetype.so:print/freetype2
diff --git a/games/tuxpuck/Makefile b/games/tuxpuck/Makefile
index fb23f8753d3f..66d4cc7cdb2d 100644
--- a/games/tuxpuck/Makefile
+++ b/games/tuxpuck/Makefile
@@ -5,20 +5,23 @@ PORTNAME= tuxpuck
PORTVERSION= 0.8.2
PORTREVISION= 23
CATEGORIES= games
-MASTER_SITES= http://www.sourcefiles.org/Games/Sports/Miscellaneous/
+MASTER_SITES= # disappeared
MAINTAINER= ports@FreeBSD.org
COMMENT= Shufflepuck Cafe Clone
LICENSE= GPLv2
+DEPRECATED= Mastersite disappeared
+EXPIRATION_DATE= 2018-03-01
+
LIB_DEPENDS= libpng.so:graphics/png \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \
libfreetype.so:print/freetype2
-USE_SDL= sdl
USES= gmake jpeg
+USE_SDL= sdl
ALL_TARGET= ${PORTNAME}
MAKE_JOBS_UNSAFE= yes