aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-26 05:13:59 +0800
committerbapt <bapt@FreeBSD.org>2013-07-26 05:13:59 +0800
commit5391cc1b274680394b012e9ce3e72cbbef1396e1 (patch)
tree462cd77a43deda0142b0abcaa126e584a5dcd6f2 /games
parent0c68f0353eec188b9a3a186f39eb392b651ca5be (diff)
downloadfreebsd-ports-gnome-5391cc1b274680394b012e9ce3e72cbbef1396e1.tar.gz
freebsd-ports-gnome-5391cc1b274680394b012e9ce3e72cbbef1396e1.tar.zst
freebsd-ports-gnome-5391cc1b274680394b012e9ce3e72cbbef1396e1.zip
Fix build with linker that does not copy the dt_need from libraries it links
with like recent binutils. [1] While here: - trim headers - convert to new options framework - remove shlib version - convert USE_GMAKE -> USES=gmake Obtained from: DPorts [1]
Diffstat (limited to 'games')
-rw-r--r--games/tuxpaint/Makefile19
-rw-r--r--games/tuxpaint/files/patch-Makefile11
2 files changed, 19 insertions, 11 deletions
diff --git a/games/tuxpaint/Makefile b/games/tuxpaint/Makefile
index 173158ec1c40..fa07063b1ba7 100644
--- a/games/tuxpaint/Makefile
+++ b/games/tuxpaint/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tuxpaint
-# Date created: 14 Jul 2005
-# Whom: Alejandro Pulver <alejandro@varnet.biz>
-#
+# Created by: Alejandro Pulver <alejandro@varnet.biz>
# $FreeBSD$
-#
PORTNAME= tuxpaint
PORTVERSION= 0.9.21
@@ -14,13 +10,14 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Drawing program designed for young children
-LIB_DEPENDS= fribidi.3:${PORTSDIR}/converters/fribidi \
- paper.2:${PORTSDIR}/print/libpaper
+LIB_DEPENDS= fribidi:${PORTSDIR}/converters/fribidi \
+ paper:${PORTSDIR}/print/libpaper
+
+OPTIONS_DEFINE= DOCS
USE_GNOME= librsvg2
USE_SDL= image mixer sdl ttf pango
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PREFIX="${PREFIX}" \
@@ -37,7 +34,9 @@ MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
MANCOMPRESSED= yes
MAN1= tp-magic-config.1 tuxpaint.1 tuxpaint-import.1
-.if defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET= install-bin install-data install-man install-magic-plugins \
install-magic-plugin-dev install-icon install-gettext \
install-im install-importscript install-default-config \
diff --git a/games/tuxpaint/files/patch-Makefile b/games/tuxpaint/files/patch-Makefile
index 47d1ddf99c9e..bc1eb3d930e9 100644
--- a/games/tuxpaint/files/patch-Makefile
+++ b/games/tuxpaint/files/patch-Makefile
@@ -1,5 +1,14 @@
---- Makefile.orig 2009-04-29 14:18:57.000000000 +0900
+--- Makefile.orig 2013-03-18 11:17:31.189596000 +0000
+++ Makefile 2010-10-19 01:08:15.000000000 +0900
+@@ -157,7 +157,7 @@ CURSOR_SHAPES:=LARGE
+
+
+ # Libraries, paths, and flags:
+-SDL_LIBS:=$(shell sdl-config --libs) -lSDL_image -lSDL_ttf
++SDL_LIBS:=$(shell sdl-config --libs) -lSDL_image -lSDL_ttf -lpng15 -lintl
+
+ # Sound support
+ SDL_MIXER_LIB:=$(call linktest,-lSDL_mixer,$(SDL_LIBS))
@@ -303,7 +303,8 @@
INSTALLED_MOFILES:=$(patsubst trans/%.mo,$(LOCALE_PREFIX)/%/LC_MESSAGES/tuxpaint.mo,$(MOFILES))